RPI 4 Modele b - Bluetooth ne fonctionne plus

Bonjour Suite a une recente miseea jour de mon RPI4 ( sudo apt-get upgrade)
le bluetooth ne fonctionnne plus
au demarrage du service hciuart.service j’ai les erreurs suivantes :
pi@raspberrypi:~ $ journalctl -xe
– Defined-By: systemd
*-- *
– An ExecStart= process belonging to unit hciuart.service has exited.
*-- *
– The process’ exit code is ‹ exited › and its exit status is 1.
juin 05 14:07:43 raspberrypi systemd[1]: hciuart.service: Failed with result ‹ exit-code ›.
– Subject: Unit failed
– Defined-By: systemd
*-- *
– The unit hciuart.service has entered the ‹ failed › state with result ‹ exit-code ›.
juin 05 14:07:43 raspberrypi systemd[1]: Failed to start Configure Bluetooth Modems connected by UART.
– Subject: L’unité (unit) hciuart.service a échoué
– Defined-By: systemd
*-- *
– L’unité (unit) hciuart.service a échoué, avec le résultat failed.

Si quelqu’un a une idée je suis preneur !
Merci

PS des infos sur ma machine :
pi@raspberrypi:~ $ uname -a
Linux raspberrypi 5.10.17-v7l+ #1421 SMP Thu May 27 14:00:13 BST 2021 armv7l GNU/Linux

hello,

as tu essayé de reinstaller pi-bluetooth ( je viens de faire un upgrade et il apparaît dans les « upgradable »)

sudo apt update
sudo apt upgrade
sudo apt-get --reinstall install pi-bluetooth

Bonsoir
oui et j’ai toujours la meme erreur a la relance du service hciuart.service
juin 05 19:00:49 raspberrypi systemd[1]: Starting Configure Bluetooth Modems connected by UART…
juin 05 19:01:19 raspberrypi btuart[30199]: Initialization timed out.
juin 05 19:01:19 raspberrypi btuart[30199]: bcm43xx_init
juin 05 19:01:19 raspberrypi systemd[1]: hciuart.service: Control process exited, code=exited, status=1/FAILURE
juin 05 19:01:19 raspberrypi systemd[1]: hciuart.service: Failed with result ‹ exit-code ›.
juin 05 19:01:19 raspberrypi systemd[1]: Failed to start Configure Bluetooth Modems connected by UART.

il semble qu’il y a un pb de driver ( sur la commande ..$ sudo hciattach /dev/ttyAMA0 bcm43xx 921600 noflow)
mais bon je nage complet …
Merci

Je n’utilise pas la version de Raspbian OS de 2021, il débarque le Bluetooth sans raison.
J’ai parlé de ce problème;

[Histoire] Dernière version de Raspbian (20-03-2021) et Bluetooth
Raspbian OS et Bluetooth (CLI)

Ma (La) solution est d’utiliser une ancienne version et de ne pas faire le « upgrade ». Le problème ne semble pas affecter les versions Desktop.

Rasbian OS Version 14 Février 2020 - Stable
Lite : Index of /raspbian_lite/images/raspbian_lite-2020-02-14
Desktop : Index of /raspbian/images/raspbian-2020-02-14
Desktop Full : Index of /raspbian_full/images/raspbian_full-2020-02-14

Bonjour
je confirme qua c’est bien suite a a un upgrade que le bluetooth est inoperant
mais j’avais besoin d’installer docker et il etait conseille de mettre a jour raspbian

et le retour de pi-bluetooth a la version 0.1.15 qui fonctionnait precedement ne suffit pas pour que ca re fonctionne !
je continue a nager !

bizarrement chez moi ( pi 4 modele B Rev 1.1 ) le service se lance !

pi@raspberrypi:~ $ sudo systemctl status hciuart.service
● hciuart.service - Configure Bluetooth Modems connected by UART
   Loaded: loaded (/lib/systemd/system/hciuart.service; disabled; vendor preset: enabled)
   Active: active (running) since Sun 2021-06-06 16:32:03 CEST; 1min 19s ago
  Process: 1091 ExecStart=/usr/bin/btuart (code=exited, status=0/SUCCESS)
 Main PID: 1120 (hciattach)
    Tasks: 1 (limit: 4915)
   CGroup: /system.slice/hciuart.service
           └─1120 /usr/bin/hciattach /dev/serial1 bcm43xx 3000000 flow -

juin 06 16:31:56 raspberrypi systemd[1]: Starting Configure Bluetooth Modems connected by UART...
juin 06 16:32:03 raspberrypi btuart[1091]: bcm43xx_init
juin 06 16:32:03 raspberrypi btuart[1091]: Flash firmware /lib/firmware/brcm/BCM4345C0.hcd
juin 06 16:32:03 raspberrypi btuart[1091]: Set Controller UART speed to 3000000 bit/s
juin 06 16:32:03 raspberrypi btuart[1091]: Device setup complete
juin 06 16:32:03 raspberrypi systemd[1]: Started Configure Bluetooth Modems connected by UART.
pi@raspberrypi:~ $ sudo apt-cache policy pi-bluetooth
pi-bluetooth:
  Installé : 0.1.17
  Candidat : 0.1.17
 Table de version :
 *** 0.1.17 500
        500 http://archive.raspberrypi.org/debian buster/main armhf Packages
        100 /var/lib/dpkg/status
pi@raspberrypi:~ $ rpi-eeprom-config
BOOT_UART=0
WAKE_ON_GPIO=1
POWER_OFF_ON_HALT=0
                                                                              
                                                                              
                                                                              
                                                                              
                                                                              
                                                                              
                                                                              
                                                                              
                                                                              
                                                                              
                                                                             
                                                                              
             
[all]
BOOT_ORDER=0xf14
pi@raspberrypi:~ $ sudo /opt/vc/bin/vcgencmd version
May 27 2021 14:02:15 
Copyright (c) 2012 Broadcom
version 7d9a298cda813f747b51fe17e1e417e7bf5ca94d (clean) (release) (start)
pi@raspberrypi:~ $ cat /proc/cpuinfo | grep Model
Model		: Raspberry Pi 4 Model B Rev 1.1

ça a marcher jusqu’au moment ou j’ai mis le service enable et là ça marche plus !

WTF ?

A priori j’ai trouve une solution qui marche ici : UART configuration - Raspberry Pi Documentation

## Disable Linux serial console

By default, the primary UART is assigned to the Linux console. If you wish to use the primary UART for other purposes, you must reconfigure Raspberry Pi OS. This can be done by using raspi-config:

1. Start raspi-config: sudo raspi-config.
2. Select option 3 - Interface Options.
3. Select option P6 - Serial Port.
4. At the prompt Would you like a login shell to be accessible over serial? answer ‹ No ›
5. At the prompt Would you like the serial port hardware to be enabled? answer ‹ Yes ›
6. Exit raspi-config and reboot the Pi for changes to take effect.

Je vous en dit plus !

effectivement en supprimant la liaison série ( enable_uart=0 ds /boot/config.txt modifié par raspi-config )
ça remarche !

il y aurait peut être une solution en utilisant une autre uart ( 1,2,3,4,5 ) mais j’y comprend rien !
certains des pins a utiliser n’existe par ds le pinout !!!

raspi-gpio funcs pour avoir la liste des pins et leurs fonction
dtoverlay -h uart1 celui là ( enable_uart=1 et dtoverlay=uart1 ds /boot/config.txt ) devrait permettre la liaison serie sur les pins GPIO14 et GPIO15 ! en esperant que le bluetooth reste sur son uart (0 ? ) …

source : UART configuration - Raspberry Pi Documentation