SSH-connexion failed

Bonjour à tous,
Je suis dans la panade depuis un bon moment et je ne trouve pas ma solution… J’espère que parmi cette communauté je trouverai ma solution.

Mon problème est la connexion ssh sur mon raspberry.
La connexion ssh a très bien fonctionné pendant 6 mois/1an, et depuis 2 mois impossible, plus rien…

Avec un PC j’utilise PUTTY pour me connecter et j’ai à chaque tentative le message « access denied », depuis mon iPhone j’utilise iTerminal et là encore impossible j’ai le message suivant " failed to be authentificated by your user name and password".
Je précise que le service SSH est actif sur mon raspberry.

Pour me dépanner, j’ai branché sur mon raspberry un écran et un clavier, en direct/interne je me « connecte » (pas d’identifiant ou de mdp demandé, je suis directement connecté en pi@raspberrypi:~$)sur la console et vérifier le « status » de ma connexion ssh, celle-ci me confirme bien que le service ssh est actif.

Quand je tape la commande pour vérifier les log de connexion ssh sur mon raspberry, je vois bien mes tentatives depuis mon pc avec les logs :
pam_unix(sshd:auth):authentification failure; logname = uid=0 euid=0 tty=ssh ruser = rhost=192.168.x.xxx user=pi
Failed password for pu from 192.168.x.xxx port 56566 ssh2

Je ne pense pas avoir changer le mot de passe de connexion ssh qui est raspberry par défaut mais à croire que oui, est aucune idée de ce que j’ai pu mettre… sauf mauvaise manipulation de ma part…

Existe-t-il via le terminal du raspberry une commande pour retrouver ce mot de passe ou le réinitialiser ? C’est un peu dommage de ne pas pouvoir se servir de la connexion à distance. Et bien sur dans l’idéal sans passer par la case formatage complet de mon installation. :slight_smile:
C’est bien le mot de passe de la connexion ssh qui ne fonctionne pas ou du moins qui me pose problème.

Merci à vous tous,

Bonjour,

Dans un premier temps, tester de changer le mot de passe de pi avec la commande passwd. Il va demander l’ancien mot de passe si il a été changé, raspberry ne fonctionnera pas.

Dans ce cas se connecter changer le mot de passe avec sudo , commande sudo passwddans ce cas vu que c’est l’utilisateur pi, il ne sera pas demandé l’ancien mot de passe.

Si le mot de passe n’a pas été changé par tes soins et que le pi est accéssible sur Internet, il est possibe qu’il ait été piraté, ça c’est produit à quelqu’un il y a queques temps. Lorsque’un Raspberry Pi est accéssible sur Internet il faut impérativement changer le mot de passe de l’utilisateur PI car c’est le premier mot de passe qui est essayé par les pirates pour y accéder bien évidament.

A+

Bonsoir Jelopo,
Tout d’abord Merci de ton intérêt et ta réponse.
Ta manipulation m’a permit de vérifier le mot de passe et celui ci est correct, je l’ai tout de même changé et retester de me connecter en ssh et toujours un échec de connexion! :face_with_symbols_over_mouth::face_with_symbols_over_mouth:
Je dois donc avoir un autre problème quelque part, pas de mot de passe mais de droit ou de blocage au ssh! C’est quand même bizarre ça.
Est ce qu’il y a des droits à spécifique à débloquer (suite à une mise à jour) de raspbian, ou de sa box adsl ou autre ?
Bonne soirée,

Yo

Déjà petite notion il faut savoir que tu n’as pas de « mot de passe ssh ».
Le mot de passe est celui de compte utilisateur système (cad Raspbian) soit pi.

SSH te permet de te connecter à ton compte utilisateur à distance & de profiter des permissions qu’il dispose. La commande passwd te permet de changer le mot de passe de compte utilisateur.

Les adresses IP doivent être bonnes car tu as des logs dans ton raspberry donc la connexion à marché : on peut exclure un problème au niveau du routeur.
(Pour info : l’idéal est d’avoir une IP fixe pour raspberry afin que le routeur ne le change pas (DHCP)).

Vu tes adresses IP tu te connectes en local.

As-tu mise à jour raspbian dernièrement ?

Faut déjà s’assurer de la configuration d’SSH :
As tu effectué des modification dessus ?

Peux tu nous donner le contenu du fichier de paramétrage du serveur ssh ?
C’est le fichier sshd_config :
nano /etc/ssh/sshd_config

Sans voir le fichier de configuration je pencherai quand même pour un problème de clefs (ça met déjà arrivé).

En faite, quand tu te connectes pour la première fois en SSH, le serveur ssh envoi un clef d’identification afin que la communication s’effectue de manière sécurisé.
En gros ton raspberry sait que les données qu’il reçoit provienne de ton pc & inversement.
Et C’est pour ça que tu as ce message avec Putty quand tu te connectes la première fois en ssh :
Capture
(ca te rappel quelque chose ?)

Tu peux faire la manipulation suivante :

cd /etc/ssh/
rm /etc/ssh/ssh_host_*
dpkg-reconfigure openssh-server

1er ligne : on se met dans le dossier ssh
2ème ligne : on supprime les différentes clefs qu’utilise le serveur ssh. Attention de bien saisir ssh_host_* au risque de supprimer ton les fichiers.
3ème ligne : on régénère les clefs

source : https://wiki.debian.org/fr/SSH#R.2BAOk-g.2BAOk-n.2BAOk-rer_les_cl.2BAOk-s_h.2BAPQ-te

Bonjour pytotux,
concernant l’adresse ip, je suis bien en fixe en effet. Normalement :wink:
En effet, je fais des tests en local, depuis l’extérieur ça ne fonctionne pas mieux, alors qu’également ça fonctionnait très bien.
Des modifications sur le fichier ssh, je n’en suis pas sur, sauf si mauvaise manip de ma part.
Voici le contenu du fichier demandé :
# $OpenBSD: sshd_config,v 1.100 2016/08/15 12:32:04 naddy Exp $

# This is the sshd server system-wide configuration file.  See
# sshd_config(5) for more information.

# This sshd was compiled with PATH=/usr/bin:/bin:/usr/sbin:/sbin

# The strategy used for options in the default sshd_config shipped with
# OpenSSH is to specify options with their default value where
# possible, but leave them commented.  Uncommented options override the
# default value.

#Port 22
#AddressFamily any
#ListenAddress 0.0.0.0
#ListenAddress ::

#HostKey /etc/ssh/ssh_host_rsa_key
#HostKey /etc/ssh/ssh_host_ecdsa_key
#HostKey /etc/ssh/ssh_host_ed25519_key

# Ciphers and keying
#RekeyLimit default none

# Logging
#SyslogFacility AUTH
#LogLevel INFO

# Authentication:

#LoginGraceTime 2m
#PermitRootLogin prohibit-password
#StrictModes yes
#MaxAuthTries 6
#MaxSessions 10

#PubkeyAuthentication yes

# Expect .ssh/authorized_keys2 to be disregarded by default in future.
#AuthorizedKeysFile     .ssh/authorized_keys .ssh/authorized_keys2

#AuthorizedPrincipalsFile none

#AuthorizedKeysCommand none
#AuthorizedKeysCommandUser nobody

# For this to work you will also need host keys in /etc/ssh/ssh_known_hosts
#HostbasedAuthentication no
# Change to yes if you don't trust ~/.ssh/known_hosts for
# HostbasedAuthentication
#IgnoreUserKnownHosts no
# Don't read the user's ~/.rhosts and ~/.shosts files
#IgnoreRhosts yes

# To disable tunneled clear text passwords, change to no here!
#PasswordAuthentication yes
#PermitEmptyPasswords no

# Change to yes to enable challenge-response passwords (beware issues with
# some PAM modules and threads)
ChallengeResponseAuthentication no

# Kerberos options
#KerberosAuthentication no
#KerberosOrLocalPasswd yes
#KerberosTicketCleanup yes

#KerberosGetAFSToken no

# GSSAPI options
#GSSAPIAuthentication no
#GSSAPICleanupCredentials yes
#GSSAPIStrictAcceptorCheck yes
#GSSAPIKeyExchange no

# Set this to 'yes' to enable PAM authentication, account processing,
# and session processing. If this is enabled, PAM authentication will
# be allowed through the ChallengeResponseAuthentication and
# PasswordAuthentication.  Depending on your PAM configuration,
# PAM authentication via ChallengeResponseAuthentication may bypass
# the setting of "PermitRootLogin without-password".
# If you just want the PAM account and session checks to run without
# PAM authentication, then enable this but set PasswordAuthentication
# and ChallengeResponseAuthentication to 'no'.
UsePAM yes

#AllowAgentForwarding yes
#AllowTcpForwarding yes
#GatewayPorts no
X11Forwarding yes
#X11DisplayOffset 10
#X11UseLocalhost yes
#PermitTTY yes
PrintMotd no
#PrintLastLog yes
#TCPKeepAlive yes
#UseLogin no
#UsePrivilegeSeparation sandbox
#PermitUserEnvironment no
#Compression delayed
#ClientAliveInterval 0
#ClientAliveCountMax 3
#UseDNS no
#PidFile /var/run/sshd.pid
#MaxStartups 10:30:100

#PermitTunnel no
#ChrootDirectory none
#VersionAddendum none

# no default banner path
#Banner none

# Allow client to pass locale environment variables
AcceptEnv LANG LC_*

# override default of no subsystems
Subsystem       sftp    /usr/lib/openssh/sftp-server

# Example of overriding settings on a per-user basis
#Match User anoncvs
#       X11Forwarding no
#       AllowTcpForwarding no
#       PermitTTY no
#       ForceCommand cvs server

Ensuite pour le message d’avertissement, en effet je l’ai bien eu, je ne l’ai plus eu depuis longtemps.

Concernant la manip que tu me demandes de faire, j’ai essayé, ils me disent que je n’ai pas les autorisations car le fichier est protégé en écriture.

rm : supprimer fichier (protégé en écriture) ‹ /etc/ssh/ssh_host_dsa_key › ?

Dois-je écrire « sudo » avant ?

Du fait que je ne peux faire l’étape 2, je n’ai pas encore procédé à l’étape 3…

Merci pytotux et les autres qui suivent :wink:

Info complémentaire, j’ai quand meme essayé de faire ta manip en rajoutant sudo, je n’ai pas eu le message d’erreur, j’ai donc ensuite faire l’étape 3 et là j’ai eu le message :

dpkg-query: le paquet « opeenssh-server » n’est pas installé et aucune information n’est disponible
Utilisez dpkg --info (= dpkg-deb --info) pour examiner les fichiers
archives, et dpkg --contents (= dpkg-deb --contents) pour afficher leur
contenu.
/usr/sbin/dpkg-reconfigure: opeenssh-server n’est pas installé

J’ai ensuite essayé de me connecté en ssh, aucune réponse, je me suis dit que je le service ssh était désactivé, je suis allé voir dans raspi-config, pour le rendre « enable » et j’ai retenté une nouvelle fois, et là quand je clique sur « connect » dans mon appli, la fenetre se ferme directement et je reviens sur mon écran principal d’iPhone.

Et avec Putty j’ai le message suivant : network error : software caused connection error

J’espère que ça va se solutionner du coup…

Mais quand je ping toujours raspberry, il répond toujours présent.

y a un truc bizarre.
D’une part dans le fichier de configuration tu as un commentaire devant la ligne Port 22.
de souvenir si le fichier par défaut n’a pas cette ligne commenté;
D’autre part, on te dit que openssh-server n’est pas installé…

1- Tu utilises ton raspberry pour quoi ? et pourquoi te connectes tu sur ton raspbery en ssh ?
Utilises tu la connexion ssh en-dehors de ton réseau local (donc à l’extérieur de chez toi) ?
Si, oui, c’est juste pour le fun ou y a un vrai besoin ?

2 - As-tu modifié un jour le fichier sshd_config ?

3- On va vérifier si ton paquet openssh-server est installé :

Que te retourne la commande

sudo dpkg -l openssh-server

Nota : « dpkg -l » peut te lister tous tes paquets. Rajouter un ou plusieurs noms de paquets de permet de vérifier leur présence.

4- Et, peux nous donner le résultat de la commande suivante :

sudo service ssh status

Comme dit précédemment si tu as ouvert la connexion à ton raspberry à l’extérieur avec le mot de passe par défaut & sans sécurité (config d’un firewall par exemple) ce n’est pas une très bonne idée.
T’as des gars qui s’amuse à tester la connexion ssh avec toutes les combinaison d’adresses IP possibles et imaginables.

En effet j trouve ça bizarre aussi que Port 22 soit en commentaire avec le dièse.
J’ai fait un upgrade et un update, ça a duré pas mal de temps et j’ai de nouveau le ssh d’installé je pense.
Pour répondre dans l’ordre à tes questions :
1, j’utilise mon raspberry pour faire tourner domoticz, des fois je dois vérifier avec la connexion ssh si domoticz est bien lancé, c’est très très rare mais des fois il faut le réactiver, et via le ssh c’est très pratique. Je peux faire ça depuis mon bureau, depuis mon téléphone si je suis à droite à gauche.
Car mon raspberry n’a pas d’écran en temps normal, il est à côté de mon tableau électrique et je n’y touche plus. Depuis mon pb de ssh je l’ai mis dans ma chambre avec un écran dédié, c’est pas trop cool.

2,Modifier sshd_config, je ne pense pas avoir fait quelque chose de ce genre

3, retour de la commande sudo dpkg :

pi@raspberrypi:~ $ sudo dpkg -l openssh-server
Souhait=inconnU/Installé/suppRimé/Purgé/H=à garder
| État=Non/Installé/fichier-Config/dépaqUeté/échec-conFig/H=semi-installé/W=attend-traitement-déclenchements
|/ Err?=(aucune)/besoin Réinstallation (État,Err: majuscule=mauvais)
||/ Nom Version Architecture Description
++±==============-============-============-=================================
ii openssh-server 1:7.4p1-10+d armhf secure shell (SSH) server, for se

4, résulat de sudo service

pi@raspberrypi:~ $ sudo service ssh status
● ssh.service - OpenBSD Secure Shell server
Loaded: loaded (/lib/systemd/system/ssh.service; enabled; vendor preset: enabled)
Active: active (running) since Sun 2019-08-25 12:03:47 CEST; 1h 4min ago
Process: 407 ExecStartPre=/usr/sbin/sshd -t (code=exited, status=0/SUCCESS)
Main PID: 470 (sshd)
Tasks: 3 (limit: 4915)
CGroup: /system.slice/ssh.service
├─ 470 /usr/sbin/sshd -D
├─2393 sshd: pi [priv]
└─2394 sshd: pi [net]

août 25 13:08:07 raspberrypi sshd[2382]: Disconnected from xxx.xx.xx.xxx port xxxxx [preaut
août 25 13:08:08 raspberrypi sshd[2384]: Invalid user camera from xxx.xx.xx.xx port xxxxx
août 25 13:08:08 raspberrypi sshd[2384]: input_userauth_request: invalid user camera [preau
août 25 13:08:08 raspberrypi sshd[2384]: pam_unix(sshd:auth): check pass; user unknown
août 25 13:08:08 raspberrypi sshd[2384]: pam_unix(sshd:auth): authentication failure; logna
août 25 13:08:09 raspberrypi sshd[2393]: pam_unix(sshd:auth): authentication failure; logna
août 25 13:08:10 raspberrypi sshd[2393]: Failed password for pi from xxx.xx.xx.xx port xx
août 25 13:08:11 raspberrypi sshd[2384]: Failed password for invalid user camera from 106.1
août 25 13:08:11 raspberrypi sshd[2384]: Received disconnect from xxx.xx.xx.xx port xxxxx:1
août 25 13:08:11 raspberrypi sshd[2384]: Disconnected from xxx.xx.xx.xx port xxxxx [preauth

J’ai remplacé les adresses ip et les ports par des séries de xxxxxxx ou xxx.xx.xx.xx

Déjà open ssh est de nouveau présent et actif ! Je ne sais pas ce qu’il s’est passé avec la commande
sudo rm /etc/ssh/ssh_host_*

J’ai refait un sudo service ssh status après une nouvelle tentative de connexion depuis mon iphone, je vois bien ma tentative avec mon adresse ip en « interne » mais je vois aussi une ligne avec "invalid user xj from 162.238.213.216 port 49814

Est-ce une indication d’une connexion extérieur, genre un piratage ? ou rien à voir c’est une ligne du raspberry ?

Nouvelle commande sudo service ssh status ==>

août 25 13:25:10 raspberrypi sshd[2926]: Invalid user mcm from 189.213.210.35 port 51717
août 25 13:25:10 raspberrypi sshd[2926]: input_userauth_request: invalid user mcm [preauth]
août 25 13:25:10 raspberrypi sshd[2926]: pam_unix(sshd:auth): check pass; user unknown
août 25 13:25:10 raspberrypi sshd[2926]: pam_unix(sshd:auth): authentication failure; logname= uid=0 euid=0 tty=ssh ruser= rhost=189.213.210.35
août 25 13:25:11 raspberrypi sshd[2924]: Failed password for invalid user enlace from 35.187.248.21 port 57308 ssh2
août 25 13:25:12 raspberrypi sshd[2924]: Received disconnect from 35.187.248.21 port 57308:11: Bye Bye [preauth]
août 25 13:25:12 raspberrypi sshd[2924]: Disconnected from 35.187.248.21 port 57308 [preauth]
août 25 13:25:13 raspberrypi sshd[2926]: Failed password for invalid user mcm from 189.213.210.35 port 51717 ssh2
août 25 13:25:13 raspberrypi sshd[2926]: Received disconnect from 189.213.210.35 port 51717:11: Bye Bye [preauth]
août 25 13:25:13 raspberrypi sshd[2926]: Disconnected from 189.213.210.35 port 51717 [preauth]

Ce sont des tentatives de connexions ???

EXPLICATIONS
La commande :
sudo rm /etc/ssh/ssh_host_*
supprime tous les fichiers de ton dossier commençant par ssh_host_.
Il s’agit d’un ensemble de certificat permettant l’authentification.
La commande
dpkg-reconfigure openssh-server

A pour but de recréer ces certificats permettant l’authentification.

(précision : avant de te donner les commandes je les ai re-testé sur mon raspberry je n’ai pas rencontré de problèmes)

CONSTAT
En relisant le retour cette commande j’ai constaté que tu as ça :

dpkg-query: le paquet « opeenssh-server » n’est pas installé et aucune information n’est disponible
Utilisez dpkg --info (= dpkg-deb --info) pour examiner les fichiers
archives, et dpkg --contents (= dpkg-deb --contents) pour afficher leur
contenu.
/usr/sbin/dpkg-reconfigure: opeenssh-server n’est pas installé

Le paquet c’est openssh-server et non peenssh-server.
C’est un copier coller que tu as fais ? Si oui, il faut que tu saisisse correctement le nom du paquet :slight_smile:

J’espère que c’est ça sinon j’ai du mal à voir d’où ça vient car :

Ton Résultat de la commande sudo service ssh status
On est OK le service SSH tourne donc pas de soucis de ce côté là. Donc openssh-server est bien installé & reconnu.

ACTIONS si il s’agit bien d’une erreur de saisie

a- Si c’est bien une erreur de saisie refait un
sudo dpkg-reconfigure openssh-server

b-Puis ouvre le fichier etc/ssh/sshd_config et modifie/décommente les lignes avec les attirbuts que j’ai indiqué :

Port 2225
PermitRootLogin no
MaxSessions 1
PasswordAuthentication yes
MaxAuthTries 3

explication :
Port -> on change le port qui est 22 par défaut limitant les tentatives de connexion automatique par un intrut. Il faudra impérativement indiquer le port 2225 lorsque tu te connectes sur Putty où sur ton Iphone.
Définir un port est obligatoire.
Je viens de tester en commentant mon port dans le fichier : ça me pète une erreur.
PermitRootLogin : on refuse toute connexion du compte root.
MaxSessions : on autorise uniquement une session mais tu peux mettre plus si besoin
PasswordAuthentication : on applique la méthode d’autentification par mot de passe du compte système (raspbian)
MaxAuthTries : on définit le nombre de tentative de connexion maximum (tu peux définir le nombre que tu souhaites).

c-Puis essaye de te connecter

  • Concernant les logs de connexion :

Oui il y a une IP externe qui se connecte.
Sur Ton smartphone -->
tu te connectes en local (cad que tu accèdes à Internet & ton réseau local en wifi avec ton iphone)
ou tu te connectes avec le réseau 3g/4g de ton iphone ?

Car l’adresse IP peut être uniquement celle de ton Iphone

Si rien de marche on verra si on fait une réinstalle d’openshh-server.

Ça devait bien être une erreur de frappe de ma part !

Je fais bien aussi le sudo dpkg-reconfigure OpenSSh-server et ça tourne pendant 2/3 secondes et ça semble bon et par contre quand je tape nano etc/ssh/sshd_config maintenant il me dit que le répertoire etc/ssh n’existe pas, le fenêtre qui s’ouvre est vierge… alors que sudo service ssh status m’indique bien que ssh est active.

Euh… Vérifies que le dossier SSH existe dans le dossier etc :

`cd /etc/`
ls -l

Si dans la liste il y a le dossier SSH positionnes toi dans dans le dossier ssh
cd /etc/ssh
et peux tu me donner le résultat de la commande
ls -l

Avec un peu de mal car je n’ai aucune connaissance du langage « linux » j’ai un peu mis de temps à comprendre comment procéder mais c’est comme cela qu’on apprend, ou découvre tout au moins :slight_smile:

Voici donc le résultat :
dossier ssh existe
Contenu du dossier ssh :

pi@raspberrypi:/etc/ssh $ ls -l
total 576
-rw-r–r-- 1 root root 553122 mars 1 2018 moduli
-rw-r–r-- 1 root root 1723 mars 1 2018 ssh_config
-rw-r–r-- 1 root root 3298 mars 1 2018 sshd_config
-rw------- 1 root root 227 août 25 11:59 ssh_host_ecdsa_key
-rw-r–r-- 1 root root 178 août 25 11:59 ssh_host_ecdsa_key.pub
-rw------- 1 root root 411 août 25 11:59 ssh_host_ed25519_key
-rw-r–r-- 1 root root 98 août 25 11:59 ssh_host_ed25519_key.pub
-rw------- 1 root root 1679 août 25 11:59 ssh_host_rsa_key
-rw-r–r-- 1 root root 398 août 25 11:59 ssh_host_rsa_key.pub

Donc j’en conclue que ce dossier doit exister et qu’il y a des informations dedans.

Quand je tape de nouveau nano… toujours message : etc/ssh n’existe pas…

rohhhh ça devient un peu pénible non ?

Merci encore.

Grrr je n’avais pas vu mais t’as du saisir
cd etc/ssh
et non
cd /etc/ssh
T’as du oublier un slash.

Bref… Notion à bien retenir:
A- La racine de ton système de fichier c’est /
Tu retrouveras les dossiers comme home, etc, ou var.

B-

  • La commande cd suivie d’un chemin d’accès permet de te positionner dans le dossier indiqué
  • La commande ls permet de lister les dossiers et fichier de là où tu te situe. Si il est suivi de l’attribut -l on va lister les éléments avec des infos
  • La commande rm supprime les fichiers où tu te situes si tu n’indiques pas de chemin d’accès. Si tu rajoutes l’attribut -r cela va supprimer les dossiers en plus des fichiers
  • L’étoile en bout de ligne signifie '« tout ce qui suit » donc la commande rm /etc/ssh/ssh_host_* va supprimer tous les fichiers qui commencent par ssh_host_ dans le dossier /etc/ssh/

Je te conseille vivement de prendre connaissance des commandes de bases pour toutes manipulations de ton système en ssh.
Une source parmis d’autres :
https://doc.ubuntu-fr.org/tutoriel/console_ligne_de_commande

Concernant le problème

La manipulation elle a du marcher à un moment ou un autre car on a les certificats présent créé le 25/08 à 11h59.

Donc si ça ne marche pas … le problème vient de ton fichier de configuration de configuration sshd_config

DEUX SOLUTIONS :

1-Soit tu corriges le fichier.

2-Soit on désinstalle et purge les fichiers de configuration d’openssh-server et on ré-installe tout.

Pour le point 1… on va pas s’embêter

a-tu te positionnes dans le dossier
cd /etc/ssh

b-tu renommes le fichier sshd_config pour le conserver au cas où
sudo mv sshd_config sshd_config_backup

c-tu crées un nouveau fichier sshd_config

sudo nano sshd_config

et tu colles le contenu ci-dessous (raccourcis pour coller sous Nano Ctrl+u ):

#Connexion on définit le port d’écoute
Port 2225

#Gestion de l’Accès ssh
PermitRootLogin no
MaxSessions 3
PasswordAuthentication yes
MaxAuthTries 3

#???
ChallengeResponseAuthentication no

#On limite aux Comptes utilisateurs suivant
AllowUsers pi

#PAM
UsePAM yes

#Divers
X11Forwarding no
PrintMotd no

d- tu redémarres ton service ssh

sudo service sshd restart

e-tu vérifies que le service fonctionne bien si tu as envie

sudo service sshd status

f-tu te connectes

Sous putty ou ton iphone n’oublie pas de préciser le port qui n’est plus 22 mais 2225

Pour la deuxième possibilité sa résume à :

sudo apt --purge remove  openssh-server
sudo apt install openssh-server

Après la première commande tu peux refaire les commandes suivantes pour être sur que ton système soit ok
sudo apt update
sudo apt upgrade
sudo apt autoremove

Puis vérifier que dans le fichier sshd_config la ligne du port est bien décommenté.

Bonjour,
tout d’abord excuse moi, je n’ai pas vu la réponse, je n’ai donc encore rien fait.
Concernant les commandes linux, en effet je m’y suis un peu penché et je me suis servi de ce https://juliend.github.io/linux-cheatsheet/ pour comprendre ce que tu me disais de faire afin de ne pas être un « mouton » et faire simplement copier coller ce que tu me disais.

La deuxième solution semble radicale et plus simple, mais je testerai bien également la solution 1 avant.

Je te dirai ce qu’il en résulte.

Merci encore.

Pas de soucis on est sur un forum ! Immédiateté ne fait pas office de règle :wink:

C’est important de maitriser au moins le minimum vitae pour comprendre les commandes que tu peux lires de trois à gauche.
Sinon le risque c’est de bousiller ton système et de repartir de zéro :slight_smile:

La première semble longue mais c’est rapide.
Y a juste le coller sur Nano qui peut paraître un peu pénible.
Je viens de faire une recherche En faite c’est Ctrl+U pour coller.

source : https://doc.ubuntu-fr.org/nano#copier_coller

Ça commence à m’inquieter, que ce soit la manip 1 ou la 2, rien ne se passe.

Dans les échanges précédents tu me demandé de faire le status service ssh et pas sshd. Est-ce différent ? N’y aurait il pas un couac de ce côté là avec moi ?

Et avec la manip 2 maintenant si je tape sudo service ssh status il me dit « unit ssh.service could not ne found » et idem avec sudo service ssh status…

J’ai bien vérifié que j’avais le dossier ssh créé ce jour à 21h53 dans cd /etc/ssh/ et voici le résultat :

pi@raspberrypi:/etc/ssh $ ls -l
total 552
-rw-r–r-- 1 root root 553122 mars 1 2018 moduli
-rw-r–r-- 1 root root 1723 mars 1 2018 ssh_config
-rw-r–r-- 1 root root 3298 mars 1 2018 sshd_config_backup

Non -> le service est ssh porte bien sur la partie serveur.

Et avec la manip 2 maintenant si je tape sudo service ssh status il me dit « unit ssh.service could not ne found » et idem avec sudo service ssh status…

Tu as du faire une mauvaise manipulation lors de l’installation ou alors y a quelque chose qui coince.

J’ai fais les différentes étapes de la solution 2 en reprenant ce que j’ai noté dans les messages & je n’ai aucun problème.
J’ai désintallé openssh-server en laissant openssh-client
J’ai réinstaller tout comme il faut & je peux me connecter directe, sans modifier le fichier de configuration sshd_config avec le port 22.

Vu le contenu du dossier ssh, la désinstallation avec la purge à du fonctionner : On voit que le fichier ssh_config est bien présent (celui pour la partie cliente de ssh) et le sshd_config absent (partie serveur celui qu’on a désinstaller & purger).

Quand tu saisies la commande suivante, qui permet d’installer le serveur shh, tu as quoi comme résultat :

sudo apt install openssh-server

On verra si on utilise l’option --fix-broken de apt (cela permet de résoudre des problèmes de dépendances de paquet).

Bonjour pytotux,

Voici le résultat de la commande :

pi@raspberrypi:~ $ sudo apt install openssh-serveur
Lecture des listes de paquets… Fait
Construction de l’arbre des dépendances
Lecture des informations d’état… Fait
E: Impossible de trouver le paquet openssh-serveur

Ca ne sent pas très bon je pense.

Faut-il que je relance une installation ?
sudo apt–purge remove openssh-server
sudo apt install openssh-server

D’autres lignes de commande sont nécessaires avant pour supprimer d’autres fichiers potentiels ?

Lorsque j’ai fait l’ensemble des commandes :

sudo apt update
sudo apt upgrade
il m’a indiqué qui’il n’y avait pas assez de place sur dans un certain répertoire du genre var/etc/cache… et que 2 mises à jour ne se ferait pas sur les 11 à faire
Malgré ce message j’ai continué avec la dernière ligne
sudo apt autoremove

Merci encore.