Raspbian et raspberry pi4

Bonjour ;

En septembre 2019, j’ai fait l’acquisition d’un pi 4 4GB. Si je compare cette expérience avec celles faites avec les diverses versions précédentes, cette dernière comprends des aléas que je n’avais pas rencontrés auparavant. J’aimerai en faire un compte rendu ici en espérant avoir des retours de la part de personnes qui ont elles aussi expérimenté l’utilisation de ce raspberry.

La première utilisation s’est faite avec l’mage raspbian + bureau de juillet 2019.
L’installation se passe sans problème. Le démarrage du pi aussi, ainsi que les mises à jour. Reboot sans difficulté. J’en profite pour installer la partition system sur un disque dur, modifie le /boot/cmdline.txt et reboot avec succès.
Quelques redémarrages plus tard, les problèmes commencent à arriver. Le pi refuse de démarrer. Je repasse sur carte SD seule. Ça repart. je fait une vérification du disque dur avec Gparted, réactive le système sur disque dur et relance avec succès … jusqu’au retour des problèmes.

Entre temps une nouvelle image raspbian est sortie (26/09/2019). Je l’installe. Carte SD seule, puis disque dur. Au bout de quelques utilisation le pi passe en mode « safe ». Parfois un CTRL+D suffit à poursuivre le démarrage. Il semblerait que l’accès au système de fichier rencontre des problème. Quand CTRL+D ne suffit pas, je passe en carte SD seule, exécute une vérification du disque dur. Et la ronde recommence. J’ai lu que le firmware devait être amélioré. je me dis que la solution au problème viendra avec les mise à jour. Hélas, non seulement la solution ne vient pas, mais les choses empirent à tel point que même sans disque dur le pi plante lorsque j’active le pavé numérique ou que connecte un périphérique usb.

J’en viens à me demander si les mises à jours ne sont pas en cause. Je tente l’expérience de réinstaller l’image de septembre 2019 sans procéder aux mises à jour. Boot sans problème. Installation du système sur disque dur. Reboot avec succès. Je suis sur cette solution depuis plusieurs jours et pour l’instant je ne rencontre pas de problème.

Il y a quand même des limites. J’ai un écran tft hdmi et malgré les modifications de réglage, impossible d’avoir l’affichage, alors que je l’ai sans problème avec un écran avec sortie DVI et câble dvi/hdmi. Ce même écran tft fonctionne parfaitement avec le pi 3.

Aujourd’hui j’ai téléchargé l’image de février 2020. Le résultat me confirme dans les doutes que je nourris à l’égard de l’évolution de la solution logicielle type raspbian. Avec cette nouvelle image c’est le plantage dés le premier démarrage. Apres avoir réussi à le lancer pendant quelques secondes il se fige. S’il ne se fige pas tout de suite, activer le pavé numérique parvient à le faire.

Conclusion : pour l’instant je continue avec l’image de septembre sans mise à jour.

En espérant pouvoir lire à propos de vos expériences avec le pi 4

Cordialement.

Jacques

Bonjour,

Voir si ce la solution proposée dans ce sujet fonctionne.

A+

Bonjour,
je suis navré par tes deboires, me concernant je suis un newbie sur Linux, et j’ai acheté mon PI4 4GB en Juillet 2019.
Je suis allé crescendo dans la personnalisation de la bete, je fais les mise a jour totes les semaines, j’ai comme toi le boot sur la carte SD et le rootfs sur un SSD en USB3.
Et franchement, je touche du bois, il tourne comme une montre.
J’ai juste rajouté sur le GPIO un ventilo cet été, il taquinais souvent les 70° a l’heure actuelle il depasse rarement les 40°.
J’en fais un usage familial, pour internet, mail, serveur pour mon Apple TV, echange de fichiers avec iPhones, Torrent, scan et impression sans fil, Libre Office pour mes filles, écran 24" 1080p en hdmi
Il remplace sans problème un iMac, pour le cout d’un clavier Apple :slight_smile:
Ce ne serait pas un probleme materiel?

Bonjour ;

Merci pour l’information concernant le rajout de la ligne over_voltage=1 au config.txt. En effet celà à l’air d’être efficace.

Jacques

Coucou

de mon coté, je ne pense pas que le soucis soit lié a Raspbian Buster, mais plutot au pi4

J’utilise cette ISO depuis sa premiere version, sur pi2, pi3 et pi0w sans aucun soucis

Courage

Bonjour ;

Effectivement, le problème rencontré concerne exclusivement le pi 4 et buster tourne sans problème sur les autres pi. Si j’évoquais la question autour de raspbian, c’est qu’il semblerait que la conception matérielle du pi 4 soit vraiment différente des précédents et que la solution logicielle ne soit pas totalement aboutie. Pour exemple, si matériellement le boot sur un périphérique usb est possible, la solution logicielle n’existe pas encore. Ceci dit, quand je dis que matériellement c’est au point, ce n’est pas tout à fait vrai puisqu’il y aurait des choix de conception et de mise en oeuvre autour de l’usb-c qui pose problème sur les versions en cours et qui impacte l’utilisation de certaines alimentations. Ceci dit, la solution proposée par Jelopo semble bien fonctionner.