Erreur sudo apt-get update

Hello a tout le monde, me prenant la tête à configurer plex et transmission sur Rpi 4, je repars de zéro. J’ai refait la carte SD avec Raspail buster, lorsque je lance la commande sudo apt-get update, la réponse me surprend un peu. Je voudrais partir du bon pied pour la suite, voilà la réponse :

pi@raspberrypi:~S sudo apt-update
Réception de :1 http://raspbian.raspberrypi.org/raspbian buster InRealse [15,0 kB]
Réception de :2 http://archive.raspberry.org/debian InRelease [32,6 kB]
Lecture des listes de paquets … Fait
E : Le dépôt «http://raspbian.raspberry.org/raspbian buster InRelease» a modifié sa valeur «Suite» de «stable» à «oldstable»
N : Ceci doit être pleinement accepté avant que les mises à jour depuis ce dépôt puissent être appliquées. Veuillez vous référer aux pages de manuel «apt-secure(8)» pour plus de détails.
E : Le dépôt «http://archive.raspberry.org/debian buster InRelease» a modifié sa valeur «Suite» de «testing» à «oldstable»
N : Ceci doit être pleinement accepté avant que les mises à jour depuis ce dépôt puissent être appliquées. Veuillez vous référer au pages de manuel «apt-secure(8)» pour plus de détails.

Moi je veux bien accepté tout ce qu’il veut si cela peut régler le problème. Mais comment faire ?

Quelqu’un a une idée ? car je suis sûr que c’est à cause de ces erreurs que je galère à installer transmission et plex. Alors que lorsque j’ai déjà fait tout ça sur un autre Rpi (qui a HS depuis) je n’ai pas eu ce type d’erreur.

Salut @Sebastien0411

Le système t’explique bien les choses :

En gros, tu utilises un vieux système.
Donc,
Soit tu acceptes le fait de passer en « oldstable »,
Soit tu utilises plutôt la derrière image !

Lecture pour ton information :
https://www.debian.org/releases/buster/

++

Ha ok, je comprend mieux d’un coup, donc en gros l’OS que j’ai installé est une ancienne version.
Et c’est soit j’accepte d’utiliser une ancienne version, mais il n’est pas impossible que j’ai des erreurs par la suite. Ou alors je regarde dans le site que tu m’a donné et je prend la dernière version d’OS,
celle-ci par exemple : Raspberry Pi OS with desktop and recommended software

                                     * Release date: October 30th 2021
                                     * Kernel version: 5.10
                                     * Size: 3,045MB

Celui-là suffit :
Raspberry Pi OS with desktop
Plus léger.

Ok cool ! merci je vais le télécharger de suite et installer ça et puis je vais me prendre la tête de nouveau
à installer transmission et plex par la suite. Sans vouloir abuser, tu ne connaîtrais pas des tutos simple pour transmission et pour plex ?

Je n’utilise pas plex.
Etant sous Linux sur tous mes PC, j’utilise Transmission depuis des années.
Aucune configuration sauf de changer le dossier de DL si tu veux que le PC ne stocke pas les fichiers téléchargés dans « Téléchargement ». Tu colles juste la destination souhaitée (en local ou en distant)

Ok, je vois ce que tu veux dire. Je vais déjà réussir à installer transmission sans problème et je vais voir pour le changement de dossier.
Que veux tu dire par : « changer le dossier de DL» ?

« changer le dossier de Téléchargement »
(DL = DownLoad = Téléchargement)

Ho le boulet que je suis de ne même pas comprendre ça. Encore merci :+1:t3:

Bonsoir, je me permets de revenir vers toi concernant transmission. J’ai réussi à l’installer et le paramétrer. Lorsque je veux télécharger un truc j’ai un message d’erreur PERMISSION DENIED, je comprend que ça veut dire comme erreur.
J’ai fais un : sudo chmod 777 /home/pi/Downloads
mais cela n’a pas fonctionné.
Je laisse une capture d’écran

Une idée ?

Mettre en « 777 » n’est pas une bonne solution, plusieurs logiciels vont bloquer l’accès dans ce cas de figure (Apache par exemple). Essai avec « 640 » et « 650 » qui sont habituellement utilisé, et assure toi d’utiliser le même « user/group » que celui du dossier.

Sinon, ajoute le process qui fait le travail d’e^tre dans le group du dossier, mais évite de toucher les valeurs « public » de tes accès, qui nuisent justement à l’accès.

Dans mes essai, le « 777 » provoque un blocage d’accès dans 99% des cas, donner des accès au USER/GROUP mais pas à Public sauf en « READ » est plus profitable. Il était plus simple d’ajouter le « USER » voulant accès, au « GROUP », que de lui donner un accès publique.


Pour du Torrent sous linux, j’utilise le GUI TorrentFlux-b4rt, vieux mais marche encore très bien, j’ai une version que j’ai ajusté (graphiquement) et je peux fixer les accès dossier facilement. Malgré un côté administratif parfois « bordelique » et des caprices, il est fort pratique et performant. Utilise Transmission mais peut utiliser d’autres programmes (selon ton OS).

Une simple copier des fichier et un accès au Web GUI et je peux déjà le mettre en route, ajuster et savoir quoi installer pour utiliser tout le potentiel.


Hello, merci pour la réponse super complete, même si un NOOB comme moi arrive à déchiffrer qu’une partie. Je vais déjà tâcher de savoir dans quel user/group est mon dossier en question pour par la suite faire le sudo chmod 640 /MON_DOSSIER et par la suite le sudo chmod 650 /MON_DOSSIER
En tout cas merci pour la réponse.

J’ai un autre problème qui est venu s’ajouter depuis ce matin, lorsque je fais service transmission-daemon start
il me répond :

*Job for transmission-daemon service failed because the control process exited witch errod code.

See « systemctl status tranmission-daemon.service » and « journalctl -xe » for details.

Je pense que je vais trouver les paramètre de base de transmission pour remettre ça en place.
J’ai l’impression de toucher quelque chose d’un côté de bousiller un truc de l’autre, ça me rend dingue :triumph:

Yo,
Prends l’habitude de lire ce que dis la console :wink:
Tape
systemctl status tranmission-daemon.service
puis
journalctl -xe
ça peut te dire qui/quoi/comment/où :wink:

Hey salut ! Merci pour la réponse. C’est vrai que je me suis fait la réflexion que je vais trop vite et que je ne lis pas ou pas assez. Alors la première ligne de commande me renvoie ça :

Donc je lance la deuxième commande, qui me répond ça :

Cela m’en apprend un peu mais je n’arrive pas comprendre quand il me parle de Failed with result ‘exit-code’ :thinking::face_with_monocle:

Je pense que l’erreur est là, mais la trouver et la comprendre est différent, mais c’est comme ça qu’on apprend :wink:

PS : j’ai consulté le fichier settings.json, mais je ne vois pas d’erreur. J’ai remis les valeurs pas défaut.
Je me demande si cela n’est pas à cause d’une erreur de user car je viens d’installer PLEX et je suis peut être avec le mauvais user.

Je me suis demandé s’il ne me manquait pas un fichier de config ou un truc du genre. Car j’avais voulu tout supprimé de transmission pour repartir à zéro et lorsque je lance :
apt-get install transmission-daemon libcurl3-gnutls transmission-cli

J’ai la réponse : Le type «gpg» est inconnu sur la ligne 1 dans la liste des sources /etc/apt/sources.list.d/plexmediaserver.list

Je trouve cela bizarre :face_with_monocle::thinking:

Je me pose la question si le plus simple ne serait pas encore de tout supprimé de Transmission pour le réinstaller à zéro, qu’en pensez vous les pros de Linux ? :thinking:

Hello,

sudo apt purge transmission
sudo apt update
sudo apt clean
sudo apt autoclean
sudo apt autoremove
sudo apt update
sudo apt install transmission

Propre :wink:

Ok, merci. Mais question con, j’ai installé plex juste avant, il n’y a pas une histoire de user avec lequel je suis connecter.
Genre je n’ai pas le droit de le faire avec ce user là où un truc du genre.
Actuellement dans ma ligne de commande j’ai :
pi@pi:~$

C’est peut être une question con que je pose.

:angry: Erreur dès le première ligne de commande :

Avant J’ai installé plex, qui fonctionne lui.
Peut être un rapport :thinking:

Je bosse mes partiels donc je fais court.

Je ne vois pas le rapport avec Plex dans cette erreur.

Que donne :
sudo apt update

Que donne :
cat /etc/apt/sources.list.d/plexmediaserver.list