Besoin de finalisé mon Airsonic

Bonjour a tous,

je suis depuis une semaine sur un projet qui est de créer un serveur de musique de même style que spotify mais avec mes propres musiques que j’aurais préalablement mis sur un disque dur externe relié a mon raspberry pi 3+.

J’ai donc utilisé Airsonic qui a l’intérêt d’être gratuit. J’ai avancé avec beaucoup de mal dans la réalisation de se projet, et maintenant voila ou j’en suis et les problèmes que je rencontre.

Dans Airsonic je dois sélectionner un ou plusieurs dossiers ou il y a de la musique. Si je défini le dossier Musiques de mon ssd externe airsonic ne trouve pas le dossier… Si par contre le dossier Musiques je le copie colle dans le fichier Documents (par exemple) et que je renseigne dans Airsonic le chemin du dossier Documents, la Airsonic le trouve…

Donc pourquoi Airsonic n’arrive pas a accéder a mon ssd Externe ?

Et deuxième chose je voudrais savoir comment je peux lancer l’application Airsonic au démarrage du pi. Pour éviter a chaque fois que je débranche le pi je dois relancer l’application manuellement.
(PS: mon pi servira qu’a ça).

Merci par avance les coupains :slight_smile:

Hello
Une piste potentielle que j identifie en lisant ton problème : l’espace dans le nom du répertoire (SSD externe).
Certains programmes n aiment pas. Airsonic est peut être dans ce cas.
Pour le démarrage automatique, une piste ici

Ah ca serait si bête ? je vais tester ca et je reviens vers toi :slight_smile:

EDIT : Alors j’ai viré l’espace entre SSD et Externe mais non ca marche toujours pas. Bien entendu j’ai enlevé l’espace sur le SSD et dans le logiciel Airsonic pour que les 2 correspondes.

Mais tu as remis un espace ailleurs et des caractères spéciaux (les parenthèses) avec: (A trier)
Mets A_trier sans parenthèse. Les underscore passent generalement.
Ou ATrier.
Sinon quels sont les droits des répertoires ? Airsonic a peut être besoin d voir un accès complets (755).

Salut Ernie95,

je viens de tester avec un autre dossier et c’est pareil.

Je pense comme toi que ça doit être du coté des permissions que ca pose problème…

Que dois-je faire pour vérifier ça ?

Si tu es à l aise en ligne de commande:
Tu ouvres un terminal et voici les commandes à passer (faire une ligne puis valider avant de faire la suivante):
cd /media/pi
ls -la

Cela affichera les propriétaires des dossiers et aussi les droits (avec des r, w et x)

Donne le résultat et on visera.

Comment est monté le disque dur ssd ? Via le fichier fstab ? Autre ?

Merci Ernie95,

oui je suis a l’aise avec les lignes de commandes malgré que je ne sois pas du tout un expert.

voila le résultat après les lignes de commandes tapé :

total 12
drwxr-x—+ 3 root root 4096 août 15 13:24 .
drwxr-xr-x 3 root root 4096 août 12 16:36 …
drwxrwxrwx 1 pi pi 4096 août 7 12:30 SSDExterne

Le ssd est branché en usb sur l’un des 4 ports usb du pi c’est tout.

hello,

et si tu fait ls -la /media/pi/SSDExterne/Musiques/Autres

comment est monté le disque ?

Bonjour,

Pour repondre a bof si je fais « ls -la /media/pi/SSDExterne/Musiques/Autres »

Voila ce que j’obtiens :
« total 54497
drwxrwxrwx 1 pi pi 4096 août 7 12:30 .
drwxrwxrwx 1 pi pi 4096 août 7 12:35 …
-rwxrwxrwx 1 pi pi 7344407 févr. 20 2012 ‹ 08 - Metal Gear Solid Theme.mp3 ›
-rwxrwxrwx 1 pi pi 9261 juil. 8 2014 AlbumArt_{4C9B0AF2-9B94-4BF2-B5CF-0EDE2FC5B18C}Large.jpg
-rwxrwxrwx 1 pi pi 1898 juil. 8 2014 AlbumArt
{4C9B0AF2-9B94-4BF2-B5CF-0EDE2FC5B18C}_Small.jpg
-rwxrwxrwx 1 pi pi 1898 juil. 8 2014 AlbumArtSmall.jpg
-rwxrwxrwx 1 pi pi 441363 sept. 20 2012 battlefield_1942.mp3
-rwxrwxrwx 1 pi pi 3936830 déc. 27 2012 ‹ Battlefield 3 - by Advait Nemlekar.mp3 ›
-rwxrwxrwx 1 pi pi 409 juil. 8 2014 desktop.ini
-rwxrwxrwx 1 pi pi 9261 juil. 8 2014 Folder.jpg »

Pour répondre a Ernie95 :

Le SSD est branché tout bêtement avec un adaptateur USB sur l’un des 4 ports USB du pi.

Je gérerais le montage du disque via le fichier fstab pour qu’il soit monté de la même façon à chaque fois.
Pour airsonic il faut voir si il faut des droits et propriétés particuliers.
Que donne ls -la pour les répertoires qui marchent ?

Ok je vais me renseignais sur le disque en fstap. Je ne connais pas du tout je vais découvrir :slight_smile:

Pour ce qui est des droits pour les répertoires qui marche voici ce que j’obtiens :

total 738132
drwxr-xr-x 2 pi pi 4096 août 13 20:01 .
drwxr-xr-x 4 pi pi 4096 août 13 20:10 …
-rwxrwxrwx 1 pi pi 8529944 mars 24 2006 ‹ 01 - Why.mp3 ›
-rwxrwxrwx 1 pi pi 7950036 juil. 22 2018 ‹ 02 - Fantasy (featuring Ruckazoid).mp3 ›

PS : j’ai pas tout copier parce que ça serait trop long.

Pour fstab, il s agit du fichier qui gère automatiquement les montages au démarrage.
Au préalable il faut identifier ton disque en tapant en ligne de commande: blkid
Il te donnera un résultat de tout tes disques et il faut identifier ton ssd et noter le code derrière partuuid. Et pas uuid tout seul, c est bien partuuid.
Tu édites en ligne de commande le fichier fstab:
sudo nano /etc/fstab
Et tu rajoutes cette ligne:
PARTUUID=Xxxxxxx /cheminquetusouhaites ext4 defaults,auto,users,rw,nofail 0 0

A la place des xxxxx tu mets ton code partuuid et a la place de /cheminquetusouhaites /mnt/ ssdexterne
J ai supposé que ton disque etait formaté en ext4. Si pas le cas il faut adapter.

Tu enregistre avec CTRL+x, tu valide avec oui ou yes, tu valides le nom (laisser tel quel).
Tu rebootes la pi.

Pour airsonic et le problème d accès, potentiellement un paramètre du fichier de configuration qui impose de ne regarder que dans home. Quel tuto as tu suivi ?

Salut Ernie95,

tout d’abord merci pour ton aide super détaillé :slight_smile: ça fait vraiment plaisir de suivre pas a pas tes explications :+1:

Alors j’ai identifié le ssd externe, voici ce que me donne en tapant la commande blkid :

/dev/sda1: LABEL=« SSDExterne » UUID=« 48A6CDD4A6CDC2A4 » TYPE=« ntfs » PARTLABEL=« Basic data partition » PARTUUID=« 26419ec5-b52d-41ea-899c-aafc467b1ef9 »

Avant d’aller plus loin dans tes explications je vois que mon ssd externe et au format ntfs et non ext4. Du coup il faut certainement que je le formate en ext4 avant de continuer ? (j’ai jamais entendu parler d’un format ext4 :face_with_raised_eyebrow:).

Pour airsonic j’ai suivi partiellement le tuto de airsonic officiel :

(partiellement parce que toutes les commandes sont pas a jour).

J’attends ton retour et je continue :slight_smile:

Non: RPi s’accomode très bien de ntfs (ext4 est un format de fichiers supporté fort bien par GNUlinux; mais un support externe en NTFS est fort bien géré par RPi).
J’arrête de vous détourner…

Salut dbrion06,

mais alors est-ce que je dois forcement le formater en ext4 pour poursuivre les étapes de Ernie95 ?

J’attends vos réponses peur de faire une coui…

NON
(sauf si quelqu’un de plus competent me dement):
vous pouvez utiliser (lire, écrire, executer…) votre disque NTFS aussi bien,( voire mieux…) sous RPi que sous windows (donc faire des copies de l’un à l’autre, en déplaçant le disque…)
Par contre,lire du ext4 https://fr.wikipedia.org/wiki/Ext4 sous windows semble compliqué… (écrire encore plus)…
Ceci n’est certainement pas la source de vos soucis.
Je répète, pour la 3 ième fois:
NON

Ok très bien ! j’ai bien compris pour le NON…

Du coup comme la dit Ernie95 : « Pour airsonic et le problème d accès, potentiellement un paramètre du fichier de configuration qui impose de ne regarder que dans home. »

Faudrait que je regarde des le fichiers de configuration de airsonic mais où je dois chercher ? C’est la première fois que je fais ça :roll_eyes:

Hello
Ton soucis est peut être le ntfs
Ntfs ne gère pas les droits comme les systèmes unix.
Si tu as une clé usb, essaye de la formater en nfts et dans airsonic de pointer vers la clé et voir si cela marche. Même manipulation mais cette fois en formatant en ext4.
Le résultat de ces essais permettra de statuer. N ayant pas airsonic, je ne peux pas faire la manipulation.
Une fois le format adéquate identifier, pour fstab :
PARTUUID=Xxxxxxx /cheminquetusouhaites ext4 defaults,auto,users,rw,nofail 0 0

A la place des xxxxx tu mets ton code partuuid et a la place de /cheminquetusouhaites /mnt/ ssdexterne
Si le disque est en ext4, garder ext4 de l exemple. Si c est ntfs, mettre ntfs.

Si tu souhaites garder ntfs, il faut creuser les options de fstab pour monter le disque avec les bonnes permissions. Celles que je propose peuvent suffire. Actuellement pour ta config, la pi monte comme elle veut et je ne sais pas ce qu elle met par défaut.

Je m’en occupe cette après midi en rentrant du boulot :ok_hand: je te tiens au courant