Webcam image quality on octoprint

Bonjour,
Sur Octoprint j’ai installé une Wecam logitech C270, j’ai paramétré octoprint, installé les plugin.
Mais je n’arrive pas à avoir une image nette

Comment faire ?

Merci
webcam

Il faut ajuster les options; Manual USB camera settings in Linux | KUROKESU

Ok, merci
Par contre j’ai remarqué que la caméra envoyait une image nette sur les objet en arrière plan et au 1er plan c’est flou, je recherche l’inverse et je ne trouve pas de paramètres à régler
Voir la photo
Comment faire ?
merci

hello,

il faudrait que tu mettes off l’autofocus et que tu règles toi même la profondeur de champ ( pour avoir nette la partie de l image qui t intéresses)

je ne sais pas si c’est possible avec ta caméra pour savoir et éventuellement la paramétrer tu peux utiliser opencv en python ou en C/C++

1 J'aime

Je n’ai pas l’option focus
Voici les options que j’ai:
brightness 0x00980900 (int) : min=0 max=255 step=1 default=128 value=128
contrast 0x00980901 (int) : min=0 max=255 step=1 default=32 value=32
saturation 0x00980902 (int) : min=0 max=255 step=1 default=32 value=32
white_balance_temperature_auto 0x0098090c (bool) : default=1 value=1
gain 0x00980913 (int) : min=0 max=255 step=1 default=64 value=1
power_line_frequency 0x00980918 (menu) : min=0 max=2 default=2 value=2
white_balance_temperature 0x0098091a (int) : min=0 max=10000 step=10 default=4000 value=3690 flags=inactive
sharpness 0x0098091b (int) : min=0 max=255 step=1 default=24 value=24
backlight_compensation 0x0098091c (int) : min=0 max=1 step=1 default=0 value=0
exposure_auto 0x009a0901 (menu) : min=0 max=3 default=3 value=3
exposure_absolute 0x009a0902 (int) : min=1 max=10000 step=1 default=166 value=667 flags=inactive
exposure_auto_priority 0x009a0903 (bool) : default=0 value=1

Et si tu change de résolution de capture ?
Au passage, avec les caméras, tout ce qui ce trouve à moins de 30cm de la lentille, il y a peux de chance d’avoir un bon focus sans un pilote spécifique. C’est mieux du grand angle/paysage. Une Webcam c’est pas universel dans la capture. :stuck_out_tongue: