Utilisation du scanner HP DeskJet AIO 2050 j510 sur serveur d'impression

Bonjour,
Je me lance tout juste dans l’utilisation du Rasberry et je viens de monter un serveur d’impression avec CUPS et HPLIP. Jusque la tout fonctionne à merveille :smiley:
L’imprimante utilisé est une HP deskjet 2050 j510 multifonction (print + scan).

L’objectif maintenant est de pouvoir aussi partager l’utilisation du scan mais là je sèche.
J’ai trouvé que très peux d’info sur le net à ce sujet et elle sont très anciennes.

Une idée de comment faire ? Comment administrer l’utilisation du scan ?
J’ai cru comprendre que l’utilisateur pouvait passer par une interface web en local, comme avec CUPS.

Merci d’avance pour votre aide

Bonjour,
j’ai une HP Envy 4500, qui je pense est plus recente que ton tout en un, je me connecte tout simplement a son IP;
http://192.168.1.58/#hId-pgWebScan
Et j’accede a une interface qui me permet de scanner, depuis n’importe quel navigateur sur mon reseau local.

En esperant que tu puisse y acceder de la meme maniere.

Malheureusement je n’ai pas cette option :sleepy:

hello,

cette page, même si elle est faite pour ubuntu, devrait aussi permetrre de faire fonctionner un scanner en réseau sur raspbian « buster » ( raspberry pi OS ) :

Oui oui j’ai déjà consulté cette page et il y a une application sanetwain pour installer un client sur un poste en windows 10.
Cette application est la seule trouvé qui détecté le scan mais elle ne fonctionne pas sur les environnement en 64 bits. Donc impossible de d’utiliser cette application :sleepy: :sleepy:

Pour le moment, je n’ai d’autre choix que de me connecter en VNC et utiliser Simple Scan.
Mais bon avec vous je trouverai bien une solution :wink:

j’ai trouvé une application « phpsane » qui permet d’accéder au scanner via un navigateur web.
je l’ai installé sur un Rpi4 raspian « buster » avec nginx et php7.3 ça fonctionne avec mon imprimante/scanner HP (Hewlett-Packard Deskjet 1510 series all-in-one)
j’ai remplacé les " Prerequisites" par:
sudo apt install sane sane-tools netpbm imagemagick

apres le git ds le root de nginx (/var/www/phpSane) il faut changer le proprietaire et le group :
sudo chmod -R www-data:www-data /var/www/phpSane
mettre les droit d’ecriture sur /var/www/phpSane/tmp et /var/www/phpSane/output a 775

et j’ai eu besoin de https://github.com/gawindx/phpSane/blob/master/doc/README_EN.txt
pour les droits sur scanimage. ( chmod +s /usr/bin/scanimage)

ça fonctionne on peut même recadrer la preview … pas contre j’arrive pas a faire fonctionner pdf !
et suivant la Résolution DPI ça peut être très lent !

source:
phpsane : https://github.com/gawindx/phpSane

1 J'aime

@bof, merci pour cette info, je vais tester des que j’ai 2 minutes.
Par contre moi j’ai un Pi zero :smiley: :D, j’espère que ca passera aussi

@bof, cela fait plusieurs jours que je cherche à configurer PHPSANE, mais je rencontre des difficultés.
Une aide me serait précieuse :

  1. La commande : sudo chmod -R www-data:www-data /var/www/phpSane me dit que chmod: mode incorrect : « www-data:www-data » Je pense que c’est un manque de droit sur www-data.
  2. La commande sudo apt install sane-tools me dit Impossible de trouver le paquet sane-tools.
  3. /usr/bin/scanimage ce dossier n’existe pas. Faut-il le créé manuellement ou il est créé a l’installation d’un des paquets précédent.
  4. Dans leur doc il est fait mention d’un test en faisant su -m www -c 'scanimage --test' J’ai remplacer www par www-data mais il me demande un mot de passe que je n’ai pas. J’imagine que c’est lié au point 1

Un grand merci pour votre aide

Bonjour

Tu confond chmod et chown,
chmod pour donner des droits sur un fichier.
chown pour modifier le propriétaire d’ un fichier

désolé ! erreur d’inattention :blush: comme l’indique Mik91390
il fallait lire :
sudo chown -R www-data:www-data /var/www/phpSane

:sob: :sob: non mais c’est sans fin.
Bon j’ai créé un fichier phpsane.conf pour le virtualhost que je fait écouté sur le port 8080
Et maintenant il m’affiche bien la page index.php mais comme si c’était du texte. En gros il affiche le code source de la page php.
J’ai restart Apache et php mais sans résultat.
une idée ??

Bon, j’ai réinstallé php et ca marche.
Enfin presque, j’accède a l’interface, le scan se lance, mais pas de fichier de généré.
Suis persuadé que c’est en rapport avec cette histoire de dossier scanimage inexistant.