Spectacle musique et vidéo

Bonjour à toutes et à tous,
Je monte un projet nommé « Fluctus Planetarium » qui consiste en 8 écrans vidéos indépendants et une musique quadriphonique.
Pour le son, je gère sans problème avec Pure Data sur un RPi 3 sous Raspbian.
Pour l’image, j’ai testé l’envoi de « top départ » en UDP par le serveur géré par le RPi 3, lequel déclenche une lecture en boucle sur un RPi esclave avec MPlayer : ça marche impec’ !
Je me demande maintenant (pour alléger la facture et dissocier les 8 écrans vidéos) s’il est envisageable d’utiliser 8 RPi Zéro W (sous Raspbian Lite ?) gérant chacun une seule vidéo Full HD.
Alors… réaliste ou pas ?

Salut,

Petite contribution.

J’ai un RpiZero (sans Wifi) qui j’avais passé en affichage dynamique sous Raspbian Lite et Mplayer.
Bon, je n’ai pas tenté avec une vidéo en Full HD et il était configuré en mode automatique avec lecture en boucle des vidéos au démarrage (soit récup’ des vidéos dans un NAS distant, soit lecture des vidéos en local avec dossier ‹ vidéos › géré par FTP).

C’était juste pour le fun pour rendre service à des gens en leur réalisant des tuto, mais une des personnes a ce système dans son magasin (un Rpi et un écran = 1 affichage ; il a 7 affichage je crois).

++

1 J'aime

Merci pour ta réponse si rapide !
J’ai commandé un kit complet chez Kubii : je vais tenter le coup. À suivre…

C’est bon : j’ai le RPi zéro WH sous Raspberry Lite, il marche, et j’arrive à lire une vidéo mp4 avec omxplayer (écran gris avec mplayer) ! Pour l’instant, par contre, je n’arrive pas à la faire boucler en continu… elle lit le fichier une seule fois et s’arrête.
Quant à un fichier .avi ça ne marche pas…
Mais l’image est belle et fluide, c’est encourageant ! :slight_smile:
Pourtant, la commande « omxplayer -o local Luna.mp4 --loop » devrait fonctionner en boucle continue, non ?
Des pistes à me suggérer ?

C’est bon : la boucle est bouclée !
Par contre, j’ai un « saut » de 300ms à chaque fois.

J’arrive maintenant à déclencher la lecture à distance (avec Pure Data en UDP sur le RPi4) via un script python (sur le RPi0) qui déclenche la vidéo choisie… mais quand je change de vidéo à lire, au bout d’un « certain » nombre fois, le script python arrête de boucler !
Pourtant, à chaque changement de choix de vidéo, je « kill » omxplayer avant de le relancer en lui envoyant un « 0 » avant de lui envoyer le nombre du nouveau choix…

import socket
import os
import psutil

sock = socket.socket( socket.AF_INET, socket.SOCK_DGRAM )
sock.bind( ('',9000) )
code = "on";

while True:
    data, addr = sock.recvfrom(1024)
    data = str(data, encoding='utf8')
    if "1" in data:
        os.system('omxplayer --loop --no-osd /home/pi/Musique/fluctus/video/Clément.mp4 &')
    elif "2" in data:
        os.system('omxplayer --loop --no-osd /home/pi/Musique/fluctus/video/Fanny.mp4 &')
    elif "3" in data:
        os.system('omxplayer --loop --no-osd /home/pi/Musique/fluctus/video/Hugo.mp4 &')
    elif "4" in data:
        os.system('omxplayer --loop --no-osd /home/pi/Musique/fluctus/video/Luna.mp4 &')
    elif "5" in data:
        os.system('omxplayer --loop --no-osd /home/pi/Musique/fluctus/video/Matis.mp4 &')
    elif "6" in data:
        os.system('omxplayer --loop --no-osd /home/pi/Musique/fluctus/video/Neila.mp4 &')
    elif "7" in data:
        os.system('omxplayer --loop --no-osd /home/pi/Musique/fluctus/video/Pauline.mp4 &')
    elif "8" in data:
        os.system('omxplayer --loop --no-osd /home/pi/Musique/fluctus/video/Tristan.mp4 &')
    elif "0" in data:
        for process in psutil.process_iter():
            if process.name() == "omxplayer.bin":
                process.kill()

Je m’épuise à fouiller sur le net mais je ne trouve aucune information sur ce bug.
Des idées ?

J’ai eu une intuition en vérifiant l’encodage des MP4 : certains bouclaient, d’autres non…
Un petit coup de HandBrake à partir des AVI d’origine (preset = Official > General > Fast 1080 p30) et le tour était joué : toutes les vidéos bouclent !
Par contre, rien encore à faire pour éviter le « saut » de 300ms entre chaque boucle… à part créer un autre fichier avec plusieurs fois le même, ce qui distancie les sauts de bouclage.

melt luna.mp4 luna.mp4 luna.mp4 luna.mp4 -consumer avformat:luna4.mp4 acodec=libmp3lame vcodec=libx264

Galère : le port USB du Pi Zéro a lâché ! J’arrive encore à me connecter en SSH mais je renvoie quand même l’appareil chez Kubii pour qu’ils me le changent.
Il paraît que ça arrive… un défaut de fabrication, sans doute…

[Hors-Sujet]
Pour « défendre » les Rpi Zero :
Mes 2 RpiZero V1.3 à 5,22 euros me donnent parfaite satisfaction malgré qu’ils ne vivent pas forcément une vie tranquille entre les tests et le stockage à l’arrach’ :wink:
J’en ai même un qui a passé plusieurs nuits dehors avec une caméra nocturne pour faire des photos récurrentes d’un couple d’oiseau en nidification.
J’avais juste fait un « toit » avec une plaque de mousse pour éviter que la rosée ne se dépose dessus :blush:
[/Hors-Sujet]