RPI 4 - VNC -> Lenteurs et deconnections

Bonjour à tous,

Je suis nouveau dans la communauté PI, j’ai récemment acquis un RPI 4, 4GB, que je souhaite contrôler à distance via mon PC portable (juste pour éviter d’avoir à brancher clavier, souris et écran à chaque utilisation). J’ai donc activé SSH, installé VNCserver et RealVNC sur mon PC. La prise de contrôle fonctionne mais bien souvent la navigation n’est pas fluide et occasionne même parfois des déconnections où je suis expulsé de Viewer. ex:

  • Quand je télécharge un fichier sur le net.
  • Quand je lancer l’installation ou MAJ ou APP via commande
  • Quand je lance KODI (installé sur Raspbian)
  • Parfois juste le fait de taper du texte rapidement sur l’invité de commande les lettres mettent du temps à apparaître.

la RPI et PC sont sur le WIFI (5ghz). Savez-vous pourquoi ces lenteurs surviennent ? Avez-vous des recommandations pour y remédier ?

Merci par avance & bonne journée

WB.

hello,

as tu essayé de changer de canal wifi sur ta box en accord avec les fréquence que te donne :
iw list

ceci dit j’avais le même problème en 2,4Ghz et j’ai fini par utilisé ethernet !

Hello Bof,

Merci pour ton retour, j’ai fait un scan, on était 3 box 5Ghz sur le canal 36 dans le voisinage, j’ai changé de canal donc. J’y gagne un peu en fluidité quand je déplace la souris, ouvre et ferme des fenêtre et tape du texte.

En revanche je ne peux toujours pas lancer KODI ou télécharger un fichier lourd (300mo) sans être déconnecté par exemple. Il y a peut être des réglages à effectuer qui ne sont pas en lien avec la connexion?

EDIT : Pour KODI je n’avais pas activé le mode capture directe dans Viewer, méa culpa. Parcontre c’est encore plus lent depuis l’activation de cette option.

si tu utilises la commande iwconfig peut être tu auras des infos utiles (link quality, erreur « invalid »)
si j’en crois cet article ( https://le-routeur-wifi.com/choisir-wifi-5-ghz-2-4ghz/ ) le choix du 5 Ghz est pas toujours le meilleur et certaines box permettrait de créer un réseau 2.4 Ghz et un 5Ghz si ta box le fait ça vaut peut être le coup d’essayer !

Merci pour le lien. Ma box me propose les 2, j’ai essayé de switcher pour test. En 2.4ghz pas de différences dans la fluidité. Mêmes soucis.
J’ai exécuté la commande iwconfig:

5 GHZ : bitrate : 200mb/s ; Link quality 70/70
2.4 GHZ : bitrate : 77 mb/s ; link quality 70/70

Hello,

Regare Kodi à travers VNC c’est pas top, regarde du coté de Emby qui est un serveur local de streaming. (Kodi le fait aussi mais moins bien je trouve).

En gros tu installes Emby sur ton PI, puis tu utilises soit une page web soit l’application android pour regarder tes films/séries

Bonjour Gpapig,

Bien noté pour Emby merci, que je garde dans un coin de ma tête pour d’autres usages. L’idée n’était pas d’utiliser KODI pour regarder des videos sur mes devices via VNC, mais simplement de le piloter (tout comme mes autres applications sur Raspbian) via VNC. Effectivement c’est bien trop lent en capture direct, du coup. La solution que j’ai trouvé c’est de piloter Raspbian via VNC puis quand lance KODI, je passe en contrôle via l’app mobile Kodi remote, qui fonctionne très bien.

Pour aller plus loin comme je n’ai pas forcement besoin d’utiliser l’interface Raspbian à chaque fois, je lance KODI en automatique après démarrage de Raspbian, afin d’éviter de démarrer VNC puis lancer KODI. Cela ne fonctionne pas très bien, il crash et se relance. puis quand je lance une vidéo j’ai une fenetre écran noir par dessus l’écran de la vidéo, étrange, j’irai voir plus tard les crashs log, p-e une sombre histoire de cache à vider? je n’ai essayé que 2x hier soir, mais c’est un autre sujet… :slight_smile:

Le problème de KODI résolu, j’ai quand même le problème des déconnexions dès que je lance un téléchargement… en attendant j’ai confirguré le RPI4 en NAS ou j’alimente la bibli Kodi via mon PC du coup, mais c’est des actions en plus et cela ne résout pas le pb de fond :frowning: