[Résolu] Rouge partout sur l'écran avec raspberry pi4

Bonjour,
Mon raspeberry est tout en rouge sur écran.
Quelqu’un peut me dire comment revenir à la configuration précédente?
Merci pour votre aide

Salut,
Rien ne dit que c’est lié à une configuration … sauf si tu as modifié des réglages (mais tu ne le dis pas).
Donc :

  • Tu as modifié des réglages pour basculer en rouge ?
  • Tu es connecté comment à cet écran ? (VGA, HDMI, …)
  • Tu as essayé un autre écran ? Un autre câble ?
    @+

Non, je n’ai pas modifié les réglages.
Sur l’écran actuel qui n’a pas de port HDMI, ça marchait parfaitement avec un adaptateur minidisplayport-hdmi. Le même cable HDMI mini n’a pas fonctionné sur un autre écran avec seulement port HDMI. J’ai du me procurer un nouveau cable adaptateur HDMI Mini (Câble Hdmi/Mini - PSDAV06 - Noir). Et celui-là allait très bien.
J’ai branché le nouveau cable à l’adaptateur minidisplayport-HDMI et à l’écran actuel. Et toc, écran rouge. J’ai réutilisé l’ancien cable, mais toujours écran rouge.
Voici l’image de appearence settings (paramètres d’apparence ou d’affichage).

Merci pour votre aide.

Bonjour, bonne année et bonne santé en 2022.
En fait l’écran est rouge dès le démarrage de la raspberry.
J’ai oublié de vous en indiquer la version que j’ai:

pi@raspberrypi:~ $ cat /proc/version
Linux version 5.10.63-v7l+ (dom@buildbot) (arm-linux-gnueabihf-gcc-8 (Ubuntu/Linaro 8.4.0-3ubuntu1) 8.4.0, GNU ld (GNU Binutils for Ubuntu) 2.34) #1496 SMP Wed Dec 1 15:58:56 GMT 2021
pi@raspberrypi:~ $

et ceci:

root@raspberrypi:/home/pi# lsb_release -a
No LSB modules are available.
Distributor ID: Raspbian
Description: Raspbian GNU/Linux 10 (buster)
Release: 10
Codename: buster
root@raspberrypi:/home/pi#

Merci pour votre aide

Selon la documentation si tu cherche « hdmi red screen », ton cable est mort.

Salut,

Pour moi, c’est l’adaptateur qui est mort, mais seul une batterie de test nous le confirmera.
Il faut faire des tests pour avoir un vrai diagnostic différentiel.

Si j’ai compris la config, tu as :
Rpi → Câble → adaptateur → écran

Pour commencer, je testerais directement avec un autre adaptateur.

Ensuite, pour les tests complets :
1 - Brancher le Rpi avec le câble sur un écran HDMI
2 - Essayer l’adaptateur avec le Rpi sur un autre écran
3 - Essayer l’adaptateur avec un autre appareil sur cet écran
4 - Essayer l’adaptateur avec un autre appareil sur un autre écran
5 - Et caetera

++

@levelKro
L’ancien cable, peut-être. Sur un autre écran, le bureau scintillait. Et CT pour la première fois depuis que je l’utilise dessus.
Mais pour le nouveau, ce n’est pas possible. Il est tout neuf.

Merci Nabla pour la procédure. A vérifier. J’ai peur que cela vienne du Rpi.
Je fais le nécessaire.
Merci pour votre aide.

Un écran rouge complet des un signal (démarrage) est un signe de problème de cable et/ou de prise mais pas de logiciel ni de décodage (puce). Soit l’une des « pins » est défect, soit le signal ne ce rend pas correctement.

Assure toi d’avoir des cables récent et de qualité, d’être en version HDMI 2.0. ET bien sur, de tester tout matériel sur un autre appareil pour éliminer les variables.

ET juste pour savoir, as-tu déjà eu à utiliser FB ? (FrameBuffer) Ou as-tu déjà installé un écran LCD pour Raspberry, comme des TFT ou LCD de petite taille, avec ou sans le « touch » ?

Et peux tu nous donner copie de ton fichier « config.txt » ? Même si ce n’est pas « logiciel ou matériel » comme bug, dans le cas d’une Raspberry, une mauvaise configuration d’affichage peut tellement tout démolir.

Merci pour ton intérêt levelKro
Voici ce que donne le config.txt:

__# For more options and information see
# http://rpf.io/configtxt
# Some settings may impact device functionality. See link above for details

# uncomment if you get no picture on HDMI for a default « safe » mode
#hdmi_safe=1

# uncomment this if your display has a black border of unused pixels visible
# and your display can output without overscan
disable_overscan=1

# uncomment the following to adjust overscan. Use positive numbers if console
# goes off screen, and negative if there is too much border
#overscan_left=16
#overscan_right=16
#overscan_top=16
#overscan_bottom=16

# uncomment to force a console size. By default it will be display’s size minus
# overscan.
#framebuffer_width=1280
#framebuffer_height=720

# uncomment if hdmi display is not detected and composite is being output
#hdmi_force_hotplug=1

# uncomment to force a specific HDMI mode (this will force VGA)
#hdmi_group=1
#hdmi_mode=1

# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes
# uncomment hdmi_drive=2

# uncomment to increase signal to HDMI, if you have interference, blanking, or
# no display
#config_hdmi_boost=4

# uncomment for composite PAL
#sdtv_mode=2

#uncomment to overclock the arm. 700 MHz is the default.
over_voltage=6
arm_freq=2000
gpu_freq=750

# Uncomment some or all of these to enable the optional hardware interfaces
#dtparam=i2c_arm=on
#dtparam=i2s=on
#dtparam=spi=on

# Uncomment this to enable infrared communication.
#dtoverlay=gpio-ir,gpio_pin=17
#dtoverlay=gpio-ir-tx,gpio_pin=18

# Additional overlays and parameters are documented /boot/overlays/README

# Enable audio (loads snd_bcm2835)
dtparam=audio=on

[pi4]
# Enable DRM VC4 V3D driver on top of the dispmanx display stack
dtoverlay=vc4-fkms-v3d
max_framebuffers=2

[all]
#dtoverlay=vc4-fkms-v3d
start_x=0

Ce qui m’étonne c’est que le nouveau cable (tout neuf) que je me suis procuré vu que l’original ne fonctionnait plus sur l’écran (1) HDMI seulement (sans VGA et sans cette entrée d’écran:

image),

(c’est exactement ce qu’il y a sur mon écran actuel en plus de VGA, mais pas d’entrée HDMI, c’est un vieux Philips)

ce nouveau cable a très bien marché avec l’écran (1). Et, @Nabla, tant que l’écran (1) n’est pas à ma disposition, je ne souhaite pas tester sur mon écran télévision. On ne sait jamais. Aussi, si le rapport du config.text ne donne rien d’anormal, il va falloir que j’attende que je sois en face de l’écran (1). Dans quelques jours.
Je croise les doigts pour le raspberry.

Merci pour votre aide.

Enlève le « # » au paramètre, déjà tu va essayer en mode « safe ».

Mais avant, la fin de ton message est le plus important… tu relie a un écran VGA et non HDMI, ?&Z%&?, c’est un détails important.

Un signal rouge = cable defect, c’est aussi simple que ça, que ce soit DVI ou VGA, c’est toujours ça la réponse, un cable HDMI n’as pas cette erreur. Même si il a un bout en HDMI, reste qu’au final, c’est un DVI/VGA…

Prend un cable HDMI, connecte à la TV et je suis sur a 99% que tout marche.

Salut,

Aucun danger !!!
Tu ne risques pas d’injecter un défaut dans ta TV :wink:

Je pense comme levelKro.

Cela permettra déjà d’éliminer que le souci résulte d’un défaut du Raspberry et tu seras soulagé :slight_smile:

Bref, en cas de souci, je commences toujours par tester avec un autre adaptateur.
Ensuite et/ou si pas d’adaptateur avec un autre câble.
Si pas possible autrement, je teste sur un autre écran avec même connectique et sur un autre écran sans cette connectique.

Un signal perturbé est pratiquement à 100% un souci de câble (ou adaptateur) ; rarement la prise de sortie de l’appareil ; jamais l’écran (ou tu le sais quand l’affichage pourri est lié à l’écran, ça se voit direct).

Bonjour à vous,

Après moultes hésitations et interrogations, ça y est, le problème est réglé.
Il suffisait de changer l’adaptateur.
Merci @toutes et tous.

Yo,
Merci pour ton retour.
Je passe ton sujet en résolu.
++