[résolu] NGINX sur pi3 mise en place impossible

Bonjour,
Sur une installation neuve sur un pi3, l’installation de NGINX plante en cherchant à installer le paquet nginx-full qui demande un autre paquet nginx-extras ou un autre du même type nginx-light. Ces paquets se cherchent les uns après les autres !!

Bilan de l’installation :

dpkg: des problèmes de dépendances empêchent la configuration de nginx :

nginx dépend de nginx-full (<< 1.14.2-2+deb10u1.1~) | nginx-light (<< 1.14.2-2+deb10u1.1~) | nginx-extras (<< 1.14.2-2+deb10u1.1~) ; cependant :
Le paquet nginx-full n’est pas encore configuré.
Le paquet nginx-light n’est pas installé.
Le paquet nginx-extras n’est pas installé.
nginx dépend de nginx-full (>= 1.14.2-2+deb10u1) | nginx-light (>= 1.14.2-2+deb10u1) | nginx-extras (>= 1.14.2-2+deb10u1) ; cependant :
Le paquet nginx-full n’est pas encore configuré.
Le paquet nginx-light n’est pas installé.
Le paquet nginx-extras n’est pas installé.

l’instruction apt-cache policy nginx donne :

root@raspberrypi:/etc/init.d# apt-cache policy nginx

nginx:
Installé : 1.14.2-2+deb10u1
Candidat : 1.14.2-2+deb10u1
Table de version :
*** 1.14.2-2+deb10u1 500
500 http://raspbian.raspberrypi.org/raspbian buster/main armhf Packages
100 /var/lib/dpkg/status

Merci par avance pour l’aide, Alain

Bonjour

et quand tu tapes la commande
dpkg -s nginx | grep Status
parce que sous buster je je n’ai eu aucun probléme d’installation de NGINX

Merci bien, j’obtiens :
pi@raspberrypi:~ $ dpkg -s nginx | grep Status
Status: install ok unpacked
pi@raspberrypi:~ $ sudo dpkg -s nginx | grep Status
Status: install ok unpacked

Puis en tentant l’install la même chose qu’avant :
pi@raspberrypi:~ $ sudo apt install nginx
Lecture des listes de paquets… Fait
Construction de l’arbre des dépendances
Lecture des informations d’état… Fait
nginx est déjà la version la plus récente (1.14.2-2+deb10u1).
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
2 partiellement installés ou enlevés.
Après cette opération, 0 o d’espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] o
Paramétrage de nginx-full (1.14.2-2+deb10u1) …
Job for nginx.service failed because the control process exited with error code.
See « systemctl status nginx.service » and « journalctl -xe » for details.
invoke-rc.d: initscript nginx, action « start » failed.
● nginx.service - A high performance web server and a reverse proxy server
Loaded: loaded (/lib/systemd/system/nginx.service; enabled; vendor preset: enabled)
Active: failed (Result: exit-code) since Tue 2019-11-05 19:08:46 CET; 101ms ago
Docs: man:nginx(8)
Process: 16177 ExecStartPre=/usr/sbin/nginx -t -q -g daemon on; master_process on; (code=exited, status=0/SUCCESS)
Process: 16178 ExecStart=/usr/sbin/nginx -g daemon on; master_process on; (code=exited, status=1/FAILURE)

nov. 05 19:08:44 raspberrypi nginx[16178]: nginx: [emerg] bind() to 0.0.0.0:80 failed (98: Address already in use)
nov. 05 19:08:44 raspberrypi nginx[16178]: nginx: [emerg] bind() to [::]:80 failed (98: Address already in use)
nov. 05 19:08:45 raspberrypi nginx[16178]: nginx: [emerg] bind() to 0.0.0.0:80 failed (98: Address already in use)
nov. 05 19:08:45 raspberrypi nginx[16178]: nginx: [emerg] bind() to [::]:80 failed (98: Address already in use)
nov. 05 19:08:45 raspberrypi nginx[16178]: nginx: [emerg] bind() to 0.0.0.0:80 failed (98: Address already in use)
nov. 05 19:08:45 raspberrypi nginx[16178]: nginx: [emerg] bind() to [::]:80 failed (98: Address already in use)
nov. 05 19:08:46 raspberrypi nginx[16178]: nginx: [emerg] still could not bind()
nov. 05 19:08:46 raspberrypi systemd[1]: nginx.service: Control process exited, code=exited, status=1/FAILURE
nov. 05 19:08:46 raspberrypi systemd[1]: nginx.service: Failed with result ‹ exit-code ›.
nov. 05 19:08:46 raspberrypi systemd[1]: Failed to start A high performance web server and a reverse proxy server.
dpkg: erreur de traitement du paquet nginx-full (–configure) :
installed nginx-full package post-installation script subprocess returned error exit status 1
dpkg: des problèmes de dépendances empêchent la configuration de nginx :
nginx dépend de nginx-full (<< 1.14.2-2+deb10u1.1~) | nginx-light (<< 1.14.2-2+deb10u1.1~) | nginx-extras (<< 1.14.2-2+deb10u1.1~) ; cependant :
Le paquet nginx-full n’est pas encore configuré.
Le paquet nginx-light n’est pas installé.
Le paquet nginx-extras n’est pas installé.
nginx dépend de nginx-full (>= 1.14.2-2+deb10u1) | nginx-light (>= 1.14.2-2+deb10u1) | nginx-extras (>= 1.14.2-2+deb10u1) ; cependant :
Le paquet nginx-full n’est pas encore configuré.
Le paquet nginx-light n’est pas installé.
Le paquet nginx-extras n’est pas installé.

dpkg: erreur de traitement du paquet nginx (–configure) :
problèmes de dépendances - laissé non configuré
Des erreurs ont été rencontrées pendant l’exécution :
nginx-full
nginx
E: Sub-process /usr/bin/dpkg returned an error code (1)

Donc toujours au même point

Bonjour,

ceci veut dire qu’un processus autre est déjà lancé sur le port 80 et donc ngnix ne peux pas démarrer.
Passer la commande ci-dessous pour identifier le processus utilisant le port 80.
sudo netstat -antp | grep 80

A+

Bingo, après avoir stopé APACHE2 installation ok. Plus de problème, nginx est ok et sur le bon port et le bon emplacement.
Ce qui reste une interrogation, c’est qu’il n’est pas fait mention de nginx-full dans cette nouvelle installation. Et que lors de mes premiers essais sur une configuration neuve, sans y avoir installé APACHE, l’installation de NGINX plantait !

pi@raspberrypi:~ $ sudo apt install nginx
Lecture des listes de paquets… Fait
Construction de l’arbre des dépendances
Lecture des informations d’état… Fait
nginx est déjà la version la plus récente (1.14.2-2+deb10u1).
0 mis à jour, 0 nouvellement installés, 0 à enlever et 8 non mis à jour.
2 partiellement installés ou enlevés.
Après cette opération, 0 o d’espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] o
Paramétrage de nginx-full (1.14.2-2+deb10u1) …
[ ok ] Upgrading binary: nginx.
Paramétrage de nginx (1.14.2-2+deb10u1) …
pi@raspberrypi:~ $