[Résolu] IP fixe avec la dernière version raspbian release10

bonjour,
J’utilise sans problèmes depuis plusieurs années plusieurs raspberry pi3 et zero configurés avec une adresse IP fixe; voulant repartir sur une installation propre, j’ai téléchargé et installé la dernière version prise sur https://www.raspberrypi.org/downloads/ .
Bien que le fichier /etc/dhcpcd.conf soit identique à ceux fonctionnant depuis longtemps (jessie + stretch), l’adresse n’est pas fixe et ne correspond pas à celle du fichier.
Merci de me redire si quelqu’un a eu et résolu ce problème, sans doute un paramétrage différent que je n’ai pas trouvé.

Salut ip fixe et dhcpd.conf ?

Il faut tu développe la comment tu configure ton interface réseau ?

De quel fichier tu parle ?

Tu veux une ip fixe manuelle ou une ip tu fixe via le dhcp d’un autre serveur ?

Salut @gif

Petite remarque en sus des questions pertinentes de @jojo

J’ai choisi l’option des IP fixes via ma box.
ça permet de simplifier les choses car on ne tripatouille pas les fichiers de conf (je suis sur des PC/Rpi sous base Debian) et si on va ailleurs, on ne peut pas avoir de conflit d’IP ou de pb de plage.
Je fixe l’IP en fonction de l’adresse MAC de la machine.
Une réinstall de Debian9 en Debian10 ?
Pas de souci, je garde la même IP :wink:

excellent choix c’est d’ailleurs comme sa qu’on fonctionne au boulot :wink:

Bonjour,
Merci à chacun pour leur réponse; qq précisions:
j’ai fait qq montages avec des raspberry ou microcontrôleur (nodemcu, esp8266, sonoff…) dont certains sont destinés et utilisés par des amis ou ma petite-fille (8 ans) donc hors de mon domicile et donc avec des box que je ne veux/peux pas manipuler. Dans ma box, je ne fais que des redirections pour avoir un accès de l’extérieur.
Jusqu’à présent, je n’ai jamais eu de problèmes avec:
-/etc/wpa_supplicant/wpa_supplicant.conf:
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
country=FR
network={
ssid=« Liveboxxxxxxxxxxx »
psk=« xxxxxxxxxxxxxx »
key_mgmt=WPA-PSK
}
-/etc/dhcpcd.conf:
…………………

server, but it should not be run by default.

nohook lookup-hostname
interface wlan0
static ip_adress=192.168.1.xx/24
static routers=192.168.1.1
static domain_name_servers=192.168.1.1
inform 192.168.1.xx

Ce n’est donc qu’avec la dernière image Raspbian que ces paramétrages ne fonctionnent pas et me renvoient une adresse fournie par le DHCP de la box donc aléatoire et donc rendant impossible un accès distant.

Bonjour,
Sur certain de mes RPI je fixe l’ adresse IP avec le fichier dhcpcd.conf, car mon réseau est étendu et certain de mes répéteurs WIFI transmettent un adresse MAC virtuelle et donc changeante.
Et au passage de Stretch à Buster je n’ai eu aucun problème.
Dans mon dhcpd.conf je n’ai modifié que ces lignes:

  • interface wlan0
  • static ip_address=192.168.6.44/24
  • static routers=192.168.6.1

merci d’avoir répondu, c’est ce que je fais et ai fait depuis toujours; je vais reprendre une autre image, celle que j’ai utilisée est peut-être buggée.

Bonjour,

C’est pas une faute de frappe, un retour chariot à la noix, ou un truc du genre tout bêtement ?

A+

Bonjour,
Problème résolu: comme dit par Mik91390, il suffit de 2 lignes dans le dhcpcd.conf et pas plus comme j’avais fait; j’ai utilisé l’image la plus simple de buster et non celle fournie avec imager (?).
Merci à chacun d’avoir pris qq minutes pour répondre.

Merci @gif pour ton retour.
Je passe le sujet en [Résolu]
++