[RESOLU] Bluetooth : bluez_card no found

Bonjour à tous,

Je compte connecter une barre de son bluetooth à mon raspberri pi 3B+ Buster

Mais je bloque lors de la configuration de PulseAudio.

Voici l’historique des commandes déjà effectuées :

pi@raspi:~ $ sudo adduser pi audio
pi@raspi:~ $ sudo adduser pi bluetooth
pi@raspi:~ $ sudo adduser pi pulse-access

pi@raspi:~ $ sudo nano /etc/dbus-1/system.d/bluetooth.conf
  <policy user="pi">
    <allow own="org.bluez"/>
    <allow send_destination="org.bluez"/>
    <allow send_interface="org.bluez.Agent1"/>
    <allow send_interface="org.bluez.MediaEndpoint1"/>
    <allow send_interface="org.bluez.MediaPlayer1"/>
    <allow send_interface="org.bluez.Profile1"/>
    <allow send_interface="org.bluez.GattCharacteristic1"/>
    <allow send_interface="org.bluez.GattDescriptor1"/>
    <allow send_interface="org.bluez.LEAdvertisement1"/>
    <allow send_interface="org.freedesktop.DBus.ObjectManager"/>
    <allow send_interface="org.freedesktop.DBus.Properties"/>
  </policy>
pi@raspi:~ $ sudo reboot

pi@raspi:~ $ bluetoothctl
Agent registered
[bluetooth]# power on
Changing power on succeeded
[bluetooth]# agent on
Agent is already registered
[bluetooth]# default-agent
Default agent request successful
[bluetooth]# devices
Device 2C:2B:F9:73:96:2D LG SJ4R(2D)
[bluetooth]# pair 2C:2B:F9:73:96:2D
Attempting to pair with 2C:2B:F9:73:96:2D
pair successful
[bluetooth]# trust 2C:2B:F9:73:96:2D
Changing 2C:2B:F9:73:96:2D trust succeeded
[bluetooth]# connect 2C:2B:F9:73:96:2D
Attempting to connect to 2C:2B:F9:73:96:2D
[CHG] Device 2C:2B:F9:73:96:2D Connected: yes
Connection successful
[CHG] Device 2C:2B:F9:73:96:2D ServicesResolved: yes
[LG SJ4R(2D)]# quit

pi@raspi:~ $ hcitool scan
Scanning ...
        2C:2B:F9:73:96:2D       LG SJ4R(2D)
pi@raspi:~ $ pulseaudio --start
pi@raspi:~ $ pactl list sinks short
0       alsa_output.platform-soc_audio.analog-mono      module-alsa-card.c      s16le 1ch 44100Hz       SUSPENDED
pi@raspi:~ $

Voila :blush:

Question en or :
Pourquoi n’ai-je pas de ligne « bluez_card.xx_xx_xx_xx_xx_xx »

Suis-je sur la bonne piste?

Bien à vous :slight_smile:

RESOLU :
PS : https://forum.ubuntu-fr.org/viewtopic.php?id=1573651

Mais j’ai trouvé la solution. En fait c’est très simple, il suffit d’éditer le fichier /etc/bluetooth/audio.conf et d’ajouter :

[General]
Enable=Source,Sink
Disable=Socket

C’est le Disable=Socket qui est important.