RaspiSMS smsAPI sous Debian Buster

Bonjour,
J’essaye d’installer RaspiSMS sous BUSTER et je butte sur quelques points :
Lors de l’installation Gammu, certaines commandes ne fonctionnent que sous SUDO (gammu --Identify,…) mais j’arrive à générer des SMS

Lors de 'l’installation de RaspiSMS, cela semblait fonctionner sauf l’accès à l’appli en html pour cause de connexion par défaut ROOT.

J’ai fini par trouver une info dans les ISSUES ou il est dit de modifier le « user » et « password » dans le fichier …parse… (remplacer user root par raspisms et password « password ».

Ensuite on accède à l’application, on peux consulter les SMS, les contacts… par contre je n’arrive pas à envoyer des SMS schédulés.

Enfin et le plus important pour moi, smsAPI introuvable, il semble quelle ne soit pas installé.

Et je trouve étonnant de ne pas trouver des nouvelles sur ce sujet en 2019.

Si quelqu’un peut me mettre sur une bonne piste (à moins que cela ne fonctionne sous BUSTER).

Bonjour,

De mémoire, RaspiSMS est une ancien logiciel qi n’a pas été mis à jour depuis la version Jessie.
Avec Stretch, il était déjà conseillé de downgrader l’OS vers Jessie.

A moins qu’un développeur reprenne le logiciel pour le faire tourner correctement sur Buster, c’est grillé pour le Rapsberry PI4 !

A+

hello,

pour les sms « schedulés » ça fonctionne avec un cron si tu fais :
crontab -e
et que t as pas de référence à raspisms dedans tu rajoutes:

Citation

.* * * * * cd /var/www/html/RaspiSMS && /var/www/html/RaspiSMS/console.php -c parseReceivedSMS >> /var/log/parsesms.log 2>&1
.* * * * * cd /var/www/html/RaspiSMS && /var/www/html/RaspiSMS/console.php -c sendScheduleds >> /var/log/sendsms.log 2>&1

Citation

peut être /var/www/RaspiSMS à modifier et les * * * * * aussi ( la il se lance toutes les minutes ! )
le >> /var/log/xxxxx.log 2>&1 ça te créer un log pour les deux commandes tu peux les lire avec :
less /var/log/xxxxx.log

pour le smsAPI si j’ai bien compris ça fonctionne avec curl un machin du style:
curl http://127.0.0.1/RaspiSMS/smsAPI/?email=machin@mosite.com&password=qsdffdf&numbers=0612345678&text=Texte%20du%20SMS%20à%20envoyer

si tu te goures d’url c’est apache qui envoie un 404 sinon t’as un code erreur en retour de smsAPI.php l’explication est dans le programme:
const API_ERROR_NO = 0;
const API_ERROR_BAD_ID = 1;
const API_ERROR_CREATION_FAILED = 2;
const API_ERROR_MISSING_FIELD = 3;

je serais moins pessimiste que jelopo; comme Raspisms est écris en php, qu il se sert de logiciels existant sous buster:
apache2 est déjà la version la plus récente (2.4.38-3+deb10u3).
gammu est déjà la version la plus récente (1.40.0-1).
gammu-smsd est déjà la version la plus récente (1.40.0-1).
mariadb-server est déjà la version la plus récente (1:10.3.18-0+deb10u1).
php est déjà la version la plus récente (2:7.3+69).
php-mbstring est déjà la version la plus récente (2:7.3+69).
php-mysql est déjà la version la plus récente (2:7.3+69)

il a pas vraiment de raison que ça marche pas !
En l’installant avec l’archive tgz comme c’est expliqué là :

je ne désespère pas d’y arriver ! :wink:

Oui, je crois que c’est ce qu’il faut retenir. Je me suis emballé pour RaspiSMS mais c’est une solution sans avenir puisque les évolutions sont interdites.
Je chercherai une autre solution autrement j’abandonne le coté Raspberry.
Merci pour votre réponse.

Cela fait plusieurs jours que je suis dessus, et j’ai lu à peu près tout sur le sujet et engagés des actions diverses mais je bute toujours.
Maintenant je doute vraiment de la possibilité d’aboutir avec les versions Raspbian récentes.
Je n’ai rien trouvé qui me laisse croire qu’une installation RAspisSMS fonctionne avec BUSTER.
La crontab, je l’ai mais je pense surtout que l’installation de RaspiSMS 2.1 ne se passe pas bien. Le database est créé, j’'y accéde, je peux voir les SMS reçus mais je ne peux pas en générer. Et l’API sms, aucune trace, la fameuse commande ne trouve pas le fichier.
J’ai encore un peu d’espoir dans ce forum, ensuite…
Merci pour vos suggestions.