Raspberry pi 4 et boot sur ssd

Bonjour,

savez-vous si le boot sur SSD est disponible sur le raspberry pi 4 avec la dernière version de raspbian ?

J’ai suivi ce tuto https://www.domo-blog.fr/comment-installer-jeedom-sur-un-disque-dur-ssd-sur-raspberry-pi/

Mais je n’obtiens pas le fameux code 17:3020000a avec la commande
vcgencmd otp_dump | grep 17

Si non, auriez-vous un site permettant de suivre l’évolution de ce problème ?

Merci.

Bonjour
Je n’ai toujours pas installer le boot sur ssd,
ais tu peux suivre l’évolution sur https://www.raspberrypi.org/forums/viewtopic.php?f=63&t=243995&sid=2187d303fdf9a62ae8953dd0bc516773&start=425

merci beaucoup pour le lien

J’ai trouvé ce tuto :

Par contre, si j’enlève la carte SD, le rapberry ni démarre pas.

Savez-vous si cette procédure me permettrai d’installer jeedom sur le ssd, et que jeedom ecrive bien sur le SSD et pas la carte SD ?

Merci

Je ne sais pas si c’est différent mais mon RPi 3B+, j’ai flashé mon ssd avec Etcher et je démarre dessus sans problème. Evidamment sans carte SD.
J’ai redimensionné la partition systeme avec gparted pour pouvoir utiliser le disque entier.

Ton tuto est bizarre il dit d’agrandir ta partition avec extend file system mais ça ne marche pas sur le disque SSD ou je n’ai pas compris ce qu’il y est raconté…

Comme je j’ ai expliqué pour l’instant à ma connaissance le boot sur ssd avec un rpi 4 n’est pas possible.
Mais pour un rpi j’ utilise une méthode simple, je démarre le rpi avec ne carte sd sur laquelle un systéme fonctionnel est un installé, je charge rpi-clone avec ce lien, puis en ssh je lance la commande sudo rpi-clone sda -f
Toutes les explications sont sur le GitHub.
et voici ce que donne la commande:
texte préformaté indenté par 4 espaces

Booted disk: mmcblk0 63.9GB Destination disk: sda 250.1GB

Part Size FS Label Part Size FS Label
1 /boot 43.5MB fat32 –
2 root 63.8GB ext4 rootfs

== Initialize: IMAGE mmcblk0 partition table to sda - forced by option ==
1 /boot (22.5MB used) : IMAGE to sda1 FSCK
2 root (2.1GB used) : RESIZE(250.0GB) MKFS SYNC to sda2

Run setup script : no
Verbose mode : no
-----------------------:
** WARNING ** : All destination disk sda data will be overwritten!
: The partition structure will be imaged from mmcblk0.
-----------------------:

Initialize and clone to the destination disk sda? (yes/no): yes
Optional destination ext type file system label (16 chars max):

Initializing
Imaging past the start of /boot partition 2.
=> dd if=/dev/mmcblk0 of=/dev/sda bs=1M count=52 …
Resizing last partition to end of disk …
Resize success.
Changing destination Disk ID …
Delaying so partprobe can update /dev entries …
=> fsck -p /dev/sda1 …
=> mkfs -t ext4 /dev/sda2 …

Syncing file systems (can take a long time)
Syncing mounted partitions:
Mounting /dev/sda2 on /mnt/clone
=> rsync // /mnt/clone with-root-excludes …
Mounting /dev/sda1 on /mnt/clone/boot
=> rsync /boot/ /mnt/clone/boot …

Editing /mnt/clone/boot/cmdline.txt PARTUUID to use cdd86dc0
Editing /mnt/clone/etc/fstab PARTUUID to use cdd86dc0

Done with clone to /dev/sda
Start - 14:14:57 End - 14:17:46 Elapsed Time - 2:49

Cloned partitions are mounted on /mnt/clone for inspection or customizing.

Hit Enter when ready to unmount the /dev/sda partitions …
unmounting /mnt/clone/boot
unmounting /mnt/clone

vérifier:sudo fdisk -l

Device Boot Start End Sectors Size Id Type
/dev/sda1 8192 93802 85611 41,8M c W95 FAT32 (LBA)
/dev/sda2 98304 488397167 488298864 232,9G 83 Linux

Je devais être un peu fatigué quand j’ai répondu hier soir.
J’avais oublié que le boot sur USB n’est pas possible.