Problème RaspAP

Bonjour, si aujourd’hui je me tourne vers vous, c’est parceque je suis novice sur Raspberry, j’ai un gros problème, après avoir passé plusieurs heures dessus, je ne trouve la dite solution.
Je m’explique, je possède une Raspberry 3 avec Raspbian comme OS, (le plus récent : burst)
(Ceci étant pour un projet je précise)
Je dois transformer ma raspberry en point d’accès Wi-Fi, donc elle récupère le réseau en ethernet sur l’interface classique eth0 et ensuite, en théorie elle dois renvoyer le WiFi, et d’autres appareils doivent communiquer sur ce wifi, mais, le problème intervient maintenant :

J’ai utilisé RaspAP pour créer et configurer ce dit point d’accès, je précise aussi que je dois passer par un proxy pour me connecter au réseaux eth0.
Donc, j’ai paramètrer le proxy sur ma rasp, j’ai aussi défini une plage Dhcp pour que le PA redistribue les @ comme je le désire. mais le problème survient lorsque j’essaie de me connecter au réseau créer.
Pour effectuer les test, j’ai utiliser mon smartphone.
il repère le SSID créé, mais impossible de se connecter, il affiche ‹  › connecter, aucun service’’, donc j’ai essayé de paramétrer le proxy sur le téléphone, mais rien n’y fais.
Je me tourne vers vous, pour savoir comment faire pour pouvoir me connecter à ce p***** de réseau. Merci beaucoup ! Bonne soirée !

hello,

  1. la version actuelle est 10 (buster) la future 11 (Bullseye) donc on va dire que t’es sur buster :wink:
  2. le proxy n’a un rôle que dans l’accès au web, c’est la connexion de ton raspberry à la passerelle internet qui te permet d’accèder à l’extérieur ( classiquement ta box ou sur un réseau plus pro le routeur qui fait la passerelle entre l’extérieur et le réseau local )
    c’est aussi souvent cette passerelle qui te donne l’acces au dhcp et au dns
    la où ça devient compliqué c’est pour arriver à deviner ton architecture réseau d’où quelques questions:
  • le Rpi accede t il au web via le proxy ?
  • peux tu pinguer d’autres PC ? la passerelle ?
  • as tu autoriser le forward sur le Rpi ?
  • rediriges tu le port 80 et 443 vers ton proxy ?
  • le proxy il est « transparent » ou il faut une manip pour si connecter ?

le message « connecter, aucun service » semble vouloir dire que ton Rpi accepte les clients mais ne laisse pas passer leurs requêtes ? non ?

Alors, merci pour ta réponse, je vais éclaircir un peu plus :

  • le rpi accède au Web par le proxy,
  • je peux pinger d’autres pc
  • le ‹  › forward’’, pourrai tu me donner plus d’explication sur ce que c’est
  • je ne redirige pas ces ports
    -pour se connecter au proxy, j’ai besoin d’un login et mdp

Et, sur mon téléphone, dans les informations de connexion du SSID la passerelle est l’ interface wlan0 du rpi

pour que les connexions réseau passe de wlan0 à eth0 il faut que tu ais 1 dans :
less /proc/sys/net/ipv4/ip_forward
si tu as un firewall il faut aussi qu’il accepte le forward pour voir les règles:
sudo iptables -L
ou si tu utilises ufw :
sudo ufw status verbose
la il faut s"assurer que la « policy » forward ( ou routed ds ufw ) soit accept ( ou allow ds ufw)
Si ton problème vient d’un de ces deux paramètrages, le message d’erreur devrait changer.
par contre pour la connexion au proxy faudrait savoir comment il gère ! j’avoue que je n’y connais pas grand chose; le seul proxy SQUID que j’ai installé était en « transparent » et là il me semble que c’est le proxy qui doit envoyé l’écran de login; bref si tu te connectes directement au proxy quand tu vas sur le web, tes clients wifi devrait faire pareil.
qu’est que tu as dans les paramètres proxy de ton Rpi ? dans firefox c’est ds :
preferences#general#paramètres réseaux
si il y a autre chose que « Pas de proxy » il faudra que tes clients l’ai aussi !

Alors, je vais essayer tout ça cette semaine, merci beaucoup de ton aide, pour paramètrer mon proxy j’ai suivi cette étape :

Je reviens vers vous aujourd’hui pour vous dire que j’ai vérifier les manipulation, et, les paramètres sont bon, après réflexion, je pense que le problème vient de mon proxy, mais je ne sais résoudre

c’est toi qui l’a installé le proxy ?

  • si oui lequel ?
  • faut il un login (utilisateur,mot de passe) pour s’y connecter ?
  • l’as tu paramètré en transparent ?

sinon ( si tu n’as pas la main dessus):

  • est ce que tes clients sur le hotspot ont un login déclaré sur le proxy ?

Bonjour, je n’ai pas la main sur le proxy, mais sur ce proxy il existe un login/psswd que tout le monde peut utiliser et qui nous connecte, seulement, je n’ai pas la boîte de login lorsque je vais sur internet avec le mobile, et, même dans les paramètres du ssid, en spécifiant le proxy, rien n’y fait, je suis toujours en ‹  › connecté, sans accès internet’’

dans ce cas la ça devrait marcher avec un NAT :
iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE

mais je ne suis vraiment pas sur que cette ligne suffise … par contre dans le principe c’est bien d’envoyer au proxy les requetes de tes clients comme si c’était les tiennes ( MASQUERADE) et la tes clients devrait pouvoir se connecter directement en utilisant tes paramètres de connexion ou arriver sur un écran de login du proxy …

Bonjour, problème quasiment résolu, aidé par une personne extérieure, le problème viendrais de la configuration de l’interface en php qui definirais par defaut une passerelle qui n’est pas la mienne ainsi qu’un mauvais masque par defaut. Merci !