Point d'accès avec raspap : déconnexion au bout de qq heures

Bonjour,
J’utilise pi 3b+ depuis deux ans, il héberge grafana et influxdb. J’y stocke des données provenant de mes serres et de mes ruches. Tout roule si ce n’est que je passe par ma box internet.

Donc j’ai configuré une seconde framboise en point d’accès autonome avec RaspAP. Tout est OK, entre autres, passage de mon point d’accès à la box et vice-versa, lecture sans problème depuis ma tablette, mon ordinateur, VNC viewer, etc

Le problème est que la réception des données (toutes les 3 minutes) en provenance d’un esp32/ttgo stoppe au bout de 3 heures environ (parfois plus). Pour qu’il reprenne le cours, je dois relancer mon esp32.

Je dois ajouter que le même dispo sur l’autre pi fonctionne sans problème. J’ai donc l’impression que c’est au niveau du point d’accès que ça déconne mais je ne vois pas où…

hello,

peut être des infos dans le fichier log …
et avec du bol une solution par la : https://github.com/billz/raspap-webgui/wiki/FAQs#scanning

difficile de se faire une idée … peut être que si le esp32 se reconnectait toutes les trois minutes ça passerait ? on peut imaginer que quand le lease du dhcp arrive a son terme, le esp32 qui devrait se reconnecter, ne fait rien
sur ta box le lease sera « infinite » et donc attribuer sans limite de temps … donc pas ce problème !
si mes élucubrations sont juste il faudrait rendre le lease du dhcp de raspap « infinite »

si raspap utilise dnsmasq faudrait supprimer le lease time a la fin de la ligne commençant par :
dhcp-range=
( en général 12h 24h peut être 3h ds ton cas … )

Merci du retour rapide,

je vais digérer ta réponse et j’ai pensé effectivement que ça se comportait comme s’il y avait une limite temporelle. En fait je me suis trompé ce n’est pas toutes les trois heures mais plutôt les 6…
Ce qui n’est pas simple pour estimer l’effet des diverses solutions mises en oeuvre, comme modifier le code de l’esp32 pour lui dire « si ce n’est plus connecté, relance le programme » sans succès.

Merci, je vais voir tes suggestions

Bonjour,

j’ai vérifié le bail qui était effectivement limité à 12h, je l’ai porté à « infinite » et j’ai cru que j’avais solutionné le problème mais ce matin j’ai constaté l’arrêt vers minuit. J’ai relancé.

J’ai une question, dans le gestionnaire de RaspAP, dans le sous-menu réseau/wlan j’ai le choix entre DHCP ou statique, par défaut c’est statique. Que dois-je choisir ? De même, les cases en desssous « activer la repli vers l’option statique » moi, rien comprendre…

En parallèle, j’essaie de comprendre les log…

je viens d’installer « raspap » avec ce guide : https://github.com/billz/raspap-webgui#quick-installer
qui a l’air d’être sur le site des développeurs et je n’ai pas trouvé de « activer la repli vers l’option statique » …
peut être cette version est plus stable ?
je suis parti d’une sd « vierge » , j’ai répondu « Yes » à toutes les options « recommended » et non au autres ( vpn, adblock…)
au niveau de l’onglet « server DHCP » aprçs avoir tout redémarré j’ai :
. rien dans le bail
. infinite ds intervalle
et mon /etc/dnsmasq.d/090_raspap.conf est comme ça:

interface=wlan0
dhcp-range=10.3.141.50,10.3.141.51,255.255.255.0,infinite
log-facility=/tmp/dnsmasq.log

et le esp01 que j’ai en client sur mon raspberry est toujours connecté depuis 18H15 …
(il est 20H20)

Bonsoir,

peu de différence avec mon fichier :rasp_conf :

interface=wlan0
dhcp-range=10.3.141.50,10.3.141.255,255.255.255.0,infinite
dhcp-host=24:6f:28:9e:72:c0,10.3.141.223
log-facility=/tmp/dnsmasq.log
conf-dir=/etc/dnsmasq.d

je continue de tester…

voilà, au bout d’environ 4 heures, il y a arrêt d’enregistrement des données, le fichier log ne change pas, je vais me concentrer sur l’émetteur car du côté raspberry, je ne vois pas ce qui cloche.

Bonjour,

Problème résolu du moins du côté de la framboise qui n’est pas en cause. C’est au niveau de mon esp32/ttgo que ça coince. Pourquoi, je n’en sais encore rien, la même config tourne en routine sur un autre esp32 compilé avec le même programme (ou presque) avec la même carte. Mais bon entre temps, il y a eu des MAJ de ci de là…
Donc je ne me prends pas la tête, je lance un soft reset (de l’esp32) toutes les 3 heures et ça devrait coller (en attendant de trouver la bonne raison de la déconnexion).

Cela dit le PA créé avec RaspAP marche super bien, rien à dire…