PiHole ne bloque rien

Bonjour,
Nouveau dans le monde du Raspberry, j’essaie désespérément d’installer et configurer PiHole sur une Pi3 B+.
L’installation semble avoir fonctionné et j’a accès à l’interface web. l’IP est fixe pour le Rasperry (192.68.1.19)

–> Sur ma box (livebox 4), j’ai désactivé le serveur DHCP.
–> Sur PiHole, j’ai activé le serveur DHCP (de 192.168.1.2 à 192.168.1.251) le nom de domaine est « lan_Pi_Hole ».

Actuellement aucune pub n’est bloquée. J’ai également tenté de bloquer un site complet (facebook) mais j’ai y toujours accès.
Dans le tableau de bord Pi-Hole il y a pourtant le ombre de requête qui augmente.

Lorsque je tape la commande ipconfig depuis le PC voila ce que j’ai :
Suffixe DNS propre à la connexion. . . : lan_Pi_Hole
Adresse IPv6. . . . . . . . . . . . . .: 2a01:cb14:228:3600:a08c:798c:cc0d:932e
Adresse IPv6 temporaire . . . . . . . .: 2a01:cb14:228:3600:dcf9:76b8:e372:a9ef
Adresse IPv6 de liaison locale. . . . .: fe80::a08c:798c:cc0d:932e%6
Adresse IPv4. . . . . . . . . . . . . .: 192.168.1.29
Masque de sous-réseau. . . . . . . . . : 255.255.255.0
Passerelle par défaut. . . . . . . . . : fe80::2a9e:fcff:fe79:3280%6

Ce que je ne comprends pas, c’est comment la box sait ou trouver Pi-Hole sachant que j’ai juste désactiver le DHCP sans lui donner l’adresse du nouveau.
Pouvez-vous m’aider à résoudre mon problème ?
Je vous remercie par avance.

Hello !

L’option serveur DHCP n’est utile sur pi-hole que si ta box ne permet pas de préciser le serveur DNS.

Donc 1ère question, est-ce que ta box te permet de spécifier un serveur DNS?

Merci pour ra réponse.
Sur la livebox il est malheureusement impossible de spécifier un serveur DNS

Alors dans ce cas il faut en effet activer le serveur dhcp sur pi-hole.

Il faudra préciser que la passerelle est ta box

c’est ce que j’ai fait :
Capture

Mais comment peut-on expliquer que le nombre de requêtes augmente alors que j’ai toutes les pubs qui sont visibles ? Il y a quelques chose que je ne comprends pas la …

Est-ce que tes listes de blocage sont à jour?

Est-ce que le blocage fonctionne au moins sur un poste ou sur aucun?

Connecte toi en ssh sur ton pi et lance les commandes

pihole -up
pihole -g
pihole restart dns

Je ne sais pas si les listes sont à jour … Comment faire pour vérifier ?
Le blocage ne fonctionne sur aucun appareil.

Pour la première commande j’ai plusieurs erreurs :
[✗] Downloading and Installing FTL Error: Unable to get latest release location from GitHub [✗] FTL Engine not installed Unable to complete update, please contact Pi-hole Support

Pour la deuxième commande, il semble impossible de télécharger les listes:
[i] Target: raw.githubusercontent.com (hosts) [✗] Status: Connection Refused [✗] List download failed: using previously cached list
(C’est pareil pour toutes les listes (9 au total)

Après redémarrage rien de nouveau. Toujours autant de pub.

Visiblement ton pi-hole est mal installé.

recommence le tout en effacant d’abord la version en cours avec la commande

pihole uninstall

puis tappe la commande suivante

curl -sSL https://install.pi-hole.net | bash

j’ai donc tout réinstaller (même Rasbian) fait les MaJ de ce dernier et j’ai lancé les commandes suivantes :
pihole -up
pihole -g
pihole restart dns

Cette fois pas d’erreur.
J’ai désactivé le DHCP sur la box et activé sur PiHole

Mais le système ne fonctionne toujours pas.

Svp quelqu’un peut essaye de m’aiguiller dans mes recherches. Je vous remercie

Hello

Je suis comme toi, une box qui ne gère pas le dns.

J ai laissé le dhcp sur la box et sur l ensemble des ordinateurs ou téléphone, j ai réglé manuellement pour pointer le dns vers l adresse du PiHole.

Peut être que cette stratégie t aidera.

A+

Salut.
As-tu mis une DNS primaire et secondaire sur tous les appareils dont tu veux bloquer les pubs ? Si tu ne l’a pas fait, ça ne fonctionne pas.
En DNS primaire, tu met l’adresse à laquelle tu te connecte sur l’interface PiHole sur le Raspberry Pi, et en secondaire, une DNS que tu trouve n’importe ou sur le net, comme Google par exemple : 8.8.8.8

Bonjour
J’ai suivi ces recommandations pour l’installation de pi-hole sur mon raspberry 3b+.
J’ai également un problème de blocage qui n’est pas parfait, pas mal de pub passent au travers.
Je ne peux rien modifier sur le routeur de mon FAI.
J’agis donc sur la config de mon PC. J’ai mis L’IP du raspberry dans les DNS primaire et 1.1.1.1 dans les DNS secondaires.
Je n’ai rien modifié dans le dhcp du pi-hole il y a un message d’avertissement : Make sure your router’s DHCP server is disabled when using the Pi-hole DHCP server!.
Questions :
Où puis-je trouver des bonnes listes de blocage.
Y a t-il quelque chose à modifier dans la config de pi-hole de base.
Merci et cordialement.

Bonsoir j’ai le meme probleme, l’avait vous résolu svp ?