Pi4 VNC Impossible d'afficher le bureau

Bonjour, ou bonsoir c’est vous qui voyez,

J’ai actuellement une Rpi Pi4 fraîchement acheter sur laquelle j’ai installer Raspbian, je la connecte a un écran, elle boot, m’affiche le bureau, bref jusque la pas de problème.

Par contre si je veux y accéder via VNC avec mon PC j’ai le droit a un black screen ou je peut lire : " Impossible d’afficher le bureau".
image
Chose bizarre par contre… si je la connecte a mon écran, attend qu’elle finisse d’afficher le bureau et qu’elle se connecte au wifi, la je peux y accéder avec VNC sans problème.

Est ce que j’ai oublier de configurer un truc ?? Car j’ai eu aucun problème pour utiliser ma Pi3 avec VNC.

Merci de votre aide futur,
Cordialement,
Nymus

1 J'aime

Bonjour,

J’ai exactement le même problème sur RPI 4 et la distribution raspian buster. C’est tres ennuyeux car ce sont des RPI qui sont destinés a etre dans des baies infos sans écran, sans clavier et souris. Et je n’aime pas le SSH. A croire que le pilote graphique ne se charge pas si aucun ecran n’est branché sur les ports micro HDMI… Avez vous trouvez une solution depuis ?

Merci

hello,
je pense avoir trouver la solution tellement simple que ça gave un peu d avoir chercher 2 jours lol

sudo raspi-config
choisir advanced options
puis resolution
moi j ai choisi DMT mode 82 mais je suppose que choisir autre chose que l option par defaulf doit suffire ( peut être meme simplement faire une mise a jour )
et la miracle vnc fonctionne … ( avec GL 1 ou 2 )

[sur raspberry pi4 avec raspbian buster ( 2019-09-26-raspbian-buster-full.img) MAJ le 2019/11/17

2 J'aimes

J’ai tésté ta solution mais ca ne fonctionne pas mieux :frowning:

dans le raspi-config j ai :

  • interfacing option - vnc : oui
  • advanced options - resolution : DMT Mode 82 1920x1080 60Hz 16:9
  • advanced options - GL driver : G1 Legacy Original non-GL desktop driver

la version de vncserver : realvnc-vnc-server 6.5.0.41824 armhf VNC® Server
et le viewer sur le PC maitre : VNC-Viewer-6.19.1115-Linux-x64 sur un debian stretch

il me semble pas avoir changer autre chose a part avoir choisi d abord l openGL 2 puis etre revenu a GL1 ( le fait de changer ces valeur a peut etre provoquer une mise a jour utile ( c est parfois cruel ces petites machines :wink: )

Même problème, j’ai les mêmes paramètres dans rasp-config que ‹ bof › hier cela fonctionnait parfaitement même après de nombreux reboot ou arrêt machine.
ce matin , que nenni pas d’écran sous VNC et après avoir connecter un écran sur hdmi1 pas d’image (mais un signal présent car mon écran se ‹ cale › dessus) retour en mode 35 … J’ai la fraise Welcome … mais c’est tout (en bas à gauche 'ssh.service) _ l’accès sous ssh est toujours possible (heureusement)
si quelqu’un à une piste ?

le vncserver par défaut te propose un log tu peux le lire avec un less:
less /var/log/syslog
puis rechercher :
/error ou /fail ou …
t auras peut être des infos …
sinon sur un raspberry avec écran tu peux faire un log debug ( clic droit sur l icône vnc de la barre de tache, dépannage - créer un journal de debug ) plein d info mais pas souvent digestes !

sinon sur le raspberry par ssh tu peux voir l état de ton service vnc par :
systemctl status vncserver-x11-serviced
sur mon systeme ça donne ça :
Avant la connexion
pi@raspi4:~ $ systemctl status vncserver-x11-serviced
● vncserver-x11-serviced.service - VNC Server in Service Mode daemon
Loaded: loaded (/usr/lib/systemd/system/vncserver-x11-serviced.service; enabled; vendor preset: enabled)
Active: active (running) since Thu 2019-11-21 17:17:56 CET; 29s ago
Main PID: 535 (vncserver-x11-s)
Tasks: 5 (limit: 4915)
Memory: 22.2M
CGroup: /system.slice/vncserver-x11-serviced.service
├─535 /usr/bin/vncserver-x11-serviced -fg
├─540 /usr/bin/vncserver-x11-core -service
├─627 /usr/bin/vncagent service 13
├─867 /usr/bin/vncserverui service 14
└─891 /usr/bin/vncserverui -statusicon 5

nov. 21 17:17:56 raspi4 systemd[1]: Started VNC Server in Service Mode daemon.
nov. 21 17:17:57 raspi4 vncserver-x11[540]: ServerManager: Server started
nov. 21 17:18:04 raspi4 vncserver-x11[540]: ConsoleDisplay: Cannot find a running X server on vt1
nov. 21 17:18:05 raspi4 vncserver-x11[540]: ConsoleDisplay: Found running X server (pid=583, binary=/usr/lib/xorg/Xorg)

Apres la connection

pi@raspi4:~ $ systemctl status vncserver-x11-serviced
● vncserver-x11-serviced.service - VNC Server in Service Mode daemon
Loaded: loaded (/usr/lib/systemd/system/vncserver-x11-serviced.service; enabled; vendor preset: enabled)
Active: active (running) since Thu 2019-11-21 17:17:56 CET; 4min 53s ago
Main PID: 535 (vncserver-x11-s)
Tasks: 5 (limit: 4915)
Memory: 41.1M
CGroup: /system.slice/vncserver-x11-serviced.service
├─535 /usr/bin/vncserver-x11-serviced -fg
├─540 /usr/bin/vncserver-x11-core -service
├─627 /usr/bin/vncagent service 13
├─867 /usr/bin/vncserverui service 14
└─891 /usr/bin/vncserverui -statusicon 5

nov. 21 17:17:56 raspi4 systemd[1]: Started VNC Server in Service Mode daemon.
nov. 21 17:17:57 raspi4 vncserver-x11[540]: ServerManager: Server started
nov. 21 17:18:04 raspi4 vncserver-x11[540]: ConsoleDisplay: Cannot find a running X server on vt1
nov. 21 17:18:05 raspi4 vncserver-x11[540]: ConsoleDisplay: Found running X server (pid=583, binary=/usr/lib/xorg/Xorg)
nov. 21 17:20:07 raspi4 vncserver-x11[540]: Connections: connected: 192.168.1.11::38846 (TCP)
nov. 21 17:20:08 raspi4 vncserver-x11[540]: session started: user pi permissions f
nov. 21 17:20:08 raspi4 vncserver-x11[540]: Connections: authenticated: 192.168.1.11::38846 (TCP), as pi (f permissions)

Merci ‹ bof › , tout compte fait, avant de lire ton post, j’ai refais une install complète en prenant des notes (pas à la sauvage comme dab ) et en faisant un backup de ma SD (au fait c’est un peu long cette opération)
Merci pour le log ! :slightly_smiling_face:

Bon cela repart en sucette … cela arrive lorsque je n’ai pas connecté d’écran… j’ai donc créer un écran virtuel sur le serveur vnc de mon raspi (aprés avoir mis à jour vnc)
Je lance vncserver-virtual sous ssh
je lis donc Nouveau bureau : xxxx:2 (192.168.1.22:2)
j’ouvre donc mon viewer sur mon PC sur 192.168.1.22:2 et cela foncti:innocent:onne … (pour l’instant)

1 J'aime

Merci, ca marche! J ai choisi DMT mode 82 resolution full HD

1 J'aime

bonjour,
Ça se trouve où DMT mode 82 please?
Merci :smiley:

Bonjour, et merci beaucoup pour l’astuce, ça marche nickel

Pour moi modifier le fichier config.txt comme ceci fonctionne à merveille :slight_smile:

hdmi_ignore_edid=0xa5000080
hdmi_group=2
hdmi_mode=82

En esperant vous avoir aidé, j’ai galéré 2h avant de trouver l’astuce :wink:

La ligne suivante est essentiel sinon ca ne fonctionne pas
hdmi_ignore_edid=0xa5000080

Je suis sur PI4

Nickel, merci ! C’est bon pour moi en DMT mode 82 1920x1080 60hz 16:9

Bonjour tout le monde. voici mon 1er message sur un forum. A force de lire des infos, me voilà contributeur désormais.

VNC n’avais pas accès au bureau, comme toi.
J’avais simplement oublié de ‹ sudo raspi-config › puis ‹ Boot Options › -> ‹ B1 Desktop/CLI › et activer ‹ B3 › ou ‹ B4 › suivant le besoin de chacun.

Depuis cela fonctionne parfaitement
a++

Buster | PI B

Merci, ça a fonctionné pour moi.