OpenMediaVault et disque dur NTFS

Bonjour,
J’ai en projet de modifier légèrement la gestion de mon NAS (actuellement sur RPI1 avec samba) en installant OpenMediaVault sur RPI2.
Ma seule question (pour l’instant !), OpenMediaVault prend t-il en compte les disques durs formatés en NTFS ?
J’ai farfouillé dans tous les sens sur le net, mais je n’ai rien trouvé de très clair sur ce sujet.

Merci d’avance de vos réponses.

Salut ,

tu a pas bien chercher ;)(je te taquine )
alors sur raspbery l’inplentation du pilote ntfs-3g n’est pas comprise sur OMV ,contraitrement au version desktop

il te faudra l’installer tiens sa en parle ici https://www.tinkernut.com/portfolio/make-raspberry-pi-nas-network-attached-storage/

:loud_sound: je précisse que le pilote est pas tous a fait stable sur pi,donc tu aura des bug, il est conseiller de changer de systéme de fichier EXT4 étant le must

Merci pour la réponse, mais jusque là, j’avais tout bon ! :grin:

J’essuie les plâtres avec Openmediavault et je reprends rapidement:

J’ai 1 RPI2 et debian-jessie-pixel, un disque dur format NTFS raccordé en USB.

J’avais 2 impressions (mauvaises), la 1ère était que mon DD NTFS n’était pas reconnu par OpenMediaVault et la 2ème que j’avais écumé tout le net et bien faux pour les 2:

1: mon DD NTFS est bien non seulement reconnu, mais il est monté automatiquement par OpenMediaVault, à mon avis j’ai du faire déjà la motif (mais j’ai du oublier) puisque j’ai trouvé une vidéo sur youtube (pas de pub merci !!!) qui me montre qu’il faut le paramètrer dans OpenMediaVault…… https://www.youtube.com/watch?v=INkPKZ8JP_Y

2: donc j’ai trouvé des videos pour le paramètrage de OpenMediaVault

Pour reprendre, avec debian-jessie que je me rends compte qu’il n’y a pas besoin d’installer le pilote ntfs-3g, puisque, Il est déjà installé par défaut et donc pas besoin d’aller non plus d’aller modifier, le fichier « fstab ».

Cette fois j’ai mieux cerné ce qu’il ne va pas dans OpenMediaVault:

Quand je veux créer un dossier de partage, une fenêtre s’ouvre ou l’on doit nommer le dossier à créer et choisir sur quel périphérique l’installer, donc là, le menu déroulant ne fonctionne pas donc pas, donc je ne vois aucuns périphériques s’afficher.
J’ai le même chose a la création d’un dossier partagé SMB/CIFD.

J’ai fait un classique sur sudo apt-get update et sudo apt-get upgrade pour avoir un système à jour, idem pour une mise à jour de OpenMediaVault, mais cela ne change rien….

J’ai essayé de paramètrer le RPI2 depuis lui-même Debian-Jessie et Chromium, depuis un PC avec XP3 et Firefox et depuis un Macbookpro avec Safari…… rien ne change……

Etant un éternel débutant depuis 3 ans :disappointed_relieved: , je continue mes recherches et mes essais.

cordialement.

Bonjour,

Je sais que ce problème à plus de 3 ans mais j’ai eu exactement le même et j’ai eu beaucoup de difficulté à trouver une solution claire au problème, j’espère donc que ça pourra en aider certains.

Mon disque était un HDD toshiba de 1 To formaté ntfs.

Le problème vient d’un espace dans le nom du HDD que tu essaies de monter.
J’avais un HDD qui s’appelait « Thosiba Ext » je l’ai renommé en « Thoshiba_ext » et tout est rentré dans l’ordre, je vois bien le périphérique apparaître dans le menu déroulant « Périphérique » quand je cherche à ajouter un dossier partagé.

J’avais les symptômes suivants :

  • Impossible de monter le disque dans la GUI une erreur m’était renvoyée. (Très cryptique elle parlait d’une erreur sur la commande mount avec un « Bad call ».) --> Résolu en supprimant l’espace dans le nom du disque.
  • Rallumer ma raspberry Pi avec le disque déjà branché en USB me permettait de monter le disque (il l’était automatiquement dans la GUI, monté lors du boot j’imagine ?). Par contre démonter le disque pour le remonter provoquait la première erreur. --> Résolu en supprimant l’espace dans le nom du disque.
  • Le disque n’était pas visible dans la liste des périphériques lors de la création d’un dossier partagé
  • Le disque n’est pas visible dans la liste des périphériques lors de la création d’un nouveau système de fichiers. --> Pas résolu mais je pense que c’est normal étant donné que le disque est en ntfs et que je n’ai pas d’options pour ajouter un système de fichier en ntfs. --> Pas résolu.

Je pense qu’il s’agit d’un bug de OpenMediaVault qui gère mal les noms de device contenant des espaces. De manière générale il est bon de ne pas utiliser d’espaces dans les noms de fichiers et de dossiers ( et de périphérique ) :slight_smile:

Cordialement.