Nom de domaine pour accéder au serveur local

Bonjour à tous,

J’ai installé un serveur apache sur mon pi, mis des fichiers html dans le dossier var/www/html
modifié le nom du pi par monserveur
si je tape monserveur dans la barre d’adresse de mon navigateur j’ouvre bien les fichiers html.

J’ai installé RaspAP pour créer un hotspot wifi.
Quand je me connecte au hotspot wifi avec ma tablette et que je tappe monserveur dans le navigateur ça ne marche pas.
Si je tappe 10.3.141.1 je tombe bien sur les fichiers html.
Question : comment faire pour que je puisse accéder aux fichiers html du pi en me connectant au hotspot wifi et en tappant un nom (ex : monserveur) à la place de l’adresse ip du pi ?

Merci !!!

hello,

il doit te manquer une entrée DNS pour ton hotspot…
ça doit pouvoir se rajouter dans le fichier dhcp (/etc/dhcp/dhcpd.conf ?) utilisé par RaspAP de la forme :
option domain-name-servers ; 192.168.1.1;
ou 192.168.1.1 est l adresse de ta box où tu as le serveur dns de ton reseau privé

apres modification du fichier dhcpd.conf et redemarrage du service ça devrait dire a ta tablette lors de sa reconnexion, où chercher le nom lié a l IP

NB j ai pas installé RaspAP donc je ne suis pas sur de la syntaxe ni du nom du fichier a modifier mais avec une recherche dans ton systeme de dhcp ( par find ou un dpkg -l|grep dhcp ) tu seras vite fixé.
si tu y arrives pas (!) repost avec ta config ( version de l OS, type de box ça peut aider :wink:

source:https://wiki.debian.org/fr/DHCP_Server#Configuration__de_base