MotionEyeOs stream depuis adresse IP extérieure [RESOLU]

Bonjour,
J’ai MotionEyeOS installé sur un Rpi depuis quelque temps. J’avais paramétré une redirection de port pour y accéder depuis n’importe quel PC extérieur à mon réseau et tout fonctionnait parfaitement bien.
Je l’ai coupé quelques mois et j’ai retenté de l’utiliser dernièrement.
Et là grosse surprise. Impossible d’y accéder depuis un PC extérieur, mais par contre j’arrive à accéder à MotionEye depuis mon IP interne ET depuis mon IP externe sur un poste interne… Là je comprend pas trop.
Je suis sur une freebox…
Si quelqu’un a une piste…

Salut @campanule

Perso, je colle des IP fixes via filtrage des adresses MAC.
Donc je suis sûr que mon Rpi vision nocturne avec MotionEyeOS est sur 192.168.0.25 quelque soit le jour et le lieu (chaque pièce est câblée) ; même si je le rallume après 2 mois.
Vérifie ton adresse IP interne actuelle et celle de la redirection car je pense que ton bail DHCP a expiré.
Enfin, j’espère car ça serait simple = il suffirait de reconfigurer une redirection :slight_smile:

As-tu vérifié le port de stream ? et si le stream est bien activé.

++

Bonjour,
Je suis en IP fixe depuis la mise en place de mon installation. En effet plus sûr ! Donc le problème ne vient pas de là (d’ailleurs il stream très bien en local sans avoir changé l’adresse dans mon navigateur).
Sur le portail freebox, la redirection de port semble bien active…
Je me connecte avec les bonnes adresses IP (vérifié sur le portail de la freebox, visiblement rien à changé de ce côté là depuis l’interruption).
Sur MotionEye pour moi, le stream est fonctionnel :

image
Mais j’ai très bien pu décocher une case quelque part et l’avoir oublié !

Mais je ne comprend vraiment pas comment je peux atteindre depuis ma box à la fois mon IP locale et mon IP externe… je pensais la chose impossible !!

Hello,

Redemarre ta freebox, il me semble avoir vu le même soucis réglé ainsi

Bonjour,
Merci du coup de main,
Il y a une amélioration… avec la remise à 0 de la box, je n’accède plus à mon IP publique en local…
Mais toujours impossible d’accéder à MotionEye depuis mon IP publique à l’extérieur…

J’avais dis redémarrer, pas reseter !

J’ai fait les deux. J’avais fait un redémarrage quand j’ai découvert le problème… sans résultat. C’est pour ça que je suis passé à la remise à 0…

Suite des péripéties…
J’ai vérifié mes baux DHCP permanents sur http://mafreebox.freebox.fr/ et j’ai comparé avec ce que j’ai dans l’interface de gestion de ma Freebox.
Pour le RPI sur lequel est installé MotionEyeOS, pas de problème par contre, mon autre RPI n’était pas sur la même IP sur deux. J’ai attribué une IP fixe à une 3ème machine qui n’en avait pas encore et j’ai redémarré la box.
Maintenant les attributions dhcp correspondent bien à ce que j’ai rentré… mais j’ai de nouveau accès à mon IP publique en local… et MontionEye n’est toujours pas accessible de l’extérieur…
Bref, je tourne en rond !!

Au niveau de la redirection des ports sur la freebox j’ai un truc du type :
TCP - 8082 - 192.168.0.15 -80

Ce qui me semble correct… Et donc on me connectant sur mon IPpublique:8082 en dehors de mon réseau interne ça devrait fonctionner, il me semble (enfin ça fonctionnait il y a 2 mois).

Yo,

Juste une idée.
Tu es passé à la fibre entre temps ?
Parce que chez moi, comme chez d’autres, la passage à la fibre a été génial pour le débit … mais … pas pour la gestion des ports.
J’ai dû demander une IP personnelle et pas partagée.
Je suis en « Full Stack »
(dans « Ma Freebox », option « Demander une adresse IP fixe V4 full-stack »)
++

Merci pour la piste…
Je ne suis pas passée à la fibre (du moins pas à ma connaissance) mais je vois dans mon interface de gestion que j’ai un préfixe IPV6… ça peut venir de là ?
Je peux toujours tenter le coup de demander l’IP fixe V4 full stack… mais qu’est ce que ça implique (je n’y connais rien !!) ??

Re,
Tu vas sur mafreebox.freebox.fr
Tu vas sur « État de la Freebox »
Puis sur "l’onglet « État Internet »
En face de « type de connexion », tu as quoi ?
En face de Adresse IPv4, tu as quoi ?
–> Ne donne pas ton IP , mais la suite ; moi, j’ai xx.xx.xxx.xxx (Ports 0 à 65535)

Merci !!!
C’est bien une question de plage de ports
Visiblement Free a changé la plage de ports qui m’étais attribuée et le port 8082 n’était pas dans la plage…
J’ai modifié ma redirection en indiquant en port source un port dans la plage donné par Free… et ça fonctionne !!!

CCL :
Le problème d’un nageur, n’est pas forcément sa technique de nage … mais la présence ou non de l’eau autour de lui :sunglasses:

Prendre du recul :wink:

C’est tout l’intérêt d’un forum !!
En tout cas merci !!

Pas de quoi ; comme tu dis :

Au plaisir,