MotionEye et IPCAM

Bonjour

J’ai une caméra IP FOSCAM C1 branchée sur un port numéro 1 de ma box internet.
J’ai une raspberry 3 branchée sur un port numéro 2 de ma box internet avec Raspbian comme OS dessus.

Lorsque je tente de me connecter avec motion EYE (sur la RSPI) vers la CAM IP voici ce que j’obtiens comme message, j’ai testé plusieurs URL je n’en mets que 2 ici :

Connection reset by per
(rtsp://192.XXXXX:88/videoMain

Not a supported network Camera
htttp://192,XXXXXX:88/

Idem VLC sur mon mac n’arrive pas à se connecter par le LAN sur la CAM IP.

LE service technique de FOSCAM ne sait pas quoi faire…

EST ce que quelqu’un à ma config et mon pb ?

A l’aide !!

Merci d’avance si qqn trouve la bonne URL… (PI FOscam me dit que ça vient soit de la RSPI soit de MotionEye)

Bonjour,

Pour de l’aide se référer au manuel en premier lieu:


Chapître 2 : Access the IP Camera

Je lis:

For example:
IP: 192.168.1.11
RTSP Port number: 554
User name: admin
Password: 123
Enter either one of the following four URLs in the VLC

1.rtsp://admin:123@192.168.1.11:554/videoMain
2.rtsp:// @192.168.1.11:554/videoMain
3.rtsp://:123@192.168.1.11:554/videoMain
4.rtsp://admin@192.168.1.11:554/videoMain

Vous devez passer les identifiants/mots de passe et changer le port je dirai. Je traduis:

Si vous avez un identifiant et un mot de passe utilisez l’URL n°1.
Si vous n’avez pas d’identifiant et mot de passe utilisez l’URL n°2.
Si vous avez uniquement un mot de passe et pas de nom utilisateur utilisez l’URL n°3.
Si vous avez uniquement un nom utilisateur sans mot de passe utilisez l’URL n°4.

Essayez les URLs précédentes et tenez moi au courant. Bon courage.

Voila tous mes essais sachant qu’en ce qui concerne la connexion VLC en direct j’ai tout testé comme demandé et aussi en mettant l’adresse IP de l’IP CAM (xxx.XXX.XXX.38) et j’obtiens le même message d’erreur.

Par contre j’ai trouvé un connexion REfused (dernier imprimer écran AVANT DE POUVOIR METTRE mon MDP) et j’ai aussi retirer le nom de dossier, idem même message d’erreur. (Par contre je pense que maintenant le num de port est bon)

Je pense que c’est au niveau de l’appel du flux via l’url rtsp. L’identifiant ‘admin’ et mdp ‘123’ fourni par la documentation, ainsi que le numéro de port sont à titre d’exemple il faut ajuster en fonction de votre configuration.

Quand vous n’utilisez pas de mot de passe, vous devez entrer:

rtsp://@192.168.1.11:554/videoMain

le ‘@’ est très important pour que le 'programme sache que vous n’utilisez pas d’identifiant et mot de passe.

RTSP est un serveur autre que HTTP , rtsp tourne sur le port 554 et http 80 et 443.

Pour vous connecter à l’administration de la CAM.

Chapître ‘2.1 WiredConnection’
‘The default HTTP port NO. is 88’ , http:// LAN IP+HTTP Port NO

http://192.168.1.38:88

The default HTTPS port NO. is 443 , \https://LAN IP+HTTPS Port NO.
(je vous conseil de toujours utiliser cette url qui est sécurisée tant qu’à faire, pour l’accès aux paramètres de configuration de votre CAM sur votre réseau L.A.N)

https://192.168.1.38:443

Pour lire le flux via VLC

rtsp://@192.168.1.38:554/videoMain

J’ai bien l’impression que l’erreur se trouve ici car je vois sur vos screenshots de vlc les identifiants qui sont fourni à titre d’exemple. Avez-vous ajouté/modifié un compte admin avec le mdp 123 ? Si ce n’est pas le cas entrez l’url RTSP juste ci-dessus dans VLC.

Essayez d’abord d’accèder à la CAM par votre mac, a son espace d’administration puis avec vlc au flux. Ensuite vous pourrez configurer motion eye.

Chapître 2.4 Using the VLC player

RTSP URL rtsp:// [user name][:password]@IP:Port number/videostream

  • The part in the square brackets can be omitted.
  • user name & password: The user name and password to access the camera. This part can be omitted.
  • Video stream: Three modes are supported: video Main, video Sub and audio. Video Sub is a better choice in bad network condition. If you select audio, you can only hear sound without seeing picture
  • Sometimes you may need to enter the user name and password for another time. Click OK and you can see the real-time preview.

Coucou ici

il semble que dans tes captures d’ecrans tu oublie de renseigner ton id/pwd pour te connecter , et a priori vu les lignes plus haut cest admin/123

Courage

“Glou”, Oui en effet ca me parait tout à fait clair (c’est sympa de donner ton avis mais il vaut mieux ne pas “interférer” de trop)

Reprenons le stream :

Oui en effet j’ai un compte admin avec un mot de passe que j’ai créé.
Et j’arrive très bien et tout à fait à me connecter sur la page d’admin de la cam car j’y ai rajouté les @mails

Je l’avais remarqué hyt82909, moi aussi j’ai mis mon vrai mot de passe d’admin mais uniquement en faisant le test depuis Motion Eye, j’ai pas testé en direct sur VLC, c’est vrai que j’ai testé uniquement avec le mot de passe par défaut danas mes imprimes écran. Mais de toutes les façons MotionEye bloquait aussi avec mon propre mot de passe d’admin que j’ai créé et modifié il y a 3 jours (pas mis dans les imprimes-écran) …je vais tenter avec VLC dans le doute avec le nouveau mot de passe que j’ai créé mais je ne me fais guère d’illusion. Pourquoi ca fonctionnerait bien avec VLC et pas Motion Eye ? Wait and see je vais faire le test quand même avec VLC

(idem qu’hier ==> je fais ça ce soir dès que je peux, faut que je rentre du boulot :))

Merci hyt82909

Manque de pot …ça fonctionne pas !!

Par instinct j’ai quand même imprimé les ports sous VLC.

J’ai changé mon mot de passe perso bien-sûr pour l’imprime écran<img src="/uploads/default/original

mdp visible sur ta derniere capture, attention, question sécurité

Oui MERCI !!! photo supprimée

Du coup je suis bloqué encore. Toujours les mêmes messages d’erreur de la part de VLC

Voir vos messages privés pour mes réponses.

Je viens de tenter une connexion https (comme ca ne fonctionne toujours pas en http, et qu’il n’y a aucun autre port d’ouvert…contrairement au mode op fourni par FOscam…) je tente le https mais la VLC plante et ne veut pas accepter le certificat et je boucle sur ce message même si j’accepte quand même le certificat… !!!

@Raspix

Hello,

(Désolé, absence.
on reprendra nos tests en privé)

Il faut trouver le bon flux pour que MotionEye accepte les informations.
Je préconise de tester des tas de configuration d’adresse directement depuis un navigateur.
Sur ton Mac, une fois la CamIP branchée = tu te connectes à ta caméra pour vérifier que ça fonctionne (principe de base ;-))
Ensuite, avec FireFox, tu tentes des adresses.
Normalement, c’est du type
htttp://192.168.1.XX:port/fin-de-l-adresse

Chez moi, j’ai une HEDEN.
Je m’y connecte en direct en faisant : http://192.168.0.54:8080
puis je renseigne utilisateur et mot de passe et accède ainsi à la console d’administration.

Si je tape http://192.168.0.54:8080/videostream.cgi alors, ça me permet de voir juste l’image (le flux vidéo) en direct.

C’est cette adresse que je récupère dans MotionEye afin que MotionEye fonctionne (sinon, j’ai “Not a supported network Camera”).

A mon avis, tu devrais prendre du recul et chercher juste sur FireFox.

@+ en MP et courriels en parallèle

Bonjour,
J’ai une Raspberry PI 3B et MotionEyeOS sur la carte SD
J’ai des caméras Heden, en version 5.5, 6.2 et 7.2
J’ai pu ajouté la caméra Heden 5.5 : l’URL http://192.168.xxx.xxx:8081/videostream.cgi est OK
Mais je n’ai pas pu ajouté les caméras Heden 6.2 et 7.2 je n’arrive pas à trouver l’URL.
Pourtant je my connecte dans IE par son adresse IP : 192.168.yyy.yyy se transforme en http://192.168.yyy.yyy/web/admin.html .
Pouvez vous me donner le bon URL pour ajouter ces caméras Heden 6.2 et 7.2 dans MotionEye

Salut,

tu dois mettre 8765 comme port et comme IP c’est celle de ta PI (en http ‘basique’ pas https)

A++