Mise a jour osmc impossible

Bonjour,
J’ai essayé de mettre a jour osmc pour profité de kodi 19 sur la nouvelle version mais ça ne va pas jusqu’au bout.
Voici les dernière ligne qu’il m’affiche :
E: Failed to fetch http://ftp.debian.org/debian/pool/main/m/mariadb-10.3/mariadb -common_10.3.29-0+deb10u1_all.deb 404 Not Found [IP: 199.232.178.132 80]
E: Failed to fetch http://security.debian.org/pool/updates/main/o/openssl/openss l_1.1.1d-0+deb10u6_armhf.deb 404 Not Found [IP: 199.232.178.132 80]
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-mis sing?

J’ai essayer en passant par my osmc mais ça ne va pas jusqu’au bout non plus. Il est installer sur un raspberry pi 3B+

hello,

Ton système utilise des dépôts qui sont plus récents que lui … en clair la mise à jour cherche des programmes dans le mauvais endroit !

peut être une solution ici : Keeping your OSMC system up to date - General - OSMC

mais peut être pas si les dépôts sont pour debian bulleyes et que osmc utilise encore buster ( désolé je ne connais pas OSMC)

plus d’info :
https://forums.raspberrypi.com/viewtopic.php?t=317507

Merci de la réponse.

J’ai essayé à tout hasard en fin de journée la commande ‹ apt-get dist upgrade --fix-missing › c’est allé jusqu’au bout mais avec le même message d’erreur et le système c’est bloquer sur les commande en cours d’exécution. Je l’ai redémarré manuellement et il c’est mit correctement à jour.
Pour info dans le fichier /etc/apt/source.list il y a une ligne spécifique pour osmc
Par contre je sais pas si il y a une solution plus propre.

a priori le paquet demande une version 3.10.29 de mariadb server or ce paquet n’existe pas dans buster ( remplacer par 10.3.31 )

j’imagine que c’est pareil pour openssl…

kodi 19 il fonctionne maintenant ?

il est possible d’empêcher une mise à jour :

echo "<package> hold"|sudo dpkg --set-selections

ou de le debloquer

 echo "<package> install" | sudo dpkg --set-selections

et verifier l’état :

sudo dpkg --get-selections|grep <package>

si tu as besoin d’une version particulière il est possible l’installer avec
sudo dpkg -i <package>.deb
a condition de trouver le bon package pour raspbian
ou a partir du source en le compilant

Ça fait 24h que je l’utilise et je n’ai aucun problème et tous les services que j’utilisais fonctionne très bien.
J’ai peur que faire des installation ciblé comme ça ne soit pas dans mes cordes, si ça plante je suis pas sur de réparer les erreur.
J’ai refait un update et un dist-upgrade aucune erreur nul part. J’avais pas mis a jours mon système depuis longtemps et j’ai raté pas mal de version peut être que mes problème viennent de là.