KODI démarrage auto après lancement Raspbian

Bonjour,

J’ai une RPI4, j’ai installé Raspbian dernière version et KODI 18.5. Je veux avoir la possibilité de lancer KODI au démarrage, puis de pouvoir le quitter pour retrouver l’interface de Raspbian.

via le terminal
sudo nano /etc/xdg/lxsession/LXDE-pi/autostart
puis j’ai ajouté @kodi.

KODI se lance donc au démarrage mais je rencontre 2 problèmes :

  • Lorsque je lance une vidéo, j’ai une fenêtre noire de boot par dessus. (j’ai le son mais l’image est caché par cette fenetre en partie)
  • Quand je quitte KODI pour retourner sur Raspbian, il relance KODI automatiquement, je requitte et il reste bloqué sur une fenetre de boot.

Avez-vous une idée ? merci d’avance

J’ai trouvé une solution, je poste si jamais quelqu’un est dans le même cas que moi :

virer @kodi de /etc/xdg/lxsession/LXDE-pi/autostart.

ouvrir terminal : sudo nano .config/lxsession/LXDE-pi/autostart
ajouter @kodi mais le mettre tout en haut de la liste pour qu’il soit exécuté en premier.

Tout fonctionne.

Bonjour,

sinon en fouillant un peu sur le forum, on avait déjà donné une solution qui permet de revenir sur la console raspbian apres le boot sur kodi (meme si le retour est un peu long, ca marche vraiment bien)

je vous remet ici cette soluce

1- récuperer le script qui va permettre de faire de kodi un service
sudo wget -O /etc/init.d/kodi https://gist.githubusercontent.com/shyamjos/60ea61fd8932fd5c868c80543b34f033/raw

2 - on donnes les bons droits au script récupéré et on active
sudo chmod +x /etc/init.d/kodi
sudo systemctl daemon-reload
sudo systemctl enable kodi

3 - un pti sudo reboot pour valider que ca marche bien

J’ai testé ce script sur raspbian 9 & 10 , ca roule du feu de dieu !

Courage