Installer WordPress sur une Raspberry Pi (avec Nginx) 2

Bonjour à tous,
Je sollicite votre aide pour terminer le tuto « Installer WordPress sur une Raspberry Pi (avec Nginx) » sur ce même site.
Je suis bloqué à la dernière étape quand il faut redémarrer le serveur nginx :frowning:
J’ai bien un nom de domaine réservé et je l’ai utilisé dans certaines parties du tuto.

J’ai également essayé de m’en sortir en suivant le fil sur le forum :

Voici ce que j’ai dans mon fichier wordpress (j’ai compris que je pouvais aussi bien mettre mon nom de domaine ou l’IP locale de mon rasp ?) :

server {
 listen 80;
 root /var/www/html/wordpress;
 index index.php;
 server_name 192.168.1.25 www.192.168.1.25;
 access_log /var/log/nginx/siteamoi.access_log;
 error_log /var/log/nginx/siteamoi.error_log
 notice;
 location / {
  try_files $uri $uri/ /index.php?$args;
 }
 location ~ \.php$
 {
  include snippets/fastcgi-php.conf;
  fastcgi_pass unix:/var/run/php/php7.3-fpm.sock;
 }
}

Puis :
ln -s /etc/nginx/sites-available/siteamoi /etc/nginx/sites-enabled/siteamoi

Et enfin quand j’essaie de rédémarrer nginx, j’obtiens : … (c’est bien le mot de passe « pi » de mon rasp qu’il faut utiliser ?)

pi@raspberrypi:/etc/nginx/sites-available $ /etc/init.d/nginx restart                                  [....] Restarting nginx (via systemctl): nginx.service==== AUTHENTICATING FOR org.freedesktop.systemd1.manage-units ===
Authentication is required to restart 'nginx.service'.
Authenticating as: ,,, (pi)
Password:
==== AUTHENTICATION COMPLETE ===
Job for nginx.service failed because the control process exited with error code.
See "systemctl status nginx.service" and "journalctl -xe" for details.
 failed!
pi@raspberrypi:/etc/nginx/sites-available $

J’avais bien suivi le tuto pour installer nginx précédemment sans souci.

Si l’un de vous avait une idée ce serait super ! Merci par avance et bon we !
Pkpas

Tu ne peux pas ajouter un « www » a une adresse IP.
L’adresse IP du vHost est pas statique je crois, elle change à chaque redémarrage, ont set jamais un vHost depuis un IP local, même si le IP est correct localement, ceux du Net ne verrons rien car elle n’est pas valide pour eux.

La ligne que je parle : server_name 192.168.1.25 www.192.168.1.25; Je suis plus habitué avec Apache, le vHost serais alors « * » pour un « catch all ».

Pour relancer ton service, fait pas /etc/init.d/nginx restart mais sudo /etc/init.d/nginx restart ou encore mieux sudo systemctl restart nginx, le sudo est pour passer une commande en mode « root », en étant déjà sous l’user « pi » qui est dans la liste « sudoer » le mot de passe sera pas requis.

PS. Pense à formater correctement ton texte quand tu post sur un forum :slight_smile: Sinon c’est dur de différencier le texte des logs

Yo,

Après ton
ln -s /etc/nginx/sites-available/siteamoi /etc/nginx/sites-enabled/siteamoi

Tu peux passer un
sudo nginx -t
puis, seulement si c’est OK
sudo systemctl restart nginx

Sinon, (comme @levelKro) quand tu notes

 server_name 192.168.1.25 www.192.168.1.25;

C’est bien pour l’exemple ? parce que c’est de l’IP privée ça
On est d’accord que c’est plutôt

 server_name siteamoi.truc www.siteamoi.truc;

Sinon …

Bon, évidemment, puisque le système te le demande, aller voir

systemctl status nginx.service

et

journalctl -xe

peut être une bonne idée :wink:

PS : j’ai formaté le code du message initial

1 J'aime

Merci à tous les deux ! :slight_smile:

Alors tout d’abord, j’ai modifié le fichier « wordpress » :

Citation
server {
listen 80;
root /var/www/html/wordpress;
index index.php;
server_name designex.fr www.designex.fr;
access_log /var/log/nginx/siteamoi.access_log;
error_log /var/log/nginx/siteamoi.error_log
notice;
location / {
try_files $uri $uri/ /index.php?$args;
}
location ~ .php$
{
include snippets/fastcgi-php.conf;
fastcgi_pass unix:/var/run/php/php7.3-fpm.sock;
}
}

Ensuite j’ai testé les deux commandes :

sudo /etc/init.d/nginx restart

Citation
pi@raspberrypi:/etc/nginx/sites-available $ sudo /etc/init.d/nginx restart
[…] Restarting nginx (via systemctl): nginx.serviceJob for nginx.service failed because the control process exited with error code.
See « systemctl status nginx.service » and « journalctl -xe » for details.
failed!
pi@raspberrypi:/etc/nginx/sites-available $

sudo systemctl restart nginx

Citation
pi@raspberrypi:/etc/nginx/sites-available $ sudo systemctl restart nginx
Job for nginx.service failed because the control process exited with error code.
See « systemctl status nginx.service » and « journalctl -xe » for details.

Effectivement, cette étape renvoie déjà un message d’erreur :

Citation
pi@raspberrypi:/etc/nginx/sites-available $ sudo nginx -t
nginx: [emerg] open() « /etc/nginx/sites-enabled/siteamoi » failed (2: No such file or directory) in /etc/nginx/nginx.conf:62
nginx: configuration file /etc/nginx/nginx.conf test failed

Et enfin pour les 2 messages qui doivent correspondre aux logs (?), j’obtiens :

Citation
pi@raspberrypi:/etc/nginx/sites-available $ systemctl status nginx.service
● nginx.service - A high performance web server and a reverse proxy server
Loaded: loaded (/lib/systemd/system/nginx.service; enabled; vendor preset: enabled)
Active: failed (Result: exit-code) since Sat 2021-04-24 20:06:11 BST; 1h 2min ago
Docs: man:nginx(8)
Process: 20841 ExecStartPre=/usr/sbin/nginx -t -q -g daemon on; master_process on; (code=exited, stat
Apr 24 20:06:11 raspberrypi systemd[1]: Starting A high performance web server and a reverse proxy serv
Apr 24 20:06:11 raspberrypi nginx[20841]: nginx: [emerg] open() « /etc/nginx/sites-enabled/siteamoi » fai
Apr 24 20:06:11 raspberrypi nginx[20841]: nginx: configuration file /etc/nginx/nginx.conf test failed
Apr 24 20:06:11 raspberrypi systemd[1]: nginx.service: Control process exited, code=exited, status=1/FA
Apr 24 20:06:11 raspberrypi systemd[1]: nginx.service: Failed with result ‹ exit-code ›.
Apr 24 20:06:11 raspberrypi systemd[1]: Failed to start A high performance web server and a reverse pro

Et

Citation
pi@raspberrypi:/etc/nginx/sites-available $ journalctl -xe
– The job identifier is 2117.
Apr 24 20:15:19 raspberrypi rngd[306]: stats: bits received from HRNG source: 200064
Apr 24 20:15:19 raspberrypi rngd[306]: stats: bits sent to kernel pool: 153824
Apr 24 20:15:19 raspberrypi rngd[306]: stats: entropy added to kernel pool: 153824
Apr 24 20:15:19 raspberrypi rngd[306]: stats: FIPS 140-2 successes: 10
Apr 24 20:15:19 raspberrypi rngd[306]: stats: FIPS 140-2 failures: 0
Apr 24 20:15:19 raspberrypi rngd[306]: stats: FIPS 140-2(2001-10-10) Monobit: 0
Apr 24 20:15:19 raspberrypi rngd[306]: stats: FIPS 140-2(2001-10-10) Poker: 0
Apr 24 20:15:19 raspberrypi rngd[306]: stats: FIPS 140-2(2001-10-10) Runs: 0
Apr 24 20:15:19 raspberrypi rngd[306]: stats: FIPS 140-2(2001-10-10) Long run: 0
Apr 24 20:15:19 raspberrypi rngd[306]: stats: FIPS 140-2(2001-10-10) Continuous run: 0
Apr 24 20:15:19 raspberrypi rngd[306]: stats: HRNG source speed: (min=238.131; avg=497.833; max=661.381
Apr 24 20:15:19 raspberrypi rngd[306]: stats: FIPS tests speed: (min=5.842; avg=6.386; max=6.563)Mibits
Apr 24 20:15:19 raspberrypi rngd[306]: stats: Lowest ready-buffers level: 2
Apr 24 20:15:19 raspberrypi rngd[306]: stats: Entropy starvations: 0
Apr 24 20:15:19 raspberrypi rngd[306]: stats: Time spent starving for entropy: (min=0; avg=0.000; max=0
Apr 24 20:17:01 raspberrypi CRON[21608]: pam_unix(cron:session): session opened for user root by (uid=0
Apr 24 20:17:01 raspberrypi CRON[21609]: (root) CMD ( cd / && run-parts --report /etc/cron.hourly)
Apr 24 20:17:01 raspberrypi CRON[21608]: pam_unix(cron:session): session closed for user root
Apr 24 20:39:01 raspberrypi CRON[23020]: pam_unix(cron:session): session opened for user root by (uid=0
Apr 24 20:39:01 raspberrypi CRON[23021]: (root) CMD ( [ -x /usr/lib/php/sessionclean ] && if [ ! -d /r
Apr 24 20:39:01 raspberrypi CRON[23020]: pam_unix(cron:session): session closed for user root
Apr 24 20:39:02 raspberrypi systemd[1]: Starting Clean php session files…
– Subject: A start job for unit phpsessionclean.service has begun execution
– Defined-By: systemd
– Support: Debian -- Support

– A start job for unit phpsessionclean.service has begun execution.

– The job identifier is 2177.
Apr 24 20:39:03 raspberrypi systemd[1]: phpsessionclean.service: Succeeded.
– Subject: Unit succeeded
– Defined-By: systemd
– Support:

– The unit phpsessionclean.service has successfully entered the ‹ dead › state.
Apr 24 20:39:03 raspberrypi systemd[1]: Started Clean php session files.
– Subject: A start job for unit phpsessionclean.service has finished successfully
– Defined-By: systemd
– Support:

– A start job for unit phpsessionclean.service has finished successfully.

– The job identifier is 2177.
Apr 24 21:08:02 raspberrypi sudo[24979]: pi : TTY=pts/0 ; PWD=/etc/nginx/sites-available ; USER=r
Apr 24 21:08:02 raspberrypi sudo[24979]: pam_unix(sudo:session): session opened for user root by pi(uid
Apr 24 21:08:02 raspberrypi sudo[24979]: pam_unix(sudo:session): session closed for user root
Apr 24 21:09:01 raspberrypi CRON[25043]: pam_unix(cron:session): session opened for user root by (uid=0
Apr 24 21:09:01 raspberrypi CRON[25044]: (root) CMD ( [ -x /usr/lib/php/sessionclean ] && if [ ! -d /r
Apr 24 21:09:01 raspberrypi CRON[25043]: pam_unix(cron:session): session closed for user root
Apr 24 21:09:02 raspberrypi systemd[1]: Starting Clean php session files…
– Subject: A start job for unit phpsessionclean.service has begun execution
– Defined-By: systemd
– Support: Debian -- Support

– A start job for unit phpsessionclean.service has begun execution.

– The job identifier is 2237.
Apr 24 21:09:03 raspberrypi systemd[1]: phpsessionclean.service: Succeeded.
– Subject: Unit succeeded
– Defined-By: systemd
– Suppo

– The unit phpsessionclean.service has successfully entered the ‹ dead › state.
Apr 24 21:09:03 raspberrypi systemd[1]: Started Clean php session files.
– Subject: A start job for unit phpsessionclean.service has finished successfully
– Defined-By: systemd
– Support:

– A start job for unit phpsessionclean.service has finished successfully.

– The job identifier is 2237.

Que dit un nano /etc/nginx/nginx.conf ?

++

Voici ce que j’obtiens quand je lance ta commande :

user www-data;
worker_processes auto;
pid /run/nginx.pid;
include /etc/nginx/modules-enabled/*.conf;

events {
worker_connections 768;
# multi_accept on;
}

http {

    ##
    # Basic Settings
    ##

    sendfile on;
    tcp_nopush on;
    tcp_nodelay on;
    keepalive_timeout 65;
    types_hash_max_size 2048;
    # server_tokens off;

    # server_names_hash_bucket_size 64;
    # server_name_in_redirect off;

    include /etc/nginx/mime.types;
    default_type application/octet-stream;

    ##
    # SSL Settings
    ##

    ssl_protocols TLSv1 TLSv1.1 TLSv1.2; # Dropping SSLv3, ref: POODLE
    ssl_prefer_server_ciphers on;

    ##
    # Logging Settings
    ##

    access_log /var/log/nginx/access.log;
    error_log /var/log/nginx/error.log;

    ##
    # Gzip Settings
    ##

    gzip on;

    # gzip_vary on;
    # gzip_proxied any;
    # gzip_comp_level 6;
    # gzip_buffers 16 8k;
    # gzip_http_version 1.1;
    # gzip_types text/plain text/css application/json application/javascript text/xml application/$

    ##
    # Virtual Host Configs
    ##

    include /etc/nginx/conf.d/*.conf;
    include /etc/nginx/sites-enabled/*;

}

#mail {

# See sample authentication script at:

# http://wiki.nginx.org/ImapAuthenticateWithApachePhpScript

    ssl_prefer_server_ciphers on;

    ##
    # Logging Settings
    ##

    access_log /var/log/nginx/access.log;
    error_log /var/log/nginx/error.log;

    ##
    # Gzip Settings
    ##

    gzip on;

    # gzip_vary on;
    # gzip_proxied any;
    # gzip_comp_level 6;
    # gzip_buffers 16 8k;
    # gzip_http_version 1.1;
    # gzip_types text/plain text/css application/json application/javascript text/xml application/$

    ##
    # Virtual Host Configs
    ##

    include /etc/nginx/conf.d/*.conf;
    include /etc/nginx/sites-enabled/*;

}

#mail {

# See sample authentication script at:

# http://wiki.nginx.org/ImapAuthenticateWithApachePhpScript

# auth_http localhost/auth.php;

# pop3_capabilities « TOP » « USER »;

# imap_capabilities « IMAP4rev1 » « UIDPLUS »;

server {

listen localhost:110;

protocol pop3;

proxy on;

}

server {

listen localhost:143;

protocol imap;

proxy on;

}

#}

Déjà, ceci me dit que le lien symbolique pointe sur une place inexistante. As tu mis une extension ? Est-ce que ta commande est correct ? Pourquoi ne pas créer la config directement dans le bon dossier ? Corrige ton lien symbolique.

Merci beaucoup pour toutes vos réponses !

Après avoir réalisé des modifs sur le fichier /etc/nginx/sites-available/wordpress et avoir refait le lien symbolique correctement, la commande pour redémarrer nginx fonctionne bien. Maintenant quand je tape l’ip de ma rasp, le navigateur m’affiche la page « PHP Version 7.3.27-1~deb10u1 ».
Quelle étape ai-je pu louper pour ne pas qu’il m’affiche la page du serveur wordpress ? :frowning:

Ah si ça fonctionne en ajoutant /wordpress après l’IP ! :slight_smile:

1 J'aime