Impossible d'installer/trouver une librairie

Bonjour,

étant novice sur Raspberry Pi j’en appel à vos connaisses :slight_smile:
Cela fait 3 jour que j’essaie de trouver et installer une librairie OpenCV : libopencv-legacy afin d’utiliser une librairie d’utilisation de la camera raspberry Pi.

Lors de la compilation j’ai le message suivant :
/usr/bin/ld : ne peut trouver -lopencv_legacy
collect2: error: ld returned 1 exit status
make: *** [Makefile:57: raspicamtest] Error 1

Du coup j’ai voulu installer cette librairie mais encore un échec j’obtiens ça :
sudo apt-get install -y libopencv-legacy
Lecture des listes de paquets… Fait
Construction de l’arbre des dépendances
Lecture des informations d’état… Fait
E: Impossible de trouver le paquet libopencv-legacy

S’il vous plaît quelqu’un à une idée?

Pour info j’ai installé raspbian sur mon Raspberry.

un grand merci à vous.

Bonjour

1 - Mettre à jour la liste des paquets connus sous Raspbian en local

sudo apt update

2 - Chercher si le paquet souhaité est dans la distribution

sudo apt-cache search libopnecv

De mon coté je ne trouve pas de libopencv-legacy.

Le tuto utilisé est-il compatible Raspbian, si oui est-ce pour la même version de l’OS ?

On trouve des paquets y faisant référence sur cette page:

https://packages.debian.org/fr/sid/libopencv-legacy-dev

A mon avis compiler des logiciels n’est pas simple pour des novices, lorsqu’il manque en plus des paquets dans la distribution c’est encore plus difficile d’arriver à ses fins, c’est à dire à faire fonctionner le logiciel à compiler. Mieux vaut reprendre les recherches vers des logiciels compatibles et déjà dans les distributions.

A+

Bonjour,

tout d’abord merci pour votre réponse.

Je ne trouve pas le paquet également dans la distribution que j’ai en tapant la commande que vous avez donné.

Le tutoriel que j’utilise est celui-ci : https://www.pihomeserver.fr/2014/01/22/raspberry-pi-home-server-utiliser-opencv-avec-la-pi-camera/

Du coup il est impossible de rajouter une librairie qui n’est pas dans la version de distribution que j’ai?

Merci à vous :slight_smile:

hello,

si j’en crois ce post ( https://answers.opencv.org/question/214301/linker-error-with-opencv-legacy-and-contrib/) cette librarie est obsolète et a été remplacée.

si tu utilises un raspberry le plus simple est certainement de passer par python (https://pypi.org/project/opencv-python/)

PS:ton tuto date de 2014 tu peux en googliser un plus récent en précisant la date avec « outils » moins d’un an c’est mieux… 2014 en informatique c’est quasiment le moyen age :wink:

Bonjour,

Effectivement un tuto de 2014, ça date…
N’y aurait-il pas des logiciels plus récents qui feraient le taf ?

A+

clair ! la version 4.2.0 d’opencv pour c++ et celle d’ open-python date de fin 2019…
https://opencv.org/releases/
par contre pour faire de l’IA il va falloir investir un peu ( https://www.hackster.io/news/getting-started-with-the-intel-neural-compute-stick-2-and-the-raspberry-pi-6904ccfe963)
je n’ai pas eu le courage d’essayer sur raspi4 mais quand je vois comment ça rame sur mon i7 avec une nvidia 1060 6Go …