Impossible de mettre le GPIO pin 7 (GPCLK0) au niveau HIGH

Bonjour à tous ,
sur une raspberry 3 B+ cette pin ne se met pas au niveau haut (ça bagotte entre 0.4 et 1V) , alors que pour les autres ça se passe sans souci .
probleme connu ?
solution connue ?
merci

Excusez moi, mais sans boule de crystal, il est difficile de déterminer si et comment vous avez configuré votre Pi, et si vous avez une horreur dans vos scripts ou vos essais en ligne de commande.
Par exemple, si vous avez autorisé le SPI, on peut subodorer que les deux chips selects du SPI seront gérés par le noyau, FYI la pine 7 est l’un des deux chips enable. (CE1 selon https://www.raspberrypi.org/documentation/usage/gpio/ )Cela reste malheureusement du domaine de la pifomètrie.
Toujours dans les spéculations : avez vous oublié de declarer 7 en sortie?
Edité : Avez vous mélangé les numéros sur le connecteur avec les numéros de pattes(ça peut arriver)…
Comment mesurez vous la tension et accrochez vous vos sondes?.

Merci pour votre interet à mon probleme
Voila le petit programme :

#!/usr/bin/python3
import time
import mysql.connector
import RPi.GPIO as GPIO # bibliothèque pour utiliser les GPIO
import time # bibliothèque pour gestion du temps
import cgi

GPIO.setmode(GPIO.BOARD) # mode de numérotation des pins
GPIO.setup(24,GPIO.OUT )
GPIO.setup(10,GPIO.OUT )
GPIO.setup(12,GPIO.OUT )
GPIO.setup(7,GPIO.OUT )
GPIO.setup(11,GPIO.OUT )

GPIO.output(10,GPIO.LOW)
GPIO.output(12,GPIO.LOW)
GPIO.output(7,GPIO.HIGH)
GPIO.output(11,GPIO.LOW)
GPIO.output(24,GPIO.HIGH)

la pin 7 ( du board ) ne concerne pas le SPI .
Je mesure la tension des pin soit avec un oscillo soit avec un multimetre .
Les gpio autres que le 7 repondent comme demandé .

Il est difficile de faire plus probant et j’exclus une horreur de manipulation/comprehension (en ce qui vous concerne…). A moins que quelqu’un de plus compétent que moi ne me démente, je vois deux options:

  • votre patte est « tirée vers le bas » par un défaut de câblage
  • votre patte a été bousillée par un court circuit temporaire (certaines sondes de multimètre, entre mes mains, relançaient l’économie mondiale)
    J’espère que j’ai tort…

Merci pour les hypotheses mais aucune n’explique le probleme .

Avez vous pensé à d’autres fora? https://www.raspberrypi.org/forums/ est le forum officiel de RPi: comme vous avez très bien documenté ce qui ne marche pas, et que google traduction fonctionne bien pour du français correct (comme pour de l’azeri correct), que les intervenants ont une formation electronique recente et peuvent être des ingeneiurs de chez RPi, et que, personne dans ce forum ci ou celui là n’est opposé au « cross posting », ça vaut le coup d’essayer avec la partie anglaise (la partie en français a moins d’intervenants, plus à l’aise dans les logiciels ou les transmissions).
Et la solution (si ce n’est pas une suspicion de destruction) serait très utile… pour tout le monde.

OK I posted on raspberrypi.org
merci du conseil

Et vous avez eu deux solutions en https://www.raspberrypi.org/forums/viewtopic.php?f=28&t=287639 (j’ai mis le lien complet, car dans 8 jours, on ne vous retrouvera plus)

l’une jeter votre RPi et en acheter un neuf (celle que je n’osais imaginer), relançant l’économie mondiale.

l’autre regarder si vous n’avez pas activé le bus 1 wire (mange la patte 7)…

effectivement le bus 1 wire est activé (dtoverlay=w1-gpio dans boot/config.txt )! donc la pin 7 est « contrariée »
j’enleve l’activation et regarde les conseqences sur le programme et la pin et vous informe