Impossible d’accéder à mon site web en interne

Bonjour,
Apres avoir suivi le tuto et installé WP sur mon raspberry, tou fonctionne nickel, No-ip etc…depuis l’extérieur tout fonctionne nickel.
Par contre quand j’essaye d’aller sur le site mais depuis mon ordi perso qui est sur le même réseau, (enfin derrière lui un routeur) impossible…des pistes ?
D’avance merci ça fait 3h que je suis dessus…
samys

Salut @samys
Il faut passer par l’extérieur donc faire croire à ton serveur que tu viens de dehors.
La solution ?
Utiliser le navigateur TOR.
++

de memoire il y avait une autre solution…ce qui est bizare c’est que depuis mon telephone portable en wifi ca marche sans probleme, mais depuis mon pc impossible…
Il y avait pas un truc a modifier dans un fichier quelque part ?..

Tu as quel serveur web ?

Apache 2
J’ai suivi ces deux tutos :
https://raspberry-pi.fr/installer-serveur-web-raspberry-lamp/
et
https://raspberry-pi.fr/mettre-en-ligne-serveur-web-raspbian-dydns-port-forwarding/
En gros le raspberry est cablé sur ma box orange, et je me connecte en wifi sur un routeur wifi (cablé lui aussi sur la box)

hello,

en fait tu as fait une sorte de DMZ sans le faire exprès ! ce qui est plutôt une bonne chose au niveau sécurité puisqu’à partir du PC accéssible de l’extérieur on peux moins facilement entrer sur le reste du réseau.

Une des raisons possible c’est que ton adresse ethernet ne fait pas partie du sous réseau des autres postes à l’inverse de la connexion wifi qui elle doit en faire partie.

par exemple ton sous réseau en 192.168.1.0/24 et ton PC ouvert en 192.168.2.0/24 ( le /24 donne le dernier byte de 0 à 255 -192.168.1.1,192.168.1.2, etc.))

DMZ : https://fr.wikipedia.org/wiki/Zone_démilitarisée_(informatique)

Heu…ok… Il y a une solution au problème ? En fait j’aimerais bosser sur le site sur mon ordi chez moi…

Mon ordi est connecté en wifi aussi…

En fait c’ est pas clair pour moi: ton PC « derrière un routeur » il va sur internet ? et il sert a quoi le routeur sur le même réseau ! ça ne serait pas un hub plutôt ?

Passer par Tor comme déjà dit :wink:

ok je vais essayer d’etre plus clair desolé…
Ma box est a un bout de la maison dans la buanderie, le raspberry est branché dessus en ethernet.
Un cable branché en ethernet (sur un autre des 4 ports de la box) arrive a l’autre bout de ma maison et dessus est branché un routeur wifi qui distibut le wifi pour l’ensemble des telephones tablettes etc…et aussi mon pc fixe (et oui je vais sur le net depuis mon pc fixe connecté en wifi sur le routeur (r7000 nergear).
Là ou quelque chose m’echappe c’est que mon tel portable en wifi ou en 4g arrive tres bien a lire le site web sur mon raspberry, mais que de mon ordi ca merdouille, c’est tres lents et je n’ai pas d’image qui s’affiche…
Desolé je suis un peu une quiche pour expliquer sur ce coup là et mes competences en terme de reseau/serveur web sont un peu limitées au cas ou vous n’aurez pas remarqué lol

je sens qu’il y a une histoire de fichier hosts…mais je me souviens plus

le fichier host te permet de faire correspondre une adresse ip avec un nom par exemple dans ton PC :
192.168.1.4 monsite.home

ça permetrait de saisir monsite.home et d’arriver sur l ip 192.168.1.4… tu peux toujours essayé !

source :

youpiiii c’etait bien ça !!!
merci de votre aide les amis :slight_smile: