Gros probleme installation mysql

Bonjour a tous,

J’ai eu des soucis lors de l’installation de mariadb, donc j’ai désinstaller, mais apres plus moyen de reinstaller.

J’ai cette erereur lors de la reinstallation;

        rasp@raspberrypi:/etc $ sudo apt install mariadb-server php-mysql
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'état... Fait      
php-mysql est déjà la version la plus récente (2:7.4+76).
Vous pouvez lancer « apt --fix-broken install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
 libmariadb3 : Dépend: mariadb-common mais ne sera pas installé
 mariadb-client-core-10.5 : Dépend: mariadb-common (>= 1:10.5.15-0+deb11u1) mais ne sera pas installé
 mariadb-server : Dépend: mariadb-server-10.5 (>= 1:10.5.15-0+deb11u1) mais ne sera pas installé
 mariadb-server-core-10.5 : Dépend: mariadb-common (>= 1:10.5.15-0+deb11u1) mais ne sera pas installé
E: Dépendances non satisfaites. Essayez « apt --fix-broken install » sans paquet
   (ou indiquez une solution).

Merci d’avance

Lis ton LOG!!! La réponse est dedans…

As tu fais ton « sudo apt update » ? Après, il te dit qu’il ne peut pas installer le serveur parce que il manque d’autres package obligatoire, le « mariadb-commun », d’habitude j’installe MariaDB simplement avec « sudo apt install mariadb » qui lui va installer tout ce qui est requis. Dans ce cas si, tu force qu’une partie de MariaDB (server), lui il pense que tu veux juste ça, car c’est un sous module de MariaDB (complet).


On the side, si tu veux fixer un bug avec MariaDB, désinstall et réinstall, installer par dessus va rien aidé et même corrompe de manière permanente ton système.

merci de me donner un coup de main levelKro,

Désolé je ne vois pas ou pour le log

le « sudo apt update » j’en ai fait mais peut etre pas en dernier

J’ai essayé mais:

rasp@raspberrypi:/etc $ sudo apt update
Atteint :1 http://archive.raspberrypi.org/debian bullseye InRelease
Atteint :2 http://raspbian.raspberrypi.org/raspbian bullseye InRelease
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'état... Fait      
Tous les paquets sont à jour.
rasp@raspberrypi:/etc $ sudo apt install mariadb
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'état... Fait      
E: Impossible de trouver le paquet mariadb

Bonjour,
Personnellement j’installe mariadb avec commande :

sudo apt install mariadb-server -y

Quelle version de RASPIOS ( 32 ou 64 bits ) car je n’ai pas le même /etc/apt/sources.list

$ cat /etc/apt/sources.list
deb http://deb.debian.org/debian bullseye main contrib non-free
deb http://security.debian.org/debian-security bullseye-security main contrib non-free
deb http://deb.debian.org/debian bullseye-updates main contrib non-free

~ $ uname -a
Linux RASPI-40 5.15.78-v8+ #1599 SMP PREEMPT Fri Nov 11 12:30:19 GMT 2022 aarch64 GNU/Linux

Merci Mik91390,

Pour info:

rasp@raspberrypi:/etc $ sudo apt install mariadb-server -y
Lecture des listes de paquets… Fait
Construction de l’arbre des dépendances… Fait
Lecture des informations d’état… Fait
Vous pouvez lancer « apt --fix-broken install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
libmariadb3 : Dépend: mariadb-common mais ne sera pas installé
mariadb-client-core-10.5 : Dépend: mariadb-common (>= 1:10.5.15-0+deb11u1) mais ne sera pas installé
mariadb-server : Dépend: mariadb-server-10.5 (>= 1:10.5.15-0+deb11u1) mais ne sera pas installé
mariadb-server-core-10.5 : Dépend: mariadb-common (>= 1:10.5.15-0+deb11u1) mais ne sera pas installé
E: Dépendances non satisfaites. Essayez « apt --fix-broken install » sans paquet
(ou indiquez une solution).

Sinon je suis en 32 j’étais à la base avec la 64 mais j’ai eu des soucis avec Anydesk et du coup je suis reparti sur la 32

Le package « mariadb » n’existe pas sous Raspbian ?

Faut dire que j’install pas de SQL sur mes Raspberry, je le fait sur des serveurs et VPS.

ET le log… c’est le log de l’application, ce que tu as posté…

Est-ce que tu as essayé:

bonjour,

Est ce que les paquets nommé on peut les désinstallé et les réinstallé pour corriger les problèmes?

oui je l’avais déjà essayé et voici le résultat:

rasp@raspberrypi:~ $ sudo apt --fix-broken install
Lecture des listes de paquets… Fait
Construction de l’arbre des dépendances… Fait
Lecture des informations d’état… Fait
Correction des dépendances… Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
galera-4 libcgi-fast-perl libcgi-pm-perl libclone-perl
libconfig-inifiles-perl libdbi-perl libencode-locale-perl libfcgi-bin
libfcgi-perl libfcgi0ldbl libhtml-parser-perl libhtml-tagset-perl
libhtml-template-perl libhttp-date-perl libhttp-message-perl libio-html-perl
liblwp-mediatypes-perl libmariadb3 libterm-readkey-perl libtimedate-perl
liburi-perl mariadb-client-10.5 mariadb-client-core-10.5
mariadb-server-core-10.5 socat
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
5 partiellement installés ou enlevés.
Il est nécessaire de prendre 0 o/36,7 ko dans les archives.
Après cette opération, 0 o d’espace disque supplémentaires seront utilisés.
dpkg: des problèmes de dépendances empêchent la configuration de mariadb-server-core-10.5 :
mariadb-server-core-10.5 dépend de mariadb-common (>= 1:10.5.15-0+deb11u1) ; cependant :
Le paquet mariadb-common n’est pas installé.

dpkg: erreur de traitement du paquet mariadb-server-core-10.5 (–configure) :
problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de mariadb-client-
core-10.5 :
mariadb-client-core-10.5 dépend de mariadb-common (>= 1:10.5.15-0+deb11u1) ; ce
pendant :
Le paquet mariadb-common n’est pas installé.

dpkg: erreur de traitement du paquet mariadb-client-core-10.5 (–configure) :
problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de libmariadb3:arm
hf :
libmariadb3:armhf dépend de mariadb-common ; cependant :
Le paquet mariadb-common n’est pas installé.

dpkg: erreur de traitement du paquet libmariadb3:armhf (–configure) :
problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de mariadb-client-
10.5 :
mariadb-client-10.5 dépend de mariadb-client-core-10.5 (>= 1:10.5.15-0+deb11u1)
; cependant :
Le paquet mariadb-client-core-10.5 n’est pas encore configuré.

dpkg: erreur de traitement du paquet mariadb-client-10.5 (–configure) :
problèmes de dépendances - laissé non configuré
Des erreurs ont été rencontrées pendant l’exécution :
mariadb-server-core-10.5
mariadb-client-core-10.5
libmariadb3:armhf
mariadb-client-10.5
E: Sub-process /usr/bin/dpkg returned an error code (1)

L’installation est vraiment planté. Moi j’arrêterais simplement de me battre avec les erreurs et je recommencerais de zéro.

  • Si tu as des données, consulte la documentation de MariaDB pour sauvegarder les bases de données (sauvegarder les fichiers de données brute) vu que ttu semble pas en mesure de faire une backup traditionnel
  • Désinstalle par Purge de MariaDB; la désinstalle garde certains fichiers, la purge fera en sorte de tout supprimer les traces de MariaDB dans le système sudo apt purge <package_name>
  • Reboot
  • Update APT et réinstall MariaDB

As tu ajouté Repositories dans le Sources.list ? ¨Ca peut causer des erreurs si la version d’un repositories rentre en conflit avec un autre. Dans ce cas la, faut forcer l’installation via qu’un seul Repository choisi. Mais avant d’en arriver la, je crois le mieux est d’essayer ce que je viens de poster.