Erreur d'installation avec apt

Bonjour,
Je n’arrive plus à télécharger php ou n’importe quels paquets avec apt ça me mais un message d’erreur dpkg et d’autres erreurs.
Voici l’erreur :

pi@raspberrypi:~ $ sudo apt-get install php-fpm
Lecture des listes de paquets… Fait
Construction de l’arbre des dépendances
Lecture des informations d’état… Fait
Les paquets supplémentaires suivants seront installés :
php-common php8.0-cli php8.0-common php8.0-fpm php8.0-opcache
php8.0-readline
Paquets suggérés :
php-pear
Les NOUVEAUX paquets suivants seront installés :
php-common php-fpm php8.0-cli php8.0-common php8.0-fpm php8.0-opcache
php8.0-readline
0 mis à jour, 7 nouvellement installés, 0 à enlever et 1 non mis à jour.
Il est nécessaire de prendre 0 o/3 266 ko dans les archives.
Après cette opération, 14,0 Mo d’espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] o
Sélection du paquet php-common précédemment désélectionné.
dpkg: avertissement: le fichier contenant la liste des fichiers du paquet « hplip » étant manquant, il est considéré qu’aucun fichier du paquet n’est actuellement installé
dpkg: avertissement: le fichier contenant la liste des fichiers du paquet « mailutils » étant manquant, il est considéré qu’aucun fichier du paquet n’est actuellement installé
dpkg: avertissement: le fichier contenant la liste des fichiers du paquet « python3-renderpm:armhf » étant manquant, il est considéré qu’aucun fichier du paquet n’est actuellement installé
dpkg: avertissement: le fichier contenant la liste des fichiers du paquet « libgc1c2:armhf » étant manquant, il est considéré qu’aucun fichier du paquet n’est actuellement installé
dpkg: avertissement: le fichier contenant la liste des fichiers du paquet « colord » étant manquant, il est considéré qu’aucun fichier du paquet n’est actuellement installé
dpkg: avertissement: le fichier contenant la liste des fichiers du paquet « libgusb2:armhf » étant manquant, il est considéré qu’aucun fichier du paquet n’est actuellement installé
dpkg: avertissement: le fichier contenant la liste des fichiers du paquet « libkyotocabinet16v5:armhf » étant manquant, il est considéré qu’aucun fichier du paquet n’est actuellement installé
dpkg: avertissement: le fichier contenant la liste des fichiers du paquet « hplip-data » étant manquant, il est considéré qu’aucun fichier du paquet n’est actuellement installé
dpkg: avertissement: le fichier contenant la liste des fichiers du paquet « libgsasl7 » étant manquant, il est considéré qu’aucun fichier du paquet n’est actuellement installé
dpkg: avertissement: le fichier contenant la liste des fichiers du paquet « libcolorhug2:armhf » étant manquant, il est considéré qu’aucun fichier du paquet n’est actuellement installé
dpkg: avertissement: le fichier contenant la liste des fichiers du paquet « libsane:armhf » étant manquant, il est considéré qu’aucun fichier du paquet n’est actuellement installé
dpkg: avertissement: le fichier contenant la liste des fichiers du paquet « printer-driver-postscript-hp » étant manquant, il est considéré qu’aucun fichier du paquet n’est actuellement installé
dpkg: avertissement: le fichier contenant la liste des fichiers du paquet « colord-data » étant manquant, il est considéré qu’aucun fichier du paquet n’est actuellement installé
dpkg: avertissement: le fichier contenant la liste des fichiers du paquet « libsnmp30:armhf » étant manquant, il est considéré qu’aucun fichier du paquet n’est actuellement installé
dpkg: avertissement: le fichier contenant la liste des fichiers du paquet « libntlm0:armhf » étant manquant, il est considéré qu’aucun fichier du paquet n’est actuellement installé
dpkg: avertissement: le fichier contenant la liste des fichiers du paquet « python3-pexpect » étant manquant, il est considéré qu’aucun fichier du paquet n’est actuellement installé
dpkg: avertissement: le fichier contenant la liste des fichiers du paquet « python3-reportlab-accel:armhf » étant manquant, il est considéré qu’aucun fichier du paquet n’est actuellement installé
dpkg: avertissement: le fichier contenant la liste des fichiers du paquet « mailutils-common » étant manquant, il est considéré qu’aucun fichier du paquet n’est actuellement installé
dpkg: avertissement: le fichier contenant la liste des fichiers du paquet « libmariadb3:armhf » étant manquant, il est considéré qu’aucun fichier du paquet n’est actuellement installé
dpkg: avertissement: le fichier contenant la liste des fichiers du paquet « python3-reportlab » étant manquant, il est considéré qu’aucun fichier du paquet n’est actuellement installé
dpkg: avertissement: le fichier contenant la liste des fichiers du paquet « printer-driver-hpcups » étant manquant, il est considéré qu’aucun fichier du paquet n’est actuellement installé
dpkg: avertissement: le fichier contenant la liste des fichiers du paquet « sane-utils » étant manquant, il est considéré qu’aucun fichier du paquet n’est actuellement installé
dpkg: avertissement: le fichier contenant la liste des fichiers du paquet « libieee1284-3:armhf » étant manquant, il est considéré qu’aucun fichier du paquet n’est actuellement installé
dpkg: avertissement: le fichier contenant la liste des fichiers du paquet « libhpmud0:armhf » étant manquant, il est considéré qu’aucun fichier du paquet n’est actuellement installé
dpkg: avertissement: le fichier contenant la liste des fichiers du paquet « guile-2.2-libs:armhf » étant manquant, il est considéré qu’aucun fichier du paquet n’est actuellement installé
dpkg: avertissement: le fichier contenant la liste des fichiers du paquet « libsane-hpaio:armhf » étant manquant, il est considéré qu’aucun fichier du paquet n’est actuellement installé
dpkg: avertissement: le fichier contenant la liste des fichiers du paquet « libmailutils5:armhf » étant manquant, il est considéré qu’aucun fichier du paquet n’est actuellement installé
dpkg: avertissement: le fichier contenant la liste des fichiers du paquet « python3-ptyprocess » étant manquant, il est considéré qu’aucun fichier du paquet n’est actuellement installé
(Lecture de la base de données… 102023 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de …/0-php-common_2%3a82+0~20210313.35+debian10~1.gbpa8195f_all.deb …
Dépaquetage de php-common (2:82+0~20210313.35+debian10~1.gbpa8195f) …
Sélection du paquet php8.0-common précédemment désélectionné.
Préparation du dépaquetage de …/1-php8.0-common_8.0.3-1+0~20210305.17+debian10~1.gbp899a74_armhf.deb …
Dépaquetage de php8.0-common (8.0.3-1+0~20210305.17+debian10~1.gbp899a74) …
Sélection du paquet php8.0-opcache précédemment désélectionné.
Préparation du dépaquetage de …/2-php8.0-opcache_8.0.3-1+0~20210305.17+debian10~1.gbp899a74_armhf.deb …
Dépaquetage de php8.0-opcache (8.0.3-1+0~20210305.17+debian10~1.gbp899a74) …
Sélection du paquet php8.0-readline précédemment désélectionné.
Préparation du dépaquetage de …/3-php8.0-readline_8.0.3-1+0~20210305.17+debian10~1.gbp899a74_armhf.deb …
Dépaquetage de php8.0-readline (8.0.3-1+0~20210305.17+debian10~1.gbp899a74) …
Sélection du paquet php8.0-cli précédemment désélectionné.
Préparation du dépaquetage de …/4-php8.0-cli_8.0.3-1+0~20210305.17+debian10~1.gbp899a74_armhf.deb …
Dépaquetage de php8.0-cli (8.0.3-1+0~20210305.17+debian10~1.gbp899a74) …
Sélection du paquet php8.0-fpm précédemment désélectionné.
Préparation du dépaquetage de …/5-php8.0-fpm_8.0.3-1+0~20210305.17+debian10~1.gbp899a74_armhf.deb …
Dépaquetage de php8.0-fpm (8.0.3-1+0~20210305.17+debian10~1.gbp899a74) …
Sélection du paquet php-fpm précédemment désélectionné.
Préparation du dépaquetage de …/6-php-fpm_2%3a8.0+82+0~20210313.35+debian10~1.gbpa8195f_all.deb …
Dépaquetage de php-fpm (2:8.0+82+0~20210313.35+debian10~1.gbpa8195f) …
Paramétrage de php-common (2:82+0~20210313.35+debian10~1.gbpa8195f) …
Created symlink /etc/systemd/system/timers.target.wants/phpsessionclean.timer → /lib/systemd/system/phpsessionclean.timer.
Paramétrage de php8.0-common (8.0.3-1+0~20210305.17+debian10~1.gbp899a74) …

Creating config file /etc/php/8.0/mods-available/calendar.ini with new version

Creating config file /etc/php/8.0/mods-available/ctype.ini with new version

Creating config file /etc/php/8.0/mods-available/exif.ini with new version

Creating config file /etc/php/8.0/mods-available/fileinfo.ini with new version

Creating config file /etc/php/8.0/mods-available/ffi.ini with new version

Creating config file /etc/php/8.0/mods-available/ftp.ini with new version

Creating config file /etc/php/8.0/mods-available/gettext.ini with new version

Creating config file /etc/php/8.0/mods-available/iconv.ini with new version

Creating config file /etc/php/8.0/mods-available/pdo.ini with new version

Creating config file /etc/php/8.0/mods-available/phar.ini with new version

Creating config file /etc/php/8.0/mods-available/posix.ini with new version

Creating config file /etc/php/8.0/mods-available/shmop.ini with new version

Creating config file /etc/php/8.0/mods-available/sockets.ini with new version

Creating config file /etc/php/8.0/mods-available/sysvmsg.ini with new version

Creating config file /etc/php/8.0/mods-available/sysvsem.ini with new version

Creating config file /etc/php/8.0/mods-available/sysvshm.ini with new version

Creating config file /etc/php/8.0/mods-available/tokenizer.ini with new version
Paramétrage de php8.0-readline (8.0.3-1+0~20210305.17+debian10~1.gbp899a74) …

Creating config file /etc/php/8.0/mods-available/readline.ini with new version
Paramétrage de php8.0-opcache (8.0.3-1+0~20210305.17+debian10~1.gbp899a74) …

Creating config file /etc/php/8.0/mods-available/opcache.ini with new version
Paramétrage de php8.0-cli (8.0.3-1+0~20210305.17+debian10~1.gbp899a74) …
update-alternatives: utilisation de « /usr/bin/php8.0 » pour fournir « /usr/bin/php » (php) en mode automatique
update-alternatives: utilisation de « /usr/bin/phar8.0 » pour fournir « /usr/bin/phar » (phar) en mode automatique
update-alternatives: utilisation de « /usr/bin/phar.phar8.0 » pour fournir « /usr/bin/phar.phar » (phar.phar) en mode automatique

Creating config file /etc/php/8.0/cli/php.ini with new version
Paramétrage de php8.0-fpm (8.0.3-1+0~20210305.17+debian10~1.gbp899a74) …

Creating config file /etc/php/8.0/fpm/php.ini with new version
Created symlink /etc/systemd/system/multi-user.target.wants/php8.0-fpm.service → /lib/systemd/system/php8.0-fpm.service.
Detected unsafe path transition / → /run during canonicalization of /run.
Job for php8.0-fpm.service failed because the control process exited with error code.
See « systemctl status php8.0-fpm.service » and « journalctl -xe » for details.
invoke-rc.d: initscript php8.0-fpm, action « start » failed.
● php8.0-fpm.service - The PHP 8.0 FastCGI Process Manager
Loaded: loaded (/lib/systemd/system/php8.0-fpm.service; enabled; vendor preset: enabled)
Active: failed (Result: exit-code) since Sun 2021-04-04 22:52:33 CEST; 25ms ago
Docs: man:php-fpm8.0(8)
Process: 29917 ExecStart=/usr/sbin/php-fpm8.0 --nodaemonize --fpm-config /etc/php/8.0/fpm/php-fpm.conf (code=exited, status=78)
Process: 29918 ExecStopPost=/usr/lib/php/php-fpm-socket-helper remove /run/php/php-fpm.sock /etc/php/8.0/fpm/pool.d/www.conf 80 (code=exited, status=0/SUCCESS)
Main PID: 29917 (code=exited, status=78)

avril 04 22:52:33 raspberrypi systemd[1]: Starting The PHP 8.0 FastCGI Process Manager…
avril 04 22:52:33 raspberrypi php-fpm8.0[29917]: [04-Apr-2021 22:52:33] ERROR: unable to bind listening socket for address ‹ /run/php/php8.0-fpm.sock ›: No such file or directory (2)
avril 04 22:52:33 raspberrypi php-fpm8.0[29917]: [04-Apr-2021 22:52:33] ERROR: FPM initialization failed
avril 04 22:52:33 raspberrypi systemd[1]: php8.0-fpm.service: Main process exited, code=exited, status=78/CONFIG
avril 04 22:52:33 raspberrypi systemd[1]: php8.0-fpm.service: Failed with result ‹ exit-code ›.
avril 04 22:52:33 raspberrypi systemd[1]: Failed to start The PHP 8.0 FastCGI Process Manager.
dpkg: erreur de traitement du paquet php8.0-fpm (–configure) :
installed php8.0-fpm package post-installation script subprocess returned error exit status 1
dpkg: des problèmes de dépendances empêchent la configuration de php-fpm :
php-fpm dépend de php8.0-fpm ; cependant :
Le paquet php8.0-fpm n’est pas encore configuré.

dpkg: erreur de traitement du paquet php-fpm (–configure) :
problèmes de dépendances - laissé non configuré
Traitement des actions différées (« triggers ») pour man-db (2.8.5-2) …
Traitement des actions différées (« triggers ») pour systemd (241-7~deb10u6+rpi1) …
Traitement des actions différées (« triggers ») pour php8.0-cli (8.0.3-1+0~20210305.17+debian10~1.gbp899a74) …
Des erreurs ont été rencontrées pendant l’exécution :
php8.0-fpm
php-fpm
E: Sub-process /usr/bin/dpkg returned an error code (1)

Voilà je cherche depuis plusieurs heures sans que ça marche. Si quelqu’un a la solution ça m’aiderait beaucoup.

Avant d’installer, fait
sudo apt-get update
Ceci va actualiser la liste des versions et des noms de package. Toujours le faire avant d’installer des trucs :stuck_out_tongue:

hello,

essaie sudo apt-get install php8.0-fpm
l’idée étant de faire coïncider la version de php (8.0) avec celle de php-fpm (8.0)
si tu fais un :
sudo apt-cache policy php-fpm
tu dois pas avoir la même version qu’avec un :
sudo apt-cache policy php8.0-fpm

1 J'aime

Bonjour merci pour vos réponses,
Pour sudo apt-get update je l’avait fait c’est juste que j’avais oublié de le rajouter dans mon message.
Pour sudo apt-get install php8.0-fpm ça me renvoit la même erreur.
Pour sudo apt-cache policy php-fpm :
pi@raspberrypi:~ $ sudo apt-cache policy php-fpm php-fpm: Installé : (aucun) Candidat : 2:8.0+82+0~20210313.35+debian10~1.gbpa8195f Table de version : 2:8.0+82+0~20210313.35+debian10~1.gbpa8195f 500 500 https://packages.sury.org/php buster/main armhf Packages 2:7.3+69 500 500 http://raspbian.raspberrypi.org/raspbian buster/main armhf Packages

Pour sudo apt-cache policy php8.0-fpm :
pi@raspberrypi:~ $ sudo apt-cache policy php8.0-fpm php8.0-fpm: Installé : 8.0.3-1+0~20210305.17+debian10~1.gbp899a74 Candidat : 8.0.3-1+0~20210305.17+debian10~1.gbp899a74 Table de version : *** 8.0.3-1+0~20210305.17+debian10~1.gbp899a74 500 500 https://packages.sury.org/php buster/main armhf Packages 100 /var/lib/dpkg/status

Mais je pense que c’est un problème avec dpkg comme je n’arrive pas à installer n’importe quels paquets avec Apt.

J’ai trouvé ces liens;

Merci je vais les essayer.
Je dirais après si ça marche ou pas.

Je te dirais de voir avec d’autres pack, si DPKG bug. Après, tente d’effacer tous ce qui touche ton PHP, et réinstalle à neuf, après tous ça, j’opterais pour un reset de la carte SD.

Sur google, tu as de vieux poste avec ce genre d’erreur, l’un date de 2014 (7 ans), je poste pas les liens vu que c’est (trop) vieux et que la solution est surement changé. Mais il en ressort que le problème est causé par le passage de apt-get upgrade, ou un apt-get dist-upgrade. Cependant, dans la documentation du Raspberry Pi il le dise bien, la upgrade et dist-upgrade n’est a utiliser que pour mettre à jour le Firmware et qui est absolument requis, il passe des versions non stable de certains apps via ce canal, etc…

Mais je me demande en écrivant; pourquoi avoir PHP 8 ? Ont vient à peine de rendre le 7 stable et le minimum requis balotte encore entre 5.4,5.6,7.0 et 7.3, person je passerais à une version inférieur, qui est plus stable et commun.

Merci pour toutes les réponses au final j’ai eu d’autres erreurs et je pouvais plus utiliser Apt donc j’ai réinstaller raspbian.