Ecran noir apres boot rasbian

Bonjour a tous,
j’ai en ma possession une raspberry pi 3 model B que j’utilise frequemment.
Je l’utilise pour faire de la robotique et de la programmation pour des projets.
Donc j’ai decidé de tester la video surveillance, j’ai installé MOTION reglé tout les parametres et celui ci marchait. Ma derniere utilisation date de ce wk ou j’ai fait une demo a des invités.
Malheureusement je pense que j’ai zappé d’eteindre ma rasp qui a du rester 2 -3 heure branchée et diffusant la video (juste sur ma box donc possible d’acces grace a son ip et navigateur).
Aujourd’hui en la rallumant tout se passe correctement, je suis celui ci grace a un ecran en HDMI, sauf que apres le boot de rasbian ecran noir avec juste un underscore. Je me suis dis que cela venait de la raspberry donc j’ai echangée avec une auter. Rien a faire meme probleme. Changé plusieurs plusieurs fois d’alimentation (j’utilise celle fournie avec) mais rien.
Je precise que les deux led clignotent verte et rouge, que le boot s’est chargé ET que je peux me connecter avec VNC mais que l’ecran est aussi noir…
Si quelqu’un pouvait m’aiguiller
Merci d’avacne

hello,

peut être que ta sd est full si tu peux la monter ds un autre PC et vérifier l’espace libre …

Hi
j’ai verifié et niveau espace je suis ok et j’arrive bien a lire la carte.
Apres il y a des parties que je ne peux pas lire.

Je vais essayer de les lire et voir pour manage les fichier dedans avec linux reader je dirai si j’ai reussi a faire d’autres choses

  1. vérifier la carte sd partition /rootfs
    si tu peux la monter ds un autre linux avec une clé usb reader essaye :
umount /dev/sdX
sudo fsck.ext4 -cDfty -C 0 /dev/sdX

ou /dev/sdX est le périphérique qui apparaît quand tu montes ta sd
(mount avant le branchement, mount après la différence c’est ta sd )

  1. l’autre hypothèse c’est que t’as un problème sur le serveur X ( l’affichage graphique du bureau )
    sudo systemctl restart lightdm
    te relancerait le service
    sudo systemctl status lightdm
    te dirait dans quel état il est.
    un coup d’œil aux logs de ligthdm ( sudo ls -l /var/log/lightdm/ puis sudo less /var/log/lightdm/???.log )
    pourra t aider si le probleme vient de là !

Bonjour Hyro,

tu as essaye de te connecter en SSH ?

A +
JC

sinon tu peux essayer ça :

3. Enable SSH on a headless Raspberry Pi (add file to SD card on another machine)

For headless setup, SSH can be enabled by placing a file named ssh , without any extension, onto the boot partition of the SD card from another computer. When the Pi boots, it looks for the ssh file. If it is found, SSH is enabled and the file is deleted. The content of the file does not matter; it could contain text, or nothing at all.

If you have loaded Raspbian onto a blank SD card, you will have two partitions. The first one, which is the smaller one, is the boot partition. Place the file into this one.

en espérant que ça marche sur pi3 …

source : https://www.raspberrypi.org/documentation/remote-access/ssh/

Bonsoir Hyro,

Apparemment vous pouvez communiquer avec VNC, donc SSH ne devrait pas poser de problèmes.
De plus, votre écran n’est pas tout à fait noir, puisqu’il affiche un _ (j’imagine clignotant) :thinking:

Il est peut probable que ce soit un problème de surchauffe, puisque la partie vidéo est intégrée dans le même processeur.
Au fait, lors du boot, les raspberry-pilogo raspberry-pilogo raspberry-pilogo raspberry-pilogo s’affichent ?

@+

Bonjour Stef-k,

Je viens de faire une mise à jour de mon raspbian sur mon pi4 et après avoir redémarrer, j’ai obtenu un écran noir avec un tiret blanc qui clignote. Lorsque le Pi4 redémarre j’ai effectivement au début les 4 logos qui s’affichent et ensuite j’obtiens mon écran noir avec le tiret blanc qui clignote. Je ne peux plus utiliser mon clavier ni de souris pour avoir un accès. Je vous remercie de votre aide.