Disque dur de 4 To sur Raspberry pi 4

Bonjour,

Depuis des années j’ai une batterie de 4 disques externes USB (Western Digital MyBook), 2 de 1 To et 2 de 500 Go. Ils sont alimentés de manière autonome, connectés à un hub USB, qui était lui-même connecté à un serveur Windows. Cela me servait pour mes sauvegardes. Le serveur me posant de plus en plus de problèmes, j’ai décidé de le remplacer par un NAS sur Raspberry.

Après quelques déboires au niveau des partages sur Raspbian Buster, dont j’ai parlé sur ce forum, j’ai donc installé Raspbian Buster Lite et OpenMediaVault sur un Raspberry pi 4. J’ai connecté les disques sur le Raspberry, et ça fonctionne.

Disposant d’un disque interne 3,5" de 2 To, j’ai remplacé l’un des 500 Go par celui-ci et ça fonctionne.

Le loi de Murphy étant ce qu’elle est, le second 500 Go en a profité pour rendre l’âme. J’ai donc acheté un autre disque dur pour le remplacer, un 4 To tant qu’à faire. J’ai remplacé le 500 Go dans le boitier, et je l’ai connecté à l’ensemble, voici ce que j’obtiens :

J’ai d’abord pensé que le disque avait un problème. Je l’ai démonté et connecté à l’aide d’un dock sur mon PC et il est bien vu en tant que 4 To.

J’ai pensé que ça venait du boitier SATA-USB. Je l’ai remonté dedans et connecté en USB au PC. RAS.

Je l’ai reconnecté à OpenMediaVault, il ne voit toujours que 1,64 To. J’ai mis une carte SD avec Raspbian Buster complet (interface graphique) sur le Raspberry, et là il ne le voit même pas. Il voir bien les autres si je les connecte, mais pas le 4 To.

Comprends pas :cry:

Si quelqu’un connait une astuce. Merci d’avance.

Désolé, l’affichage de l’image ne fonctionne pas, elle est là :

Edit : Pas doué pour les liens ici, désolé. Mais si vous cliquez sur le bidule, vous pouvez l’afficher :slight_smile:

hello,

tu dois utilisé fat32 qui doit être limité a 2To par windoz ( suivant ce que tu utilises comme utilitaire pour lire la capacité le résultat peut être différent )
tu peux utiliser NTFS à la place. ( ds raspbian c’est installé d’origine) par contre il va falloir changer le type ds /etc/fstab en ntfs .

Non, il est en NTFS.

Et si tu le formate en ext4?

alors ça doit être ta table de partition en MBR qui bloque doit falloir utiliser GPT …

source : https://fr.wikipedia.org/wiki/Master_boot_record#Avenir_du_MBR

Re-

Bon, en fait je suis persuadé que c’est l’interface USB du boitier MyBook qui pose problème. En effet :

(Je rappelle que je l’avais formaté en NTFS à l’aide de mon dock SATA.)

  1. J’ai reconnecté le disque en USB sur le PC, il apparait bien en 4 To.
  2. J’ai détruit la partition.
  3. J’ai repartitionné sans formater, et il apparait en 1,7 To.
  4. J’ai redétruit la partition et repartionné en formatant en NTFS, toujours 1,7 To.
  5. J’ai démonté le disque du boitier et je l’ai connecté au dock SATA.
  6. Il apparait en 4 To, idem en le partionnant, idem en le formatant.

Comme mon disque interne de données principal est un 2 To, je vais le remplacer par le 4 To et mettre le 2 To dans le boitier, pour l’autre ça a bien fonctionné. Et 6 To pour le NAS, ça suffira.

Merci. @+