Deux routeur et nat?

Bonjour tout le monde
j’ai un Raspberry Pi 4 4g monté en Nas et plex, tout marche nickel en LAN , je voudrais avoir accès aux fichier de l’extérieur, j’ai déjà configurer le ddns dans le routeur reste le NAT , le problème C que j’ai deux routeurs , le premier reçoit la fibre c’est un ZTE F 660 son adresse ip est 192.168.0.2 et il est branché en LAN avec un routeur Linksys AC1900 et ce dernier qui est connecté en LAN a mon Raspberry son ip est 192.168.1.1
ma question ou dois je configurer la redirection des ports pour avoir acces a mon nas dans le premier ou le deuxième routeur ? une deuxième chose je ne sais pas quoi mettre dans wan port ?
merci

hello,

  1. obligatoirement sur le premier. si les postes derrière le deuxième n’accèdent pas « librement » au web il faudra aussi rajouter une règle
  2. soit le wan port ( en fait le port sur lequel l’extérieur accède a ton réseau ) qui sera utiliser sur le Rpi soit sur un au choix ( en général entre 1025 et 6553?) le port interne sera celui utilisé par le Rpi.

on est d’accord qu’ouvrir son réseau local au monde entier représente des risques donc oblige a des « bonnes pratiques » ( voir a utiliser un vpn ) et que pour le NAT, il faut que ton Rpi ait toujours la mème adresse (statique ou forcé par le dhcp)

sources:
https://www.raspberrypi.org/documentation/configuration/security.md

merci pour l’aide
ca marche toujours pas ! avec filezilla quand je met l’ip local ca marche, mais quand je met l’adresse ddns ca me met ce message :FATAL ERROR: Network error: Connection refused
Erreur : Impossible d’établir une connexion au serveur.

j’ai mis sur le premier routeur
wan port :80
lan port :22

En gros voicic e que tu dois faire

[Router1] -> forward du port voulu -> [Router2] -> forward du port voulu -> Raspberry

Et commentaire en passant, c’est bizarre de forwarder le port 80 (web) vers le port 22 (ssh), es-tu sur de ce que tentes de faire?

merci encore pour votre aide, mais je galère toujours !
j’ai configuré le routeur 1 comme ceci :
protocol TCP and UDP
wan port 80
ip LAN ( 192.168.1.113) IP local de mon Raspberry
Lan port 22
et ce que je dois faire la meme chose dan s le routeur 2 ?

pour le Wan j’ai mis 80 en fait parceque je ne sais pas quoi faire d’autre ?

j’ai essayé ca aussi sur les deux captures ! et ca marche toujours pas !


question : sur quel port et avec quel client ( le programme qui te sert à accéder au NAS ) utilises tu ?

Il y a apparemment plusieurs possibilités :
. soit par ftp
. soit par http(s) pour plex sur le port 32400
. soit par http encapsulé dans ssh ( port 22 sur le Rpi )
. soit par un vpn

la avec ton paramétrage tu attends le port 80 ( http) en entrée ( wan port ) et tu le rediriges vers le port 22 ( ssh ) …

si tu ne connis pas le port utilisé par le nas ( plex?) tu peux faire dans une console un : netstat -tan
. avec le nas éteint
. puis apres avoir noté les ports utilisé avec le nas démarré

une doc ZTE pas vraiment pour le même routeur mais certaines des fonctionnalité doivent être sensiblement les mêmes …
https://www.alsatis.com/sites/default/files/guides/utilisation/Guide%20d'utilisation%20box%20ZTE%20ZXHN%20H298N.pdf

Si jamais je te conseille de jeter un oeil à https://tailscale.com/
En gros c’est un réseau VPN meshé auto-géré.
Donc sur, facile à mettre en place.

Si tu veux « juste » ouvrir ton NAS et PLEX, il te faut déterminer quels ports doivent être accessible de l’extérieur, et bien sur y sécuriser un minimum (surtout que se sont des ports connus généralement donc cible des hackeurs « opportunistes » qui scannent le web en permanence.

j’utilise filezilla en ftp port SSH 22 pour le nas

en local tout est ok. mais de l’extérieur je met l’adresse ddns (qui est a jour je vérifie toujour ) pas moyen d’y acceder !
je galère pour le port forwading avec deux routeurs !

si tu utilises ftp sous ssh par défaut il doit utilisé le port 22
donc si tu ne modifies pas le port 22 dans l’onglet général zone hôte de filezilla
avec le wan port a 22 et le local a 22 aussi ça devrait le faire !
( et apparemment en re-regardant tes images jointes c’est ce que tu as fait …)

si ça bloque encore, tu peux essayer d’utiliser le mode passif (a modifier sur filezilla) ,

la démarche la plus simple serait de mettre ton Rpi derrière le premier routeur voir si ça fonctionne et après le remettre derrière le second pour voir se qui se passe …

je viens de mettre la Rpi deriere le premier routeur ZTE F660 en redirigeant le Port 22 a l’adresse ip de la Rpi ( donc un seul routeur ) et pourtant filezilla n;arrive pas a se connecter a la Rpi de l’exterieur ! pourtant aucun souci via l’adresse ip local ! je ne trouve pas le firwall dans le zte !

as tu essayé les différentes possibilités de protocole et de chiffrement quee propose filezilla.
tu dois pouvoir de l’exterieur de ton réseau utiliser telnet de la forme :
telnet <adresse externe du routeur> 22

normalement si ça passe il t"affiche un message du service du Rpi là tu aurais un problème avec le ftp ( protocole, chiffrement … ) ( essaye d’abord en local tu verras le bon message a attendre )
si ça bloque c’est le routeur ( le nat ou le firewall )

pour le firewall du routeur logiquement la règle NAT doit permettre le passage de la connexion en rajoutant une ligne dans le firewall donc si la règle de NAT est correcte le firewall ne doit pas être un problème …