Débutant qui a besoin d'aide

Bonjour,
Je suis débutant sur linux et j’ai un Raspberry Pi 4 flambant neuf avec :

PRETTY_NAME=« Raspbian GNU/Linux 11 (bullseye) »
NAME=« Raspbian GNU/Linux »
VERSION_ID=« 11 »
VERSION=« 11 (bullseye) »
VERSION_CODENAME=bullseye
ID=raspbian
ID_LIKE=debian

sur carte SD.
Aujourd’hui j’ai essayé d’installer InfluxDB et Grafana en suivant des instructions sur des blogs et je suis coincé avec ça :

root@raspberrypi:/home/loll# sudo apt update
Atteint :1 htps://repos.influxdata.com/debian stable InRelease
*Atteint :2 htps://repos.influxdata.com/debian stretch InRelease *
*Atteint :3 htp://archive.raspberrypi.org/debian bullseye InRelease *
*Atteint :4 htp://raspbian.raspberrypi.org/raspbian bullseye InRelease *
*Ign :5 htps://dl.bintray.com/fg2it/deb stretch InRelease *
Err :6 htps://dl.bintray.com/fg2it/deb stretch Release

  • 404 Not Found [IP : 18.214.194.113 443]*
    Err :4 htp://raspbian.raspberrypi.org/raspbian bullseye InRelease
  • Les signatures suivantes n’ont pas pu être vérifiées car la clé publique n’est pas disponible : NO_PUBKEY 9165938D90FDDD2E*
    Lecture des listes de paquets… Fait
    E: Le dépôt htps://dl.bintray.com/fg2it/deb stretch Release n’a pas de fichier Release.
    N: Les mises à jour depuis un tel dépôt ne peuvent s’effectuer de manière sécurisée, et sont donc désactivées par défaut.
    N: Voir les pages de manuel d’apt-secure(8) pour la création des dépôts et les détails de configuration d’un utilisateur.
    W: Une erreur s’est produite lors du contrôle de la signature. Le dépôt n’est pas mis à jour et les fichiers d’index précédents seront utilisés. Erreur de GPG : htp://raspbian.raspberrypi.org/raspbian bullseye InRelease : Les signatures suivantes n’ont pas pu être vérifiées car la clé publique n’est pas disponible : NO_PUBKEY 9165938D90FDDD2E

Quelqu’un aurait’il une solution et l’amabilité de m’en faire part ?
NB : j’ai volontairement oter un « t » à chaque « http » pour qu’ils ne soient pas transformés en lien…

La solution est de passer le texte en syntaxe de code. Tu as un bouton dans l’éditeur pour ça.

Ton problème est au niveau de ta commande sudo apt update, l’un de t’es lien de source rentre des erreurs;

  1. La clé publique n’est pas disponible pour l’un des liens, pas possible de vérifier.
  2. Certains liens des sources ne possède pas de version du package pour le OS donné.
  3. Vu que la clé n’a pas été validé, les index des fichiers n’a pas été mis à jours.

En regardant les source de départ, et les erreurs, j’en conclus que tu as ajouté des sources, l’étape d’ajout de la clé publique semble alors avoir été oublié. Il faudrait consulter le site ou tu as été informé, ou sinon, en espérant être chanceux, le site qui fournis les package, pour savoir comment ajouter la clé.


et

Sont pour de vieilles version « stretch ».

Version Codename Debian release date RPI OS release date
9 Stretch June 2017 August 2017
10 Buster July 2019 July 2019
11 Bullseye August 2021 November 2021
12 Bookworm June 2023 Expected in 2023
13 Trixie Expected in 2025

Alors le guide que tu semble suivre est pour une très vieilles version de Raspbian et tu risque de rencontrer et générer des problèmes, comme la, avec tes sources pour Aptitude.

Merci levelKro,
J’ai fait quelques tentatives et terminé par une clean install…