Conneixon SSH Impossible

Bonjour à tous,

J’ai fais l’acquisition d’un pi Zero WH.
J’ai tenté d’installer raspbian lite et de me connecter en SSH dessus et aucun problème.
Maintenant j’ai changé de carte SD (car elle n’étais pas assez grosse) et quand j’essaie de me login il ne me trouve pas l’host. La connexion wifi se fais bien car sur mon interface box je le vois se connecter quand je le branche au bout de quelques temps.
J’ai tenté de réinstaller l’os mais rien ne fais. J’ai egalement retiré l’attribution d’IP fixe mais toujours rien…
Je suis à bout cette fois !

Merci à tous pour votre aide

activer le SSH: met un fichier « ssh » sans extension sur la carte SD, dossier « /boot ». Car j’imagine tu as refait avec le Raspberry Imager (ou semblable) ta nouvelle carte SD.

Sinon en ligne de commande directement sur le Pi, fait « sudo systemctl start sshd » (ou ssh si le module n’est pas trouvé, je me mélange des fois entre les noms CentOS et Debian :P)

Vérifie aussi le IP

Salut !

Oui oui j’ai déjà mis le fichier SSH…
Et je n’ai pas accès directement car je ne peux pas brancher de clavier ou de souris (c’est le pi zéro pas de ports usb, et pas d’adaptateur)

Alors il ne reste plus qu’a vérifier l’adresse IP.

Quand je me rend sur mon panel box, je vois le rasp qui apparaît et l’adresse est bien celle que j’utilise…

Salut,
Si tu as refait ta carte SD, je pense que la connexion ssh va poser problème puisqu’une ligne concernant cette IP existe déjà dans « known_hosts ».
Je n’utilise que Linux, mais ça doit être pareil sous Windows.
Sous Linux, il me faut éditer /home/nabla/.ssh/known_hosts pour « libérer » l’IP.

Je te conseille aussi d’essayer de « scanner » ton réseau avec Angry IP pour vérifier l’IP du Rpi

++

Salut !
J’utilise également linux ne t’en fais pas… je suis etudiant en informatique :wink:
Sinon je viens d’essayer avec un autre PC et en effet ça a fonctionné, je vais regarder mais je pense que c’est la solution ! Merci à toi !

Alors petite mise à jours, je me rend compte que ça vient du pc car avec un autre je m’y connecte sans problème.
Il se trouve que sur le pc ou ça déconne j’ai 2 OS, j’ai donc tenté de switch sur Windows, mais sans résultats non plus.
Je ne trouve rien sur le net pour ce problème, je ne sais pas d’où ça pourrais venir…

Vérifie déjà que tu es sous le même sous réseau, moyen simple de savoir est par le IP, si les 3 premier segment sont identique; 192.168.0.xxx ou 10.0.0.xxx par exemple.

Après si même réseau, fait un ping; sous le pc vers le pi et pi vers pc. si tu as une réponse, il ce voit.

Sous windows; fait ceci pour « reset » le réseau.
En mode admin…
ipconfig /release *
Attend quelques secondes
ipconfig /renew *

Si tu n’est pas confortable avec les commandes sous Windows; voici un pack avec les commandes en .bat: Téléchargement - levelKro.net - Download of fix_network_allwin.zip

Ceci force une réactualisation IP et Gateway du PC.

J’ai déjà tenté ceci, mais je viens de me rendre compte qu’avec mon iPhone je n’ai pas accès non plus à mon serveur… ça voudrais dire que les appareils en wifi ne peuvent pas s’y connecter mais les appareils en ethernet si ?
Sachant que le rasp est en wifi……

Yo,

Le wifi est sur quel réseau ???
Comme dit @levelKro faut vérifier que tu n’as pas des sous-réseaux différents :wink:
Genre 192.168.0.0/24 pour le filaire et du 172.168.1.0/24 pour le Wifi :smiley:

Bonsoir, sur iPhone j’utilise iSH comme shell, ça depanne bien.Et pour un scan reseau Fing.

Ok petite mise à jours aujourd’hui, le problème venais de l’attribution d’ip, j’ai refais la méthode dhcp et ça fonctionne… cependant j’ai installé Pi-Hole sur mon rasp et je n’ai plus accès à mon interface box quand je met les dns pour pi hole… j’ai ajouté à la whitelist l’ip de la box mais rien…

Défini le IP en dur dans la box, associe ce ip a son mac address dans le pi hole (réservation dhcp).

Salut,

Comme dit par @levelKro , passe par attribution d’IP selon adresse Mac.
Toutes mes machines (nombreuses et variées) ont une IP fixée via ma FreeBox sur filtre adresse MAC ; ça limite les soucis.

Tu as quoi comme box ?
Mes PC ont des DNS différents de ceux de ma FreeBox et j’accède bien à son interface Web.
Tu changes juste tes DNS ou passerelle également ?

++

Merci pour vos réponses, je n’avais pas trop compris celle de @levelKro mais en fouillant j’ai trouvé ceci :
Je me suis rendu dans Local DNS et j’ai ajouté le domaine de la box et l’ip, et ça a fonctionné !