Connection canon selphy cp 1300

Bonjour, je suis sous ubuntu et je n’arrive pas a utiliser mon imprimante avec le pc ( wifi ): elle fonctionne avec le smartphone en wifi .Le transfert des données ne se fait pas et l’imprimante indique « occupe » puis "problème avec l’imprimante " .Quelqu’un a t il une solution ??? Merci…

hello,

peut être avec cups et gutenprint ( peut être en installant le paquet printer-driver-gutenprint ? )
ou par snap

source:
http://gimp-print.sourceforge.net/p_Supported_Printers.php

Bonjour .C’est déja fait : je voudrais savoir comment creer un point d’acces pour imprimer a partir du pc ??..

en créant un port ipp soit dans les fichiers de config soit via l interface web

source:
https://guide.ubuntu-fr.org/server/cups.html

Bonjour et merci bof, c’est un peu compliqué pour moi , tu peux m’aider ??? Merci…

J’ai installé cups par la boutique des snaps mais la transmission des données vers l’imprimante ne se fait pas …

as tu vérifier si cups était actif sur ton Rpi ?
ds un terminal:

sudo systemctl status cups

as tu vérifier l’existence d’un port ipp ?
netstat -ta

as tu réussi a déclarer ton imprimante sur le poste client ?

arrives tu a imprimer depuis le Rpi ?

Comme ma boule cristal est en panne, pour essayer de t’aider, je vais avoir besoin des réponses à ces questions :wink:

herbreteau@3-07ada05-lenovo:~$ sudo systemctl status cups
[sudo] Mot de passe de herbreteau :
● cups.service - CUPS Scheduler
Loaded: loaded (/lib/systemd/system/cups.service; enabled; vendor preset: >
Active: active (running) since Fri 2022-07-29 00:00:09 CEST; 17h ago
TriggeredBy: ● cups.path
● cups.socket
Docs: man:cupsd(8)
Main PID: 342814 (cupsd)
Tasks: 4 (limit: 6980)
Memory: 52.1M
CGroup: /system.slice/cups.service
├─342814 /usr/sbin/cupsd -l
├─361744 /usr/lib/cups/notifier/dbus dbus://
├─361749 /usr/lib/cups/notifier/dbus dbus://
└─361750 /usr/lib/cups/notifier/dbus dbus://

juil. 29 00:00:09 3-07ada05-lenovo systemd[1]: Started CUPS Scheduler.
lines 1-16/16 (END)

herbreteau@3-07ada05-lenovo:~$ netstat -ta

La commande « netstat » n’a pas été trouvée, mais peut être installée avec :

sudo apt install net-tools

Le pc reconnait l’imprimante…

C’est quoi le RPI ?..

erbreteau@3-07ada05-lenovo:~$ sudo apt install net-tools
[sudo] Mot de passe de herbreteau :
Lecture des listes de paquets… Fait
Construction de l’arbre des dépendances
Lecture des informations d’état… Fait
Les NOUVEAUX paquets suivants seront installés :
net-tools
0 mis à jour, 1 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 196 ko dans les archives.
Après cette opération, 864 ko d’espace disque supplémentaires seront utilisés.
Réception de :1 http://fr.archive.ubuntu.com/ubuntu focal/main amd64 net-tools amd64 1.60+git20180626.aebd88e-1ubuntu1 [196 kB]
196 ko réceptionnés en 1s (139 ko/s)
Sélection du paquet net-tools précédemment désélectionné.
(Lecture de la base de données… 211336 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de …/net-tools_1.60+git20180626.aebd88e-1ubuntu1_amd64.deb …
Dépaquetage de net-tools (1.60+git20180626.aebd88e-1ubuntu1) …
Paramétrage de net-tools (1.60+git20180626.aebd88e-1ubuntu1) …
Traitement des actions différées (« triggers ») pour man-db (2.9.1-1) …
herbreteau@3-07ada05-lenovo:~$

le Rpi c’est le Raspberry pi .
si tu n’arrives pas à imprimer depuis le Rpi ça peut être un problème de driver.

sur le Rpi ds /var/log/syslog tu peux vérifier si tu as un message; soit de cups soit d’un éventuelle blocage du firewall

sudo tail -f /var/log/syslog

a faire sur le Rpi pendant que tu lances une impression

ça doit pouvoir se faire a travers l’interface web en imprimant une page de test comme c’est expliqué par là :

Sur cette page " imprimer une page test fonctionne " http://localhost:631/printers/Canon_SELPHY_CP1300 mais si je crée une tache ça ne fonctionne pas …

c’est à dire ? en imprimant sur le Rpi a partir d’un éditeur de texte ou autres programmes avec une option d’impression ?

le tail -f /var/log/syslog il te donne pas d’info lors de l’impression ?

??? plus simplement si je veux imprimer une photo ?? Je l’ouvre avec shotwell et je fais imprimer : je choisis l’imprimante et je fais imprimer : la transmission des données vers l’imprimante ne se fait pas .

et ds le syslog t’as quelque chose ?

??? c’est quoi ça encore ???

avec l’interface web de cups (http://localhost:631) sous l’onglet administration ds la partie server tu trouves access.log error.log c’est la que tu peux avoir des infos sur les raisons des erreurs