Comment mettre à jours Stretch vers Buster SVP ?

Bonjour à tou(te)s.

Tout est dit dans le titre. J’ai vue que la version de Raspbian Buster était sortie, et j’aimerais beaucoup l’installer sur mon merveilleux Raspberry Pi 3B+.

J’ai tapé :

sudo apt-get update && sudo apt-get upgrade

Tout était à jours, ensuite, j’ai tapé :

apt-get dist-upgrade

Et là, rien du tout, il me dit que la version que j’ai est déjà à jours, alors que je suis toujours sous Stretch.

Que faire de plus SVP ?

Merci d’avance et à bientôt.

Salut,

Je fais partie des gens qui préfèrent réaliser des installations fraiches et complètes.

Mais, tu devrais pouvoir faire le faire.

  1. Tout sauvegarder et faire copie de ta carte SD (et vérifier qu’elle fonctionne)
  2. Modifier la liste des dépôts/sources en changeant “stretch” par “buster”
  3. Puis sudo apt-get update
  4. Puis sudo apt-get upgrade
  5. Puis sudo apt-get dist-upgrade
  6. Puis sudo apt full-upgrade

Cette procédure n’est pas testée par moi ni validée (car non testée et car je n’ai pas les compétences) ; je partage juste une idée.

++

Je débute avec le Raspi, tu peux m’expliquer comment on fait ça STP ?

Hello,

Réponse “idiote” :
Il suffit de modifier le fichier /etc/apt/sources.list

Réponse dans la culture de l’apprenant :
Je suis partisan du “ne pas dire quoi faire” afin d’obtenir une expérience amenant une acquisition de connaissance.
Dans cette optique, je pense que cette lecture pourrait être utile pour comprendre le principe :
https://wiki.debian.org/fr/SourcesList

Ceci n’est pas contre toi, mais pour t’aider à asseoir une réussite sur des connaissances :wink:

On pourra évidemment en reparler !

++

Édit :
J’avais réinstallé Stretch pour vérifier un de mes tuto pour un internaute il y a qq jours.
Du coup, je teste de voir si ça casse tout ou pas.

Édit 2 :
Je viens de passer de Stretch à Buster sans souci apparent … sauf au redémarrage ; session graphique défectueuse.
Je suis bien en Buster car cat /etc/debian_version me répond 10.0
Bon, je lance des sudo apt autoremove et sudo apt-get full upgrade (et compagnie) pour voir …
ça va prendre du temps.

Si tu débutes et si tu n’as pas besoin de migrer réellement, soit tu restes à Stretch soit tu fais une installation en repartant de l’image.

A noter aussi que, en informatique, il n’est pas recommandé de mettre à jour sur le dernier système si tout fonctionne bien et si le système en place est encore maintenu (en gros, on ne change pas une équipe qui gagne)

Je laisse tourner … ça bosse dure, mais ça n’avance pas vite …

Édit 3 :
Je confirme :
Soit tu restes à Stretch si tu as des trucs qui tournent et doivent continuer à tourner (mon système de vidéosurveillance reste sous Stretch pour le moment par nécessité)
Soit tu réalises une installation de Buster à partir de l’image dispo sur raspberrypi.org
Pourquoi ?
Je me retrouve avec un raspbian en mode console car le serveur Xorg est détruit et sa réinstallation n’a pas arrangé le truc.
Je doute que les joyeuses lignes de commandes que je vais devoir taper pour tenter de réparer la chose ne te donnent envie :slight_smile:

Merci pour vos réponses.

Je pense que je vais rester sous Stretch du coup, j’ai installé PiHole, et honnêtement, ça c’était pas très bien passé, j’ai eu beaucoup de mal à le faire fonctionner, du coup, je prend pas de risques inutiles.

Merci beaucoup, et à bientôt.

Yo,
D’autant que pour ma part, les tentatives de réparations diverses sont restées des échecs.
Je vais formater :slight_smile: (je ne vais rien perdre puisque j’ai accès à tout en mode console et en ssh).
Tu pourras tenter d’installer Buster sur un autre carte SD puis installer PiHole.
Si tout fonctionne, tu pourras alors te passer de ta carte “Stretch”.
++

Bonne idée, merci. Je n’avais pas pensé à cette option.