Scan RFID ne reconnait aucun tag

Salut la communauté,

J’essaye un petit projet qui semble classique dans le monde des Pi : connecté une carte RFID RC522.

Il y a visiblement énormément de ressource sur le web, mais je suis partie sur un article plutôt clair et idéalement pas trop vieux : https://pimylifeup.com/raspberry-pi-rfid-rc522/

Tout se passe plutôt bien. Cependant, l’étape pour écrire le tag n’aboutit pas car il n’est tout simplement pas détecté : je reste bloqué sur Now place your tag to write .

J’ai essayé plusieurs méthode, dont une avec NodeJS (qui utilise python en arrière plan) ainsi que celui de raspi-france mais j’ai le même résultat. Dans le doute, j’ai testé 2 carte RFID avec 2 badges différents, mais c’est pareil pour les deux.

J’ai également essayé ce tutoriel, mais le résultat est très étrange : il indique Card detected en doucle, sans rien affiché.

J’imagine que j’ai forcément merdé quelque part. Niveau branchement, j’ai reprit celui des tutoriels. Je me demande si c’est pas ma soudure qui serait naze ? :confused:

Si quelqu’un a une idée d’où j’aurai pu merder, je vous remercie :)

Pour information, j’utilise une système Raspbian à jour et mes tests sont effectués sur un Pi 2 model B.

Bon dimanche à vous et merci beaucoup !

hello,

pour être sur que tes soudures sont correctes ( par exemple qu’il n’y ait pas deux pins en contact ) tu peux tester la continuité du signal avec un voltmètre ( la fonction résistance ( ohm ) ) .
en vérifiant que pour une pin donnée, ses voisines ne communiquent sur la même « ligne » qu’elle.

arrives tu à lire un badge ?

Hello Bof,

Merci pour ton message.

Justement non je n’arrive à lire aucun badge, rien n’est détecté ^^

Je vais voir pour héberger des photos, j’ai pas les droits pour en upload ici, peut-être que ça serait plus parlant :slight_smile:

Édit : voici une photo du montage

peut être avec ces tutos :
https://raspberry-pi.fr/rfid-raspberry-pi/
ou celui la
https://www.gotronic.fr/pj2-sbc-rfid-rc522-fr-1439.pdf

j’imagine que t’as activé le SPI ds raspi-config ! pour vérifier:

ls -l /dev/spi*
crw-rw---- 1 root spi 153, 0 août   3 14:51 /dev/spidev0.0
crw-rw---- 1 root spi 153, 1 août   3 14:51 /dev/spidev0.1

Même résultat avec les deux tutoriels (j’ai addapté le premier sans led pour uniquement lire un badge).

Pour le SPI, je te confirme qu’il est activé et me retourne le même résultat que toi. Cette commande indique que la carte RFID est bien détectée ?

image

Hello hello.

C’était bien une mauvaise soudure ! J’ai refait de manière plus propre sur une nouvelle carte et tout est bien détecté, excepté la puce de mes chats (qui était l’objectif :joy:)

Merci pour ton aide :slight_smile:

si j’en crois cette page : https://fr.wikipedia.org/wiki/Radio-identification la fréquence du module rfid 522 est 13,56 Mhz et celle des puce sous cutanées pour les animaux serait 120–150 kHz.
en recherchant ds google shopping avec « rfid lecteur puce sous cutanée » on trouve des modules mais sans connaître la fréquence exacte de la puce de tes chats ça risque d’ être compliqué … sans parler du montage sur rapsberry…

Yes éffectivement je me suis très mal renseigné sur le fréquence avant d’acheter la carte :smiley:

Mais du coup de ce que j’ai pu lire, c’est pas évident avec un raspberry. C’est assez surprenant ^^