[RÉSOLU] Lancement script au démarrage mais avec input

Arf

sudo nano /etc/xdg/lxsession/LXDE-pi/autostart

@lxpanel --profile LXDE-pi
@pcmanfm --desktop --profile LXDE-pi
@xscreensaver -no-splash
point-rpi
@lxterminal --command="./script.py"

J’avais zappé la fermeture ; je m’occupe d’un pb de banque de ma fille ainée ; pas concentré :smiley:

Mieux ?

Ahah malheureusement pour moi j’avais déjà rajouté la fermeture… :sweat_smile::sweat_smile:

sudo nano /etc/xdg/lxsession/LXDE-pi/autostart

@lxpanel --profile LXDE-pi
@pcmanfm --desktop --profile LXDE-pi
@xscreensaver -no-splash
point-rpi
@lxterminal --command="python /home/pi/script.py"

Je file à la banque ; au pire, je tente sur mon Rpi en rentrant
C’est quoi ton code exact ; je ferai le même.

++

import RPLCD as RPLCD
import time
from RPLCD.gpio import CharLCD
import RPi.GPIO as GPIO
GPIO.setwarnings(False)

GPIO.setmode(GPIO.BCM)

#numbering_mode=GPIO.BOARD

lcd = CharLCD(cols=16, rows=2, pin_rs=26, pin_e=19, pins_data=[13, 6, 5, 11],numbering_mode=GPIO.BCM)
lcd.cursor_pos = (1, 0)
lcd.write_string(“Hellllllo world!”)
time.sleep(2)
lcd.clear()
time.sleep(1)

C’est bon
trouvé !

sudo nano /etc/xdg/lxsession/LXDE-pi/autostart

@lxpanel --profile LXDE-pi
@pcmanfm --desktop --profile LXDE-pi
@xscreensaver -no-splash
@lxterminal -e /usr/bin/python3.5 /home/pi/script-nabla.py
point-rpi

sudo nano /home/pi/script-nabla.py

#!/usr/bin/python3
# -*- coding: utf-8 -*
import time

time.sleep(1)
print("Es fonktionniert")
time.sleep(3)
print("C'est Nabla le meilleur")
time.sleep(3)
print("Es fonktionniert")
time.sleep(3)
print("C'est Nabla le meilleur")
time.sleep(3)
print("Es fonktionniert")
time.sleep(3)
print("C'est Nabla le meilleur")
time.sleep(3)
print("Es fonktionniert")
time.sleep(3)
print("C'est Nabla le meilleur")

C’ets bon ?

(ça reste affiché QUE si le script tourne donc j’ai mis des pauses)

Chez moi, ça tourne sans souci avec mon script.
Le tien ne fait qu’une apparition fugace et disparait.

Parfait, cela marche! merci beaucoup!!
Pour info cela ne marchait pas avec : sudo nano /etc/xdg/lxsession/LXDE-pi/autostart

Mais avec

sudo nano /home/pi/.config/lxsession/LXDE-pi/autostart

Je te remercie pour ton aide précieuse :slightly_smiling_face:

Ho la vache, si tu utilises sudo nano /home/pi/.config/lxsession/LXDE-pi/autostart pour éditer le fichier, c’est que tu es sur un vieux système !
Depuis modification de Stretch, il faut maintenant faire : sudo nano /etc/xdg/lxsession/LXDE-pi/autostart

Tu es sur un vieux Stretch d’il y a un an je pense.

La commande cat /etc/debian_version te renvoit quoi ?

C’est un RPI 3 B+ pourtant…

je vais essayer ça !

ça dépend de la version de Rasbian installée ; pas de la version du Rpi :slight_smile:

Si tu achètes un PC en Core i7 avec 32 Go de Ram et un SSD de Haute vélocité, mais que tu installes Windows 3.11 (comme celui que j’ai utilisé à mes débuts) … Ben … Tu auras un “putain” de PC, mais tu resteras dans les anciens temps avec ses limitations :wink:
(Comme je me sens en forme pour les images à la xxx = c’ets comme avoir une lamborghini mais rouler sur une rocade limitée à 70 km/h au lieu d’aller sur un circuit ; oui, c’est “rond”, oui, tu as la voiture qu’il faut … mais …)