Owncloud rasbian impossible

Hello tout le monde, je me mange beaucoup beaucoup de tuto en ce moment et je cherche a mettre en place un cloud online.
Je suis donc les tuto Owncloud.
Cependant quelque soit le tuto moi je suis bloqué a cela :

    pi@raspberrypi:~ $ sudo apt-get install owncloud
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation : 

Les paquets suivants contiennent des dépendances non satisfaites :
 owncloud : Dépend: libjs-jcrop mais il n'est pas installable
            Dépend: libjs-jquery-minicolors (< 2~) mais ne sera pas installé
            Dépend: php-assetic mais ne sera pas installé
            Dépend: php-doctrine-dbal (< 2.5) mais 2.9.2-1 devra être installé
            Dépend: php-opencloud mais il n'est pas installable
            Dépend: php-pimple (< 2) mais ne sera pas installé
            Dépend: php5 (>= 5.3.8) mais il n'est pas installable
            Dépend: php5-cli mais il n'est pas installable
            Dépend: php5-gd mais il n'est pas installable
            Dépend: php5-json mais il n'est pas installable
            Dépend: php5-mysql mais il n'est pas installable ou
                     php5-pgsql mais il n'est pas installable ou
                     php5-sqlite mais il n'est pas installable
            Recommande: exim4 mais ne sera pas installé ou
                        mail-transport-agent
            Recommande: php-aws-sdk (< 3) mais ne sera pas installé
            Recommande: php-crypt-blowfish (>= 1.1.0~RC2-2~) mais ne sera pas installé
            Recommande: php-dropbox mais ne sera pas installé
            Recommande: php-google-api-php-client (< 1) mais ne sera pas installé
            Recommande: php5-apcu mais il n'est pas installable ou
                        php5-xcache mais il n'est pas installable
            Recommande: php5-curl mais il n'est pas installable
            Recommande: php5-imap mais il n'est pas installable
            Recommande: php5-intl mais il n'est pas installable
            Recommande: php5-ldap mais il n'est pas installable
            Recommande: php5-mcrypt mais il n'est pas installable
            Recommande: smbclient mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

Voila alors si a partir de là quelqu’un peut m’aider ca serait chouette.
Merci par avance a tous.

hello,

tu n’as pas du installer le dépôt qui fonctionne avec buster si j’en crois ce tuto ( il utilise un Rpi3 mais ça doit marché aussi sur Rpi4) :

le Owncloud des dépôts par défaut est : 7.0.13~dfsg-1 alors que dans ce tuto il propose la version 10.3.2
le php doit être 7.3 et mariadb 10.3 ( enfin si je me rappelle bien :roll_eyes: )

Avec ce tuto j’ai ete beaucoup plus loin mais arrivé " Configuration du vhost"
la je sais pas mon raspberry me stipule sur cette commande
sudo touch /etc/nginx/sites-available/owncloud.conf
impossible de faire touch ^^^
Pourquoi n’y a t’il pas quelque chose de simple juste a installer parametrer et banzai :slight_smile:

bizarre « touch » doit faire partie des programmes installés d’origine … tu es sur que ton install de nginx c’est bien passée ?
ls -l /etc/nginx/sites-available
s’il te sort encore une erreur reinstall nginx

vaste question ! mais il y a 15/20 ans tu aurais du compiler les programmes toi même, voir recompiler le kernel; on oublie souvent que l’informatique est encore une technique récente ! ( 80 ans la préhistoire, 40 ans les début de l’informatique personnelle, 30 ans création de linux )
en fait t’es une sorte de pionnier mec :wink:

Bonjour @spouns ,

Au pire utilises nano ou vi pour la modification de contenu, il se peut que touch ne soit pas dans les programmes d’origine de l’os que tu as installé (NOOBS, RASPBIAN, …).

Salut,

Désolé, je n’ai pas réalisé une lecture du fil de discussion complet.
Solution de coutournement de ton souci :wink:

J’ai un Nextcloud qui tourne sur un Rpi de manière extrêmement simpliste grâce à yunohost.
Tu télécharges l’image de YunoHost (une debian orientée auto-hébergement) puis tu installes ce que tu veux avoir (là, je suis reparti à zéro avec juste Nextcloud).

Et tu peux avoir un domaine gratuit chez eux ou carrément un domaine à toi.
Je t’encourage à aller visiter leur site.

A noter que ça tourne chez moi, sur un Rpi3B+ mais aussi sur une mini-machine de récupération du style client léger (afin de faire des tests).

@+

Liens :

https://yunohost.org

La page wikipedia à leur sujet

J’ai installé Rasbian disponible directement sur la plateforme « https://www.raspberrypi.org/downloads/raspbian/ » le plus complet directement j’ai la place :wink:

Merci Bof je vais voir cela directement demain j’aurais plus de temps

Nabla, merci de ta proposition au pire des cas je me tournerais vers cela, mais j’ai bien aller jusqu’au bout de mes problemes ca permets de comprendre d’ou vient mon erreur :wink: la perseverance est mon villain defaut ^^

Je serais plus tétu que le pinguin ^^

Heu … Nabla, il va réagir.
Il ne peut même pas essayer de faire mine de ne pas le faire. :stuck_out_tongue_winking_eye:

–> « Serai » sans « s » pour le futur, sinon, c’est du conditionnel (oui, je suis chiant)

–> Et « Manchot », pas « Pingouin » en Français.
Le manchot (qui se dit « Penguin » en Anglais) vit au Pôle Sud (Austral), alors que le Pingouin (« Auk » en Anglais, je crois) vit dans l’hémisphère Nord.
Deux animaux de familles différentes.
(oui, je suis TRÈS Chiant)

Oui, Oui, … Je sors … :yum: